aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2022-02-15 08:44:53 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2022-02-15 08:45:55 +0000
commit48e775bf887c39a5651b6936cf5e4d66a25a8568 (patch)
tree02ba814112a33ba32a219e7471f9277bc18fcd5d
parentd8dce10529a61543d66fc26a59fb9205df55558e (diff)
downloadports-48e775bf887c39a5651b6936cf5e4d66a25a8568.tar.gz
ports-48e775bf887c39a5651b6936cf5e4d66a25a8568.zip
security/ssh-tools: Add a new port
ssh-tools is a collection of scripts, which aims to make the use of SSH more convenient. The scripts are mostly wrappers around one-liners users write manually when necessary. WWW: https://github.com/vaporup/ssh-tools
-rw-r--r--security/Makefile1
-rw-r--r--security/ssh-tools/Makefile26
-rw-r--r--security/ssh-tools/distinfo3
-rw-r--r--security/ssh-tools/pkg-descr6
-rw-r--r--security/ssh-tools/pkg-plist8
5 files changed, 44 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 4be2e021d567..cc4da23540fd 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -1244,6 +1244,7 @@
SUBDIR += ssb
SUBDIR += ssdeep
SUBDIR += ssh-multiadd
+ SUBDIR += ssh-tools
SUBDIR += ssh-vault
SUBDIR += sshguard
SUBDIR += sshpass
diff --git a/security/ssh-tools/Makefile b/security/ssh-tools/Makefile
new file mode 100644
index 000000000000..89a7b1e60a8e
--- /dev/null
+++ b/security/ssh-tools/Makefile
@@ -0,0 +1,26 @@
+PORTNAME= ssh-tools
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.7
+CATEGORIES= security
+
+MAINTAINER= 0mp@FreeBSD.org
+COMMENT= CLI tools that make SSH more convenient
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= bash:shells/bash
+
+USES= perl5 shebangfix
+USE_GITHUB= yes
+GH_ACCOUNT= vaporup
+USE_PERL5= run
+SHEBANG_FILES= ssh-*
+
+NO_ARCH= yes
+NO_BUILD= yes
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/ssh-* ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/security/ssh-tools/distinfo b/security/ssh-tools/distinfo
new file mode 100644
index 000000000000..a35cdf5f7136
--- /dev/null
+++ b/security/ssh-tools/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1644914046
+SHA256 (vaporup-ssh-tools-v1.7_GH0.tar.gz) = c96dd7d4630dff0afdce597e0d254abc2a5ae87d3c3ba6e83af952713db6c961
+SIZE (vaporup-ssh-tools-v1.7_GH0.tar.gz) = 29213
diff --git a/security/ssh-tools/pkg-descr b/security/ssh-tools/pkg-descr
new file mode 100644
index 000000000000..14f5b26e3bf7
--- /dev/null
+++ b/security/ssh-tools/pkg-descr
@@ -0,0 +1,6 @@
+ssh-tools is a collection of scripts, which aims
+to make the use of SSH more convenient. The scripts
+are mostly wrappers around one-liners users write
+manually when necessary.
+
+WWW: https://github.com/vaporup/ssh-tools
diff --git a/security/ssh-tools/pkg-plist b/security/ssh-tools/pkg-plist
new file mode 100644
index 000000000000..3713eb392c23
--- /dev/null
+++ b/security/ssh-tools/pkg-plist
@@ -0,0 +1,8 @@
+bin/ssh-certinfo
+bin/ssh-diff
+bin/ssh-facts
+bin/ssh-force-password
+bin/ssh-hostkeys
+bin/ssh-keyinfo
+bin/ssh-ping
+bin/ssh-version