aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2021-08-16 14:30:05 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2021-08-16 14:30:40 +0000
commit49251745baf82c2adb3d2b35d5e00564cd2b01d2 (patch)
treeb8c2a703a7b0fb1fc5a973456b75e831f057440a
parentb7cbb62f6ab60fc116b1c12c0e4af580fb2de641 (diff)
downloadports-49251745baf82c2adb3d2b35d5e00564cd2b01d2.tar.gz
ports-49251745baf82c2adb3d2b35d5e00564cd2b01d2.zip
devel/py-types-xxhash: new port: Typing stubs for xxhash
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-types-xxhash/Makefile16
-rw-r--r--devel/py-types-xxhash/distinfo3
-rw-r--r--devel/py-types-xxhash/pkg-descr5
4 files changed, 25 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index af7b2db6aa41..2394e612d79b 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5236,6 +5236,7 @@
SUBDIR += py-types-futures
SUBDIR += py-types-protobuf
SUBDIR += py-types-requests
+ SUBDIR += py-types-xxhash
SUBDIR += py-typing-extensions
SUBDIR += py-typing-inspect
SUBDIR += py-tzlocal
diff --git a/devel/py-types-xxhash/Makefile b/devel/py-types-xxhash/Makefile
new file mode 100644
index 000000000000..09793a62bf18
--- /dev/null
+++ b/devel/py-types-xxhash/Makefile
@@ -0,0 +1,16 @@
+PORTNAME= types-xxhash
+PORTVERSION= 2.0.0
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Typing stubs for xxhash
+
+LICENSE= APACHE20
+
+USES= python
+USE_PYTHON= autoplist distutils
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-types-xxhash/distinfo b/devel/py-types-xxhash/distinfo
new file mode 100644
index 000000000000..99f73db6424b
--- /dev/null
+++ b/devel/py-types-xxhash/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1629124049
+SHA256 (types-xxhash-2.0.0.tar.gz) = a09c31747cedea9793a273be717dfc9c43cfa7f4e5732c3412b265e493f8de78
+SIZE (types-xxhash-2.0.0.tar.gz) = 1838
diff --git a/devel/py-types-xxhash/pkg-descr b/devel/py-types-xxhash/pkg-descr
new file mode 100644
index 000000000000..a7078d720587
--- /dev/null
+++ b/devel/py-types-xxhash/pkg-descr
@@ -0,0 +1,5 @@
+This is an auto-generated PEP 561 type stub package for xxhash
+package. It can be used by type-checking tools like mypy, PyCharm,
+pytype etc. to check code that uses xxhash.
+
+WWW: https://pypi.org/project/types-xxhash/