aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@fuz.su>2022-02-14 05:23:17 +0000
committerGuangyuan Yang <ygy@FreeBSD.org>2022-02-14 05:23:17 +0000
commit4931bb0fd929c4b9aa3501dfca4ac14bb5c6e764 (patch)
tree4a4b57d70b23a5a08258a12525fe31bf40814e39
parent2365b4042523751992c423ffdff4dba0f31ff664 (diff)
downloadports-4931bb0fd929c4b9aa3501dfca4ac14bb5c6e764.tar.gz
ports-4931bb0fd929c4b9aa3501dfca4ac14bb5c6e764.zip
games/stonesoup: Update to 0.28.0
-rw-r--r--games/stonesoup/Makefile15
-rw-r--r--games/stonesoup/distinfo6
-rw-r--r--games/stonesoup/files/patch-Makefile8
-rw-r--r--games/stonesoup/files/patch-initfile.cc6
-rw-r--r--games/stonesoup/files/patch-util_gen__ver.pl12
-rw-r--r--games/stonesoup/pkg-plist7
6 files changed, 30 insertions, 24 deletions
diff --git a/games/stonesoup/Makefile b/games/stonesoup/Makefile
index 753616776a4a..07653cdc7ab1 100644
--- a/games/stonesoup/Makefile
+++ b/games/stonesoup/Makefile
@@ -1,7 +1,7 @@
# Created by: Tobias Rehbein <tobias.rehbein@web.de>
PORTNAME= stonesoup
-PORTVERSION= 0.27.1
+DISTVERSION= 0.28.0
CATEGORIES= games
MAINTAINER= fuz@fuz.su
@@ -59,7 +59,6 @@ OPTIONS_DEFINE= LUA NOWIZARD SOUND
OPTIONS_DEFAULT=LUA
OPTIONS_SUB= yes
-SOUND_DESC= Sound support
NOWIZARD_DESC= Disable Wizard mode
LUA_DESC= Bindings for LUA user scripts
@@ -69,21 +68,21 @@ USE_SDL= sdl2 image2 mixer2
USE_GL= gl glu
MAKE_ARGS+= TILES=y SOUND=y
BUILD_DEPENDS+= \
- advpng:archivers/advancecomp \
fc-list:x11-fonts/fontconfig \
- ${LOCALBASE}/share/fonts/dejavu/DejaVuSans.ttf:x11-fonts/dejavu \
- pngcrush:graphics/pngcrush
+ ${LOCALBASE}/share/fonts/dejavu/DejaVuSans.ttf:x11-fonts/dejavu
RUN_DEPENDS+= ${LOCALBASE}/share/fonts/dejavu/DejaVuSans.ttf:x11-fonts/dejavu
LIB_DEPENDS+=libpng.so:graphics/png \
libfreetype.so:print/freetype2
DESKTOP_ENTRIES= "Dungeon Crawl Stone Soup" "${COMMENT}" "${DATADIR}/dat/tiles/stone_soup_icon-512x512.png" "${GAME}" "Game;" false
.else
USES+= ncurses
+OPTIONS_DEFINE+= SOUND
+SOUND_DESC= Sound support
+SOUND_MAKE_ARGS= SOUND=y
+SOUND_RUN_DEPENDS= sox:audio/sox
.endif
NOWIZARD_MAKE_ARGS= NOWIZARD=y
-SOUND_MAKE_ARGS= SOUND=y
-SOUND_RUN_DEPENDS= sox:audio/sox
LUA_MAKE_ARGS_OFF= NO_LUA_BINDINGS=yes
post-patch-SOUND-on:
@@ -94,7 +93,7 @@ post-patch-SOUND-off:
@${REINPLACE_CMD} -e "s,%%SOUND%%,// ," ${WRKSRC}/sound.h
pre-build:
- @${ECHO} ${PORTVERSION} > ${WRKSRC}/util/release_ver
+ @${ECHO} ${PKGVERSION} > ${WRKSRC}/util/release_ver
pre-install:
@${FIND} ${WRKSRC}/dat -type f -name '*.orig' -delete
diff --git a/games/stonesoup/distinfo b/games/stonesoup/distinfo
index 0d0828583544..198f66cc20b7 100644
--- a/games/stonesoup/distinfo
+++ b/games/stonesoup/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1635418020
-SHA256 (crawl-crawl-0.27.1_GH0.tar.gz) = 062f1285852fced23ecb2f272ad132467e12e7e251e02aaa84f37280b55ba63e
-SIZE (crawl-crawl-0.27.1_GH0.tar.gz) = 14647180
+TIMESTAMP = 1644677272
+SHA256 (crawl-crawl-0.28.0_GH0.tar.gz) = 287f35476d20bbe8aaa3e663140704462b4e304a4e1ed5c2b5da1d273dd1f383
+SIZE (crawl-crawl-0.28.0_GH0.tar.gz) = 16311050
diff --git a/games/stonesoup/files/patch-Makefile b/games/stonesoup/files/patch-Makefile
index 665a1f7b4ffb..a46e350c3247 100644
--- a/games/stonesoup/files/patch-Makefile
+++ b/games/stonesoup/files/patch-Makefile
@@ -1,4 +1,4 @@
---- Makefile.orig 2021-08-20 10:45:00 UTC
+--- Makefile.orig 2022-01-25 18:04:53 UTC
+++ Makefile
@@ -131,7 +131,7 @@ include Makefile.obj
# Which C++ standard to support
@@ -20,7 +20,7 @@
#
# The GCC and GXX variables are set later.
#
-@@ -503,7 +499,7 @@ endif
+@@ -505,7 +501,7 @@ endif
# Attempt to use a full compiler name, to make
# distcc builds work nicely.
@@ -29,7 +29,7 @@
ifeq ($(LMACH),-)
LMACH :=
endif
-@@ -549,15 +545,6 @@ ifdef USE_ICC
+@@ -551,15 +547,6 @@ ifdef USE_ICC
# Some very good optimization flags.
CFOPTIMIZE := -O2 -parallel
@@ -45,7 +45,7 @@
endif
# Define this to automatically generate code optimized for your machine
-@@ -858,7 +845,7 @@ ifndef NOWIZARD
+@@ -860,7 +847,7 @@ ifndef NOWIZARD
DEFINES += -DWIZARD
endif
ifdef NO_OPTIMIZE
diff --git a/games/stonesoup/files/patch-initfile.cc b/games/stonesoup/files/patch-initfile.cc
index d7dc37e77ca9..35acdc8f0c34 100644
--- a/games/stonesoup/files/patch-initfile.cc
+++ b/games/stonesoup/files/patch-initfile.cc
@@ -1,6 +1,6 @@
---- initfile.cc.orig 2021-08-20 10:45:00 UTC
+--- initfile.cc.orig 2022-01-25 18:04:53 UTC
+++ initfile.cc
-@@ -4529,7 +4529,7 @@ static void _bones_rewrite(const string filename, cons
+@@ -4795,7 +4795,7 @@ static void _bones_rewrite(const string filename, cons
if (dups)
cout << ", " << dups << " duplicates removed";
cout << "\n";
@@ -9,7 +9,7 @@
_write_bones(filename, out);
}
else
-@@ -4554,7 +4554,7 @@ static void _bones_merge(const vector<string> files, c
+@@ -4820,7 +4820,7 @@ static void _bones_merge(const vector<string> files, c
break;
}
if (file_exists(out_name))
diff --git a/games/stonesoup/files/patch-util_gen__ver.pl b/games/stonesoup/files/patch-util_gen__ver.pl
index 862c1d12e961..8acfe5f44189 100644
--- a/games/stonesoup/files/patch-util_gen__ver.pl
+++ b/games/stonesoup/files/patch-util_gen__ver.pl
@@ -1,12 +1,12 @@
---- util/gen_ver.pl.orig 2021-10-28 09:37:07 UTC
+--- util/gen_ver.pl.orig 2022-01-25 18:04:53 UTC
+++ util/gen_ver.pl
-@@ -13,8 +13,7 @@ $mergebase or $mergebase = "";
-
- mkdir dirname($outfile);
-
+@@ -20,8 +20,7 @@ mkdir dirname($outfile);
+ #
+ # Source tarbells distributed as part of a release include this file already
+ # generated with the release version.
-$_ = `git describe --tags $mergebase 2> /dev/null`
- || (open(IN, "<", "$scriptpath/release_ver") ? <IN>
+$_ = (open(IN, "<", "$scriptpath/release_ver") ? <IN>
- : die "No Git, and $scriptpath/release_ver doesn't exist.\n")
+ : die "Can't get version information: `git describe --tags` failed (no git, no repository, or shallow clone), and $scriptpath/release_ver doesn't exist.\n")
or die "couldn't get the version information\n";
diff --git a/games/stonesoup/pkg-plist b/games/stonesoup/pkg-plist
index e0b25f7bb257..3505c0932d8c 100644
--- a/games/stonesoup/pkg-plist
+++ b/games/stonesoup/pkg-plist
@@ -57,7 +57,9 @@ bin/%%GAME%%
%%DATADIR%%/dat/des/branches/dis.des
%%DATADIR%%/dat/des/branches/elf.des
%%DATADIR%%/dat/des/branches/geh.des
+%%DATADIR%%/dat/des/branches/geh_lava_maze.des
%%DATADIR%%/dat/des/branches/hell.des
+%%DATADIR%%/dat/des/branches/hells.des
%%DATADIR%%/dat/des/branches/hilbert_zone.des
%%DATADIR%%/dat/des/branches/lair.des
%%DATADIR%%/dat/des/branches/orc.des
@@ -102,6 +104,7 @@ bin/%%GAME%%
%%DATADIR%%/dat/des/builder/shops.des
%%DATADIR%%/dat/des/builder/uniques.des
%%DATADIR%%/dat/des/guide.txt
+%%DATADIR%%/dat/des/portals/arena.des
%%DATADIR%%/dat/des/portals/bailey.des
%%DATADIR%%/dat/des/portals/bazaar.des
%%DATADIR%%/dat/des/portals/desolation.des
@@ -127,6 +130,7 @@ bin/%%GAME%%
%%DATADIR%%/dat/des/serial/rivers.des
%%DATADIR%%/dat/des/serial/serial_guide.txt
%%DATADIR%%/dat/des/serial/sigils.des
+%%DATADIR%%/dat/des/serial/subway.des
%%DATADIR%%/dat/des/serial/undead.des
%%DATADIR%%/dat/des/serial/window.des
%%DATADIR%%/dat/des/sprint/arena_sprint.des
@@ -347,6 +351,7 @@ bin/%%GAME%%
%%DATADIR%%/dat/descript/lv/unident.txt
%%DATADIR%%/dat/descript/lv/unrand.txt
%%DATADIR%%/dat/descript/monsters.txt
+%%DATADIR%%/dat/descript/mutations.txt
%%DATADIR%%/dat/descript/nl/ability.txt
%%DATADIR%%/dat/descript/nl/tutorial.txt
%%DATADIR%%/dat/descript/nl/unident.txt
@@ -640,6 +645,8 @@ bin/%%GAME%%
%%SDL%%%%DATADIR%%/dat/tiles/title_froggy_natasha_and_boris.png
%%SDL%%%%DATADIR%%/dat/tiles/title_froggy_rune_and_run_failed_on_dis.png
%%SDL%%%%DATADIR%%/dat/tiles/title_froggy_thunder_fist_nikola.png
+%%SDL%%%%DATADIR%%/dat/tiles/title_kaonedong_ignis_the_dying_flame.png
+%%SDL%%%%DATADIR%%/dat/tiles/title_kaonedong_menkaure_prince_of_dust.png
%%SDL%%%%DATADIR%%/dat/tiles/title_nibiki_octopode.png
%%SDL%%%%DATADIR%%/dat/tiles/title_omndra_zot_demon.png
%%SDL%%%%DATADIR%%/dat/tiles/title_peileppe_bloax_eye.png