aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-06-23 17:31:33 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-06-23 18:13:35 +0000
commit494d86231d8dd3ceae7302676e5ff195d850510e (patch)
tree5840d610fccf46c09616d71582e041e7eb2833ad
parentf2820b6cc2170feef17989c422f2cf46644a5b57 (diff)
downloadports-494d86231d8dd3ceae7302676e5ff195d850510e.tar.gz
ports-494d86231d8dd3ceae7302676e5ff195d850510e.zip
x11-toolkits/wlroots: expose Vulkan renderer
Example usage: $ WLR_RENDERER=vulkan sway
-rw-r--r--x11-toolkits/wlroots/Makefile45
1 files changed, 43 insertions, 2 deletions
diff --git a/x11-toolkits/wlroots/Makefile b/x11-toolkits/wlroots/Makefile
index dcb789f0f170..cd4304611c4b 100644
--- a/x11-toolkits/wlroots/Makefile
+++ b/x11-toolkits/wlroots/Makefile
@@ -1,5 +1,6 @@
PORTNAME= wlroots
DISTVERSION= 0.14.0
+PORTREVISION= 1
CATEGORIES= x11-toolkits
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
@@ -31,8 +32,8 @@ USE_LDCONFIG= yes
GH_ACCOUNT= swaywm
MESON_ARGS= -Dexamples=false -Drenderers=${RENDERERS:ts,}
-OPTIONS_DEFINE= NVIDIA OPENGL X11
-OPTIONS_DEFAULT=OPENGL X11
+OPTIONS_DEFINE= NVIDIA OPENGL VULKAN X11
+OPTIONS_DEFAULT=OPENGL VULKAN X11
OPTIONS_SUB= yes
NVIDIA_DESC= EGLStreams support for DRM backend (experimental)
@@ -47,6 +48,46 @@ OPENGL_RUN_DEPENDS= mesa-dri>0:graphics/mesa-dri
OPENGL_USE= GL=egl,glesv2
OPENGL_VARS= RENDERERS+=gles2
+VULKAN_DESC= Vulkan renderer (experimental)
+VULKAN_PATCHFILES+= 8c700c534556.patch:-p1 # https://github.com/swaywm/wlroots/pull/2771
+VULKAN_PATCHFILES+= 0464af8573f9.patch:-p1 # https://github.com/swaywm/wlroots/pull/2771
+VULKAN_PATCHFILES+= e3e9250ea6d8.patch:-p1 # https://github.com/swaywm/wlroots/pull/2771
+VULKAN_PATCHFILES+= 1af1d1694195.patch:-p1 # https://github.com/swaywm/wlroots/pull/2771
+VULKAN_PATCHFILES+= 93319aa2b633.patch:-p1 # https://github.com/swaywm/wlroots/pull/2771
+VULKAN_PATCHFILES+= 0028938735d1.patch:-p1 # https://github.com/swaywm/wlroots/pull/2771
+VULKAN_PATCHFILES+= 6885b636508c.patch:-p1 # https://github.com/swaywm/wlroots/pull/2771
+VULKAN_PATCHFILES+= 76534695a8d3.patch:-p1 # https://github.com/swaywm/wlroots/pull/2771
+VULKAN_PATCHFILES+= 445142e6a1f9.patch:-p1 # https://github.com/swaywm/wlroots/pull/2771
+VULKAN_PATCHFILES+= f029ae1dac4b.patch:-p1 # https://github.com/swaywm/wlroots/pull/2771
+VULKAN_PATCHFILES+= ad1fab0b3704.patch:-p1 # https://github.com/swaywm/wlroots/pull/2771
+VULKAN_PATCHFILES+= 4407b8e5a3a7.patch:-p1 # https://github.com/swaywm/wlroots/pull/2771
+VULKAN_PATCHFILES+= e021c068d02f.patch:-p1 # https://github.com/swaywm/wlroots/pull/2771
+VULKAN_PATCHFILES+= 2cc710bda83c.patch:-p1 # https://github.com/swaywm/wlroots/pull/2771
+VULKAN_PATCHFILES+= f0888604d6ce.patch:-p1 # https://github.com/swaywm/wlroots/pull/2771
+VULKAN_PATCHFILES+= 4fdd5efc9260.patch:-p1 # https://github.com/swaywm/wlroots/pull/2771
+VULKAN_PATCHFILES+= 59c119829f1c.patch:-p1 # https://github.com/swaywm/wlroots/pull/2771
+VULKAN_PATCHFILES+= cfbd8aa6cf24.patch:-p1 # https://github.com/swaywm/wlroots/pull/2771
+VULKAN_PATCHFILES+= 3f6dbe428e8b.patch:-p1 # https://github.com/swaywm/wlroots/pull/2771
+VULKAN_PATCHFILES+= a83943798aef.patch:-p1 # https://github.com/swaywm/wlroots/pull/2771
+VULKAN_PATCHFILES+= f64a98d49d25.patch:-p1 # https://github.com/swaywm/wlroots/pull/2771
+VULKAN_PATCHFILES+= 9885ccb4b0b1.patch:-p1 # https://github.com/swaywm/wlroots/pull/2771
+VULKAN_PATCHFILES+= 71f9f33e3bf2.patch:-p1 # https://github.com/swaywm/wlroots/pull/2771
+VULKAN_PATCHFILES+= bd8c520dbd9a.patch:-p1 # https://github.com/swaywm/wlroots/pull/2771
+VULKAN_PATCHFILES+= 2d89dc9b8651.patch:-p1 # https://github.com/swaywm/wlroots/pull/2771
+VULKAN_PATCHFILES+= 8f9aeda46d8a.patch:-p1 # https://github.com/swaywm/wlroots/pull/2771
+VULKAN_PATCHFILES+= e3d16970433f.patch:-p1 # https://github.com/swaywm/wlroots/pull/2771
+VULKAN_PATCHFILES+= 79f10d929b72.patch:-p1 # https://github.com/swaywm/wlroots/pull/2771
+VULKAN_PATCHFILES+= 1a16e8fc56a9.patch:-p1 # https://github.com/swaywm/wlroots/pull/2771
+VULKAN_PATCHFILES+= dd039c56d93a.patch:-p1 # https://github.com/swaywm/wlroots/pull/2771
+VULKAN_BUILD_DEPENDS= glslangValidator:graphics/glslang \
+ vulkan-headers>0:graphics/vulkan-headers
+VULKAN_LIB_DEPENDS= libvulkan.so:graphics/vulkan-loader
+VULKAN_RUN_DEPENDS= mesa-dri>0:graphics/mesa-dri
+VULKAN_USES= localbase # Silence -Werror=undef in <vulkan/vulkan_core.h>
+VULKAN_VARS= RENDERERS+=vulkan
+VULKAN_PLIST_FILES= include/wlr/types/wlr_drm.h \
+ %%VULKAN%%include/wlr/render/vulkan.h
+
X11_LIB_DEPENDS= libxcb-errors.so:x11/xcb-util-errors \
libxcb-render-util.so:x11/xcb-util-renderutil \
libxcb-icccm.so:x11/xcb-util-wm