aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2022-11-21 17:46:52 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2022-12-25 22:05:55 +0000
commit4a51f972d1a9db6aa1bb93873b74674e4323049d (patch)
tree15374e716b1b931c66c716e8432840c8d97cb2ff
parent9a7da5f4c647f634d8da97a433abade27eeb2d96 (diff)
downloadports-4a51f972d1a9db6aa1bb93873b74674e4323049d.tar.gz
ports-4a51f972d1a9db6aa1bb93873b74674e4323049d.zip
Mk/Scripts/makesum.sh: Fix for distinfo files with nothing but a TIMESTAMP
PR: 267904
-rw-r--r--Mk/Scripts/makesum.sh2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/Scripts/makesum.sh b/Mk/Scripts/makesum.sh
index 1d09b7ffb82a..c9f50e56bb5d 100644
--- a/Mk/Scripts/makesum.sh
+++ b/Mk/Scripts/makesum.sh
@@ -28,7 +28,7 @@ cd "${dp_DISTDIR}"
# So, we extract the content of the distinfo file minus the TIMESTAMP, if it
# contains a TIMESTAMP.
if [ -f "${dp_DISTINFO_FILE}" ] && grep -q "^TIMESTAMP " ${dp_DISTINFO_FILE}; then
- grep -v "^TIMESTAMP " ${dp_DISTINFO_FILE} > ${DISTINFO_OLD}
+ grep -v "^TIMESTAMP " ${dp_DISTINFO_FILE} > ${DISTINFO_OLD} || true
fi
for file in ${dp_CKSUMFILES}; do