aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2024-05-26 06:03:41 +0000
committerJason E. Hale <jhale@FreeBSD.org>2024-05-26 06:58:25 +0000
commit4b17f0c82bfeabcb0770ebc6aabbf8ace3e714af (patch)
tree93c49d8c6a1193c0b3b070f472fb620a1476d29a
parented007e12b5856a76e0db50e00f6a808595928db6 (diff)
downloadports-4b17f0c82bfeabcb0770ebc6aabbf8ace3e714af.tar.gz
ports-4b17f0c82bfeabcb0770ebc6aabbf8ace3e714af.zip
science/qt6-quick3dphysics: Fix patch stage
Mk/Uses/qt.mk: Fix typo that lead to my test builds excluding this port and to not register it as a LIB_DEPENDS in consumers. [1] Nothing currently depends on this, but the devel/qt6 metaport technically should, so I'm bumping its PORTREVISION so that science/qt6-quick3dphysics is registered as a dependency. Reported by: pkg-fallout MFH: 2024Q2 Pointy hat to: my 7 months ago self who added this port [1]
-rw-r--r--Mk/Uses/qt.mk2
-rw-r--r--devel/qt6/Makefile1
-rw-r--r--science/qt6-quick3dphysics/files/patch-src_3rdparty_PhysX_source_foundation_src_unix_PsUnixThread.cpp14
3 files changed, 6 insertions, 11 deletions
diff --git a/Mk/Uses/qt.mk b/Mk/Uses/qt.mk
index 470415891192..127e721f4378 100644
--- a/Mk/Uses/qt.mk
+++ b/Mk/Uses/qt.mk
@@ -318,7 +318,7 @@ qt-quick3d_PORT= x11-toolkits/${_QT_RELNAME}-quick3d
qt-quick3d_LIB= libQt${_QT_LIBVER}Quick3D.so
qt-quick3dphysics_PORT= science/${_QT_RELNAME}-quick3dphysics
-qt_quick3dphysics_LIB= libQt${_QT_LIBVER}Quick3DPhysics.so
+qt-quick3dphysics_LIB= libQt${_QT_LIBVER}Quick3DPhysics.so
qt-quickcontrols_PORT= x11-toolkits/${_QT_RELNAME}-quickcontrols
qt-quickcontrols_PATH= ${LOCALBASE}/${QT_QMLDIR_REL}/QtQuick/Controls/qmldir
diff --git a/devel/qt6/Makefile b/devel/qt6/Makefile
index c4e795320e42..ef815c0d2e94 100644
--- a/devel/qt6/Makefile
+++ b/devel/qt6/Makefile
@@ -1,5 +1,6 @@
PORTNAME= qt6
DISTVERSION= ${QT6_VERSION}
+PORTREVISION= 1
CATEGORIES= devel
MAINTAINER= kde@FreeBSD.org
diff --git a/science/qt6-quick3dphysics/files/patch-src_3rdparty_PhysX_source_foundation_src_unix_PsUnixThread.cpp b/science/qt6-quick3dphysics/files/patch-src_3rdparty_PhysX_source_foundation_src_unix_PsUnixThread.cpp
index 93fd958d96a6..ecd151c1f122 100644
--- a/science/qt6-quick3dphysics/files/patch-src_3rdparty_PhysX_source_foundation_src_unix_PsUnixThread.cpp
+++ b/science/qt6-quick3dphysics/files/patch-src_3rdparty_PhysX_source_foundation_src_unix_PsUnixThread.cpp
@@ -1,5 +1,5 @@
Index: src/3rdparty/PhysX/source/foundation/src/unix/PsUnixThread.cpp
---- src/3rdparty/PhysX/source/foundation/src/unix/PsUnixThread.cpp.orig 2023-09-24 11:12:43 UTC
+--- src/3rdparty/PhysX/source/foundation/src/unix/PsUnixThread.cpp.orig 2024-05-09 03:10:14 UTC
+++ src/3rdparty/PhysX/source/foundation/src/unix/PsUnixThread.cpp
@@ -36,7 +36,7 @@
#include "PsThread.h"
@@ -19,22 +19,16 @@ Index: src/3rdparty/PhysX/source/foundation/src/unix/PsUnixThread.cpp
#include <asm/unistd.h>
#include <sys/resource.h>
#endif
-@@ -111,11 +111,11 @@ static void setTid(_ThreadImpl& threadImpl)
+@@ -110,7 +110,7 @@ static void setTid(_ThreadImpl& threadImpl)
static void setTid(_ThreadImpl& threadImpl)
{
// query TID
-#if PX_PS4 || (defined (TARGET_OS_TV) && TARGET_OS_TV)
+#if PX_PS4 || (defined (TARGET_OS_TV) && TARGET_OS_TV) || PX_FREEBSD
// AM: TODO: neither of the below are implemented
--#elif PX_APPLE_FAMILY
-+#elif PX_APPLE_FAMILY || !PX_FREEBSD
+ #elif PX_APPLE_FAMILY
threadImpl.tid = syscall(SYS_gettid);
--#elif PX_EMSCRIPTEN
-+#elif PX_EMSCRIPTEN || PX_FREEBSD
- threadImpl.tid = pthread_self();
- #else
- threadImpl.tid = syscall(__NR_gettid);
-@@ -311,7 +311,7 @@ uint32_t ThreadImpl::setAffinityMask(uint32_t mask)
+@@ -324,7 +324,7 @@ uint32_t ThreadImpl::setAffinityMask(uint32_t mask)
{
#if PX_PS4
prevMask = setAffinityMaskPS4(getThread(this)->thread, mask);