aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-07-06 14:54:37 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-07-06 14:54:37 +0000
commit4b327b761217146ef3f453d969c0ab5c23240353 (patch)
treeb4f2c6e09d491f7f06c531f34eb178d172ee06ab
parent4ad759113960755d29d475b68457e36140eac92c (diff)
downloadports-4b327b761217146ef3f453d969c0ab5c23240353.tar.gz
ports-4b327b761217146ef3f453d969c0ab5c23240353.zip
www/py-priority1: Add py-priority1 1.3.0 (copied from py-priority)
- Add PORTSCOUT
-rw-r--r--www/Makefile1
-rw-r--r--www/py-priority1/Makefile23
-rw-r--r--www/py-priority1/distinfo3
-rw-r--r--www/py-priority1/pkg-descr19
4 files changed, 46 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 57fcd3405c8a..b23978c52355 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1684,6 +1684,7 @@
SUBDIR += py-praw
SUBDIR += py-prawcore
SUBDIR += py-priority
+ SUBDIR += py-priority1
SUBDIR += py-protego
SUBDIR += py-puppetboard
SUBDIR += py-py-restclient
diff --git a/www/py-priority1/Makefile b/www/py-priority1/Makefile
new file mode 100644
index 000000000000..bc3898031fe7
--- /dev/null
+++ b/www/py-priority1/Makefile
@@ -0,0 +1,23 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= priority
+PORTVERSION= 1.3.0
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+PKGNAMESUFFIX= 1
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Pure-Python implementation of the HTTP/2 priority tree
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+PORTSCOUT= limit:^1\.
+
+.include <bsd.port.mk>
diff --git a/www/py-priority1/distinfo b/www/py-priority1/distinfo
new file mode 100644
index 000000000000..c3a2b5d3cbc0
--- /dev/null
+++ b/www/py-priority1/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1530051116
+SHA256 (priority-1.3.0.tar.gz) = 6bc1961a6d7fcacbfc337769f1a382c8e746566aaa365e78047abe9f66b2ffbe
+SIZE (priority-1.3.0.tar.gz) = 13827
diff --git a/www/py-priority1/pkg-descr b/www/py-priority1/pkg-descr
new file mode 100644
index 000000000000..8042496947ee
--- /dev/null
+++ b/www/py-priority1/pkg-descr
@@ -0,0 +1,19 @@
+Priority is a pure-Python implementation of the priority logic for HTTP/2, set
+out in RFC 7540 Section 5.3 (Stream Priority). This logic allows for clients to
+express a preference for how the server allocates its (limited) resources to the
+many outstanding HTTP requests that may be running over a single HTTP/2
+connection.
+
+Specifically, this Python implementation uses a variant of the implementation
+used in the excellent H2O project. This original implementation is also the
+inspiration for nghttp2's priority implementation, and generally produces a very
+clean and even priority stream. The only notable changes from H2O's
+implementation are small modifications to allow the priority implementation to
+work cleanly as a separate implementation, rather than being embedded in a
+HTTP/2 stack directly.
+
+While priority information in HTTP/2 is only a suggestion, rather than an
+enforceable constraint, where possible servers should respect the priority
+requests of their clients.
+
+WWW: https://github.com/python-hyper/priority