aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Nagy <rnagy@FreeBSD.org>2024-06-03 12:52:56 +0000
committerRobert Nagy <rnagy@FreeBSD.org>2024-06-03 12:54:46 +0000
commit4ba66b974729b45f6c2418d87d7403ef2e7b474d (patch)
tree82f53827ba9ec8e97bcfc2d00a6829c97b600b31
parent02ec8c323abfaca29039cce19415fa2e589970ef (diff)
downloadports-4ba66b974729b45f6c2418d87d7403ef2e7b474d.tar.gz
ports-4ba66b974729b45f6c2418d87d7403ef2e7b474d.zip
www/*chromium: update to 125.0.6422.141
Additionally to the update, do not define _XOPEN_SOURCE on FreeBSD either in the internal copy of sqlite3 to avoid new compiler errors with llvm18. Security: https://vuxml.freebsd.org/freebsd/b058380e-21a4-11ef-8a0f-a8a1599412c6.html PR: 279397
-rw-r--r--www/chromium/Makefile5
-rw-r--r--www/chromium/distinfo14
-rw-r--r--www/chromium/files/patch-third__party_libaom_source_libaom_aom__ports_aarch64__cpudetect.c4
-rw-r--r--www/chromium/files/patch-third__party_sqlite_src_amalgamation_sqlite3.c11
-rw-r--r--www/chromium/files/patch-third__party_zlib_cpu__features.c4
-rw-r--r--www/chromium/files/patch-v8_src_api_api.cc4
-rw-r--r--www/ungoogled-chromium/Makefile2
-rw-r--r--www/ungoogled-chromium/distinfo14
-rw-r--r--www/ungoogled-chromium/files/patch-third__party_libaom_source_libaom_aom__ports_aarch64__cpudetect.c4
-rw-r--r--www/ungoogled-chromium/files/patch-third__party_sqlite_src_amalgamation_sqlite3.c11
-rw-r--r--www/ungoogled-chromium/files/patch-third__party_zlib_cpu__features.c4
-rw-r--r--www/ungoogled-chromium/files/patch-v8_src_api_api.cc4
12 files changed, 50 insertions, 31 deletions
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index f02845237111..d10e0f51f028 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -1,5 +1,5 @@
PORTNAME= chromium
-PORTVERSION= 125.0.6422.112
+PORTVERSION= 125.0.6422.141
PULSEMV= 16
PULSEV= ${PULSEMV}.1
CATEGORIES= www wayland
@@ -91,7 +91,8 @@ USE_QT= buildtools:build
SHEBANG_FILES= chrome/tools/build/linux/chrome-wrapper buildtools/linux64/clang-format
MAKE_ARGS= -C out/${BUILDTYPE}
-ALL_TARGET= chrome
+#ALL_TARGET= chrome
+ALL_TARGET= chromium_sqlite3
BINARY_ALIAS= python3=${PYTHON_CMD} \
moc=${PREFIX}/bin/moc-qt5
diff --git a/www/chromium/distinfo b/www/chromium/distinfo
index 5758f96637ad..6aa0601cb3f4 100644
--- a/www/chromium/distinfo
+++ b/www/chromium/distinfo
@@ -1,11 +1,11 @@
-TIMESTAMP = 1716984974
-SHA256 (chromium-125.0.6422.112.tar.xz) = ba48d13e506ae68bd6d01a808cdc186ee09322daafeb0bddf95dae59b0b4276b
-SIZE (chromium-125.0.6422.112.tar.xz) = 3466534616
-SHA256 (chrome-linux-125.0.6422.112-llvm17.profdata.tar.xz) = c21d3e23f91342352cdfd26c11f9f9b811b870bb5d5b0e75dc14dd7c2155f5a9
-SIZE (chrome-linux-125.0.6422.112-llvm17.profdata.tar.xz) = 30243056
+TIMESTAMP = 1717418095
+SHA256 (chromium-125.0.6422.141.tar.xz) = 9966b50279d0cfaaf4b58570387f0d526388f8d5f6dd990e3f083a55d8d8e603
+SIZE (chromium-125.0.6422.141.tar.xz) = 3470583616
+SHA256 (chrome-linux-125.0.6422.141-llvm17.profdata.tar.xz) = 4407a114d7fa88467386fd596fe8b55ffcdfbbd52efa0a4a5bc05268a9d89672
+SIZE (chrome-linux-125.0.6422.141-llvm17.profdata.tar.xz) = 30247704
SHA256 (pulseaudio-16.1.tar.gz) = 027266c62f2a84422ac45fa721a649508f0f1628fb1fd9242315ac54ce2d7c92
SIZE (pulseaudio-16.1.tar.gz) = 2763111
-SHA256 (chromium-125.0.6422.112-testdata.tar.xz) = 21f4e63ed552624c32b4fe7fcd4a72b3d055a10279e6aae2418f6b95d5e3ba44
-SIZE (chromium-125.0.6422.112-testdata.tar.xz) = 280603432
+SHA256 (chromium-125.0.6422.141-testdata.tar.xz) = 96ff1038b1ac6a1679d72d137ec0558f6174f1f20c712f79bbc7ccedd5ee2fd0
+SIZE (chromium-125.0.6422.141-testdata.tar.xz) = 280241644
SHA256 (test_fonts-336e775eec536b2d785cc80eff6ac39051931286.tar.gz) = a2ca2962daf482a8f943163541e1c73ba4b2694fabcd2510981f2db4eda493c8
SIZE (test_fonts-336e775eec536b2d785cc80eff6ac39051931286.tar.gz) = 32624734
diff --git a/www/chromium/files/patch-third__party_libaom_source_libaom_aom__ports_aarch64__cpudetect.c b/www/chromium/files/patch-third__party_libaom_source_libaom_aom__ports_aarch64__cpudetect.c
index a18b66eb4f9a..cd09cd9764e1 100644
--- a/www/chromium/files/patch-third__party_libaom_source_libaom_aom__ports_aarch64__cpudetect.c
+++ b/www/chromium/files/patch-third__party_libaom_source_libaom_aom__ports_aarch64__cpudetect.c
@@ -1,4 +1,4 @@
---- third_party/libaom/source/libaom/aom_ports/aarch64_cpudetect.c.orig 2024-04-19 13:02:56 UTC
+--- third_party/libaom/source/libaom/aom_ports/aarch64_cpudetect.c.orig 2024-06-03 12:51:57 UTC
+++ third_party/libaom/source/libaom/aom_ports/aarch64_cpudetect.c
@@ -99,9 +99,45 @@ static int arm_get_cpu_caps(void) {
return flags;
@@ -21,7 +21,7 @@
+ if (sysctl(isar0_mib, 2, &cpu_id, &len, NULL, 0) < 0)
+ return flags;
+
-+ if (ID_AA64ISAR0_AES(cpu_id) >= ID_AA64ISAR0_CRC32_BASE)
++ if (ID_AA64ISAR0_CRC32(cpu_id) >= ID_AA64ISAR0_CRC32_BASE)
+ flags |= HAS_ARM_CRC32;
+
+ return flags;
diff --git a/www/chromium/files/patch-third__party_sqlite_src_amalgamation_sqlite3.c b/www/chromium/files/patch-third__party_sqlite_src_amalgamation_sqlite3.c
index 60315a0018ee..d1b8346e6155 100644
--- a/www/chromium/files/patch-third__party_sqlite_src_amalgamation_sqlite3.c
+++ b/www/chromium/files/patch-third__party_sqlite_src_amalgamation_sqlite3.c
@@ -1,5 +1,14 @@
---- third_party/sqlite/src/amalgamation/sqlite3.c.orig 2024-05-21 18:07:39 UTC
+--- third_party/sqlite/src/amalgamation/sqlite3.c.orig 2024-06-03 12:52:16 UTC
+++ third_party/sqlite/src/amalgamation/sqlite3.c
+@@ -14119,7 +14119,7 @@ struct fts5_api {
+ ** But _XOPEN_SOURCE define causes problems for Mac OS X, so omit
+ ** it.
+ */
+-#if !defined(_XOPEN_SOURCE) && !defined(__DARWIN__) && !defined(__APPLE__)
++#if !defined(_XOPEN_SOURCE) && !defined(__DARWIN__) && !defined(__APPLE__) && !defined(__FreeBSD__)
+ # define _XOPEN_SOURCE 600
+ #endif
+
@@ -44777,7 +44777,12 @@ static int unixRandomness(sqlite3_vfs *NotUsed, int nB
memset(zBuf, 0, nBuf);
randomnessPid = osGetpid(0);
diff --git a/www/chromium/files/patch-third__party_zlib_cpu__features.c b/www/chromium/files/patch-third__party_zlib_cpu__features.c
index d2b248501655..ad94c2d9d9e8 100644
--- a/www/chromium/files/patch-third__party_zlib_cpu__features.c
+++ b/www/chromium/files/patch-third__party_zlib_cpu__features.c
@@ -1,4 +1,4 @@
---- third_party/zlib/cpu_features.c.orig 2024-04-19 13:02:56 UTC
+--- third_party/zlib/cpu_features.c.orig 2024-06-03 12:51:57 UTC
+++ third_party/zlib/cpu_features.c
@@ -39,7 +39,8 @@ int ZLIB_INTERNAL riscv_cpu_enable_vclmul = 0;
#ifndef CPU_NO_SIMD
@@ -44,7 +44,7 @@
+ if (ID_AA64ISAR0_AES(cpu_id) >= ID_AA64ISAR0_AES_PMULL)
+ arm_cpu_enable_pmull = 1;
+
-+ if (ID_AA64ISAR0_AES(cpu_id) >= ID_AA64ISAR0_CRC32_BASE)
++ if (ID_AA64ISAR0_CRC32(cpu_id) >= ID_AA64ISAR0_CRC32_BASE)
+ arm_cpu_enable_crc32 = 1;
#elif defined(ARMV8_OS_FUCHSIA)
uint32_t features;
diff --git a/www/chromium/files/patch-v8_src_api_api.cc b/www/chromium/files/patch-v8_src_api_api.cc
index 8b1f2f19c261..e6753c18da2a 100644
--- a/www/chromium/files/patch-v8_src_api_api.cc
+++ b/www/chromium/files/patch-v8_src_api_api.cc
@@ -1,4 +1,4 @@
---- v8/src/api/api.cc.orig 2024-05-21 18:07:39 UTC
+--- v8/src/api/api.cc.orig 2024-06-03 12:51:57 UTC
+++ v8/src/api/api.cc
@@ -144,7 +144,7 @@
#include "src/wasm/wasm-serialization.h"
@@ -9,7 +9,7 @@
#include <signal.h>
#include <unistd.h>
-@@ -6393,7 +6393,7 @@ bool v8::V8::Initialize(const int build_config) {
+@@ -6404,7 +6404,7 @@ bool v8::V8::Initialize(const int build_config) {
return true;
}
diff --git a/www/ungoogled-chromium/Makefile b/www/ungoogled-chromium/Makefile
index 6ea6d97b2308..267c03506fe6 100644
--- a/www/ungoogled-chromium/Makefile
+++ b/www/ungoogled-chromium/Makefile
@@ -1,5 +1,5 @@
PORTNAME= ungoogled-chromium
-PORTVERSION= 125.0.6422.112
+PORTVERSION= 125.0.6422.141
UGVERSION= ${DISTVERSION}-1
PULSEMV= 16
PULSEV= ${PULSEMV}.1
diff --git a/www/ungoogled-chromium/distinfo b/www/ungoogled-chromium/distinfo
index e6856b7d20af..363cdf04252d 100644
--- a/www/ungoogled-chromium/distinfo
+++ b/www/ungoogled-chromium/distinfo
@@ -1,11 +1,11 @@
-TIMESTAMP = 1716985108
-SHA256 (chromium-125.0.6422.112.tar.xz) = ba48d13e506ae68bd6d01a808cdc186ee09322daafeb0bddf95dae59b0b4276b
-SIZE (chromium-125.0.6422.112.tar.xz) = 3466534616
-SHA256 (ungoogled-chromium-125.0.6422.112-1.tar.gz) = c6f135b6d233b71b5437dddc2977b72170b237f8e72a34a0de2a626be7d90c4e
-SIZE (ungoogled-chromium-125.0.6422.112-1.tar.gz) = 668978
+TIMESTAMP = 1717418110
+SHA256 (chromium-125.0.6422.141.tar.xz) = 9966b50279d0cfaaf4b58570387f0d526388f8d5f6dd990e3f083a55d8d8e603
+SIZE (chromium-125.0.6422.141.tar.xz) = 3470583616
+SHA256 (ungoogled-chromium-125.0.6422.141-1.tar.gz) = c7b8ed60dacb22dde8ee69ca82ab9e92e0fa2f9372b7edb441ef6d20dc356f39
+SIZE (ungoogled-chromium-125.0.6422.141-1.tar.gz) = 668658
SHA256 (pulseaudio-16.1.tar.gz) = 027266c62f2a84422ac45fa721a649508f0f1628fb1fd9242315ac54ce2d7c92
SIZE (pulseaudio-16.1.tar.gz) = 2763111
-SHA256 (chromium-125.0.6422.112-testdata.tar.xz) = 21f4e63ed552624c32b4fe7fcd4a72b3d055a10279e6aae2418f6b95d5e3ba44
-SIZE (chromium-125.0.6422.112-testdata.tar.xz) = 280603432
+SHA256 (chromium-125.0.6422.141-testdata.tar.xz) = 96ff1038b1ac6a1679d72d137ec0558f6174f1f20c712f79bbc7ccedd5ee2fd0
+SIZE (chromium-125.0.6422.141-testdata.tar.xz) = 280241644
SHA256 (test_fonts-336e775eec536b2d785cc80eff6ac39051931286.tar.gz) = a2ca2962daf482a8f943163541e1c73ba4b2694fabcd2510981f2db4eda493c8
SIZE (test_fonts-336e775eec536b2d785cc80eff6ac39051931286.tar.gz) = 32624734
diff --git a/www/ungoogled-chromium/files/patch-third__party_libaom_source_libaom_aom__ports_aarch64__cpudetect.c b/www/ungoogled-chromium/files/patch-third__party_libaom_source_libaom_aom__ports_aarch64__cpudetect.c
index 589f15891791..7ba4afde8d00 100644
--- a/www/ungoogled-chromium/files/patch-third__party_libaom_source_libaom_aom__ports_aarch64__cpudetect.c
+++ b/www/ungoogled-chromium/files/patch-third__party_libaom_source_libaom_aom__ports_aarch64__cpudetect.c
@@ -1,4 +1,4 @@
---- third_party/libaom/source/libaom/aom_ports/aarch64_cpudetect.c.orig 2024-04-23 07:42:17 UTC
+--- third_party/libaom/source/libaom/aom_ports/aarch64_cpudetect.c.orig 2024-06-03 12:28:28 UTC
+++ third_party/libaom/source/libaom/aom_ports/aarch64_cpudetect.c
@@ -99,9 +99,45 @@ static int arm_get_cpu_caps(void) {
return flags;
@@ -21,7 +21,7 @@
+ if (sysctl(isar0_mib, 2, &cpu_id, &len, NULL, 0) < 0)
+ return flags;
+
-+ if (ID_AA64ISAR0_AES(cpu_id) >= ID_AA64ISAR0_CRC32_BASE)
++ if (ID_AA64ISAR0_CRC32(cpu_id) >= ID_AA64ISAR0_CRC32_BASE)
+ flags |= HAS_ARM_CRC32;
+
+ return flags;
diff --git a/www/ungoogled-chromium/files/patch-third__party_sqlite_src_amalgamation_sqlite3.c b/www/ungoogled-chromium/files/patch-third__party_sqlite_src_amalgamation_sqlite3.c
index 32cc8d1f15f4..d1b8346e6155 100644
--- a/www/ungoogled-chromium/files/patch-third__party_sqlite_src_amalgamation_sqlite3.c
+++ b/www/ungoogled-chromium/files/patch-third__party_sqlite_src_amalgamation_sqlite3.c
@@ -1,5 +1,14 @@
---- third_party/sqlite/src/amalgamation/sqlite3.c.orig 2024-05-23 20:04:36 UTC
+--- third_party/sqlite/src/amalgamation/sqlite3.c.orig 2024-06-03 12:52:16 UTC
+++ third_party/sqlite/src/amalgamation/sqlite3.c
+@@ -14119,7 +14119,7 @@ struct fts5_api {
+ ** But _XOPEN_SOURCE define causes problems for Mac OS X, so omit
+ ** it.
+ */
+-#if !defined(_XOPEN_SOURCE) && !defined(__DARWIN__) && !defined(__APPLE__)
++#if !defined(_XOPEN_SOURCE) && !defined(__DARWIN__) && !defined(__APPLE__) && !defined(__FreeBSD__)
+ # define _XOPEN_SOURCE 600
+ #endif
+
@@ -44777,7 +44777,12 @@ static int unixRandomness(sqlite3_vfs *NotUsed, int nB
memset(zBuf, 0, nBuf);
randomnessPid = osGetpid(0);
diff --git a/www/ungoogled-chromium/files/patch-third__party_zlib_cpu__features.c b/www/ungoogled-chromium/files/patch-third__party_zlib_cpu__features.c
index ff214da52978..4a3baa864b57 100644
--- a/www/ungoogled-chromium/files/patch-third__party_zlib_cpu__features.c
+++ b/www/ungoogled-chromium/files/patch-third__party_zlib_cpu__features.c
@@ -1,4 +1,4 @@
---- third_party/zlib/cpu_features.c.orig 2024-04-23 07:42:17 UTC
+--- third_party/zlib/cpu_features.c.orig 2024-06-03 12:28:28 UTC
+++ third_party/zlib/cpu_features.c
@@ -39,7 +39,8 @@ int ZLIB_INTERNAL riscv_cpu_enable_vclmul = 0;
#ifndef CPU_NO_SIMD
@@ -44,7 +44,7 @@
+ if (ID_AA64ISAR0_AES(cpu_id) >= ID_AA64ISAR0_AES_PMULL)
+ arm_cpu_enable_pmull = 1;
+
-+ if (ID_AA64ISAR0_AES(cpu_id) >= ID_AA64ISAR0_CRC32_BASE)
++ if (ID_AA64ISAR0_CRC32(cpu_id) >= ID_AA64ISAR0_CRC32_BASE)
+ arm_cpu_enable_crc32 = 1;
#elif defined(ARMV8_OS_FUCHSIA)
uint32_t features;
diff --git a/www/ungoogled-chromium/files/patch-v8_src_api_api.cc b/www/ungoogled-chromium/files/patch-v8_src_api_api.cc
index cb3b2896b664..b7feda22fc46 100644
--- a/www/ungoogled-chromium/files/patch-v8_src_api_api.cc
+++ b/www/ungoogled-chromium/files/patch-v8_src_api_api.cc
@@ -1,4 +1,4 @@
---- v8/src/api/api.cc.orig 2024-05-23 20:04:36 UTC
+--- v8/src/api/api.cc.orig 2024-06-03 12:28:28 UTC
+++ v8/src/api/api.cc
@@ -144,7 +144,7 @@
#include "src/wasm/wasm-serialization.h"
@@ -9,7 +9,7 @@
#include <signal.h>
#include <unistd.h>
-@@ -6393,7 +6393,7 @@ bool v8::V8::Initialize(const int build_config) {
+@@ -6404,7 +6404,7 @@ bool v8::V8::Initialize(const int build_config) {
return true;
}