aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2022-09-03 07:09:16 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2022-09-03 07:09:16 +0000
commit4c18fcad6fc7c7c2e619c37d1431cd718378acae (patch)
tree6a6ac84ae18f5fafa7923a7a9d5ba692d43bed75
parenteb4078f328120e3af1a6f74087109c370dcdd2be (diff)
downloadports-4c18fcad6fc7c7c2e619c37d1431cd718378acae.tar.gz
ports-4c18fcad6fc7c7c2e619c37d1431cd718378acae.zip
deskutils/xfce4-notifyd: Update to 0.6.4
PR: 266182
-rw-r--r--deskutils/xfce4-notifyd/Makefile2
-rw-r--r--deskutils/xfce4-notifyd/distinfo6
-rw-r--r--deskutils/xfce4-notifyd/files/patch-common_xfce-notify-log.c13
3 files changed, 17 insertions, 4 deletions
diff --git a/deskutils/xfce4-notifyd/Makefile b/deskutils/xfce4-notifyd/Makefile
index acb729eb4d5d..e8627718866d 100644
--- a/deskutils/xfce4-notifyd/Makefile
+++ b/deskutils/xfce4-notifyd/Makefile
@@ -4,7 +4,7 @@
# Support of GTK+ is checked at compile time and themes directories too.
PORTNAME= xfce4-notifyd
-PORTVERSION= 0.6.3
+PORTVERSION= 0.6.4
CATEGORIES= deskutils xfce
MASTER_SITES= XFCE/apps
DIST_SUBDIR= xfce4
diff --git a/deskutils/xfce4-notifyd/distinfo b/deskutils/xfce4-notifyd/distinfo
index ac993254c555..a00e9876a9cf 100644
--- a/deskutils/xfce4-notifyd/distinfo
+++ b/deskutils/xfce4-notifyd/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1644698923
-SHA256 (xfce4/xfce4-notifyd-0.6.3.tar.bz2) = 56a9f895aed460042f2abe09bb1a899e29b7c7d5a76ecac63dead3ced990859f
-SIZE (xfce4/xfce4-notifyd-0.6.3.tar.bz2) = 547511
+TIMESTAMP = 1662106707
+SHA256 (xfce4/xfce4-notifyd-0.6.4.tar.bz2) = 0ece78f091f895374aad81a3bdc00701080b4ed07f7322fb680c4234319120f6
+SIZE (xfce4/xfce4-notifyd-0.6.4.tar.bz2) = 554776
diff --git a/deskutils/xfce4-notifyd/files/patch-common_xfce-notify-log.c b/deskutils/xfce4-notifyd/files/patch-common_xfce-notify-log.c
new file mode 100644
index 000000000000..0c83141e9543
--- /dev/null
+++ b/deskutils/xfce4-notifyd/files/patch-common_xfce-notify-log.c
@@ -0,0 +1,13 @@
+--- common/xfce-notify-log.c.orig 2022-09-02 07:22:08 UTC
++++ common/xfce-notify-log.c
+@@ -149,7 +149,9 @@ notify_get_from_desktop_file (const gchar *desktop_fil
+
+ match = matches[0];
+ appinfo = g_desktop_app_info_new (match[0]);
+- value = notify_read_from_desktop_file (g_desktop_app_info_get_filename (appinfo), key);
++ if (appinfo != NULL) {
++ value = notify_read_from_desktop_file (g_desktop_app_info_get_filename (appinfo), key);
++ }
+
+ for (gchar ***p = matches; *p != NULL; p++)
+ g_strfreev (*p);