aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2022-02-14 18:24:26 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2022-02-14 21:49:41 +0000
commit4c5de95169b69ed92027621e6e598f96e0c4e235 (patch)
tree1aa6ca2e32224e9cb419fa2f0513a629294b29fb
parent679b4cc35496a5266f8a2b0add388f66ea05b010 (diff)
downloadports-4c5de95169b69ed92027621e6e598f96e0c4e235.tar.gz
ports-4c5de95169b69ed92027621e6e598f96e0c4e235.zip
security/passh: Add a new port
Passh is a utility similar to sshpass. The goal of the project is to address some of the limitations of sshpass.
-rw-r--r--security/Makefile1
-rw-r--r--security/passh/Makefile29
-rw-r--r--security/passh/distinfo3
-rw-r--r--security/passh/pkg-descr5
4 files changed, 38 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 57c259cf7d52..4be2e021d567 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -748,6 +748,7 @@
SUBDIR += pam_yubico
SUBDIR += pamtester
SUBDIR += paperkey
+ SUBDIR += passh
SUBDIR += passivedns
SUBDIR += pbc
SUBDIR += pbnj
diff --git a/security/passh/Makefile b/security/passh/Makefile
new file mode 100644
index 000000000000..12feb82e5c05
--- /dev/null
+++ b/security/passh/Makefile
@@ -0,0 +1,29 @@
+# Created by: Mateusz Piotrowski <0mp@FreeBSD.org>
+
+PORTNAME= passh
+PORTVERSION= g20210412
+CATEGORIES= security
+
+MAINTAINER= 0mp@FreeBSD.org
+COMMENT= Non-interactive password inputting CLI
+
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= clarkwang
+GH_TAGNAME= a7506523edcbfc04e6c7481864ec7b086b71741f
+
+PLIST_FILES= bin/passh
+PORTDOCS= README.md sshpass-broken.md
+
+OPTIONS_DEFINE= DOCS
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+
+post-install-DOCS-on:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/security/passh/distinfo b/security/passh/distinfo
new file mode 100644
index 000000000000..edc7866e82a8
--- /dev/null
+++ b/security/passh/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1644862583
+SHA256 (clarkwang-passh-g20210412-a7506523edcbfc04e6c7481864ec7b086b71741f_GH0.tar.gz) = 8f8e5cccd27944fee0c7cdabf8e7ac90f4f654bc477f8e29ce812c16460a72b0
+SIZE (clarkwang-passh-g20210412-a7506523edcbfc04e6c7481864ec7b086b71741f_GH0.tar.gz) = 22164
diff --git a/security/passh/pkg-descr b/security/passh/pkg-descr
new file mode 100644
index 000000000000..a217b392c855
--- /dev/null
+++ b/security/passh/pkg-descr
@@ -0,0 +1,5 @@
+Passh is a tool for inputting passwords to programs like sudo, SSH, and
+su in a non-interactive way. The goal of the project is to address some
+of the limitations of a similar tool called sshpass.
+
+WWW: https://github.com/clarkwang/passh