aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-11-16 12:03:51 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-11-16 12:03:51 +0000
commit4c85c4afba3320edbc69a735d8fa096bf59fd45f (patch)
treedbe924cf56fd7e93d58be37f41e74c74c683ec15
parentd720da3a452231a92efaaa83d652c413b3a3e22a (diff)
downloadports-4c85c4afba3320edbc69a735d8fa096bf59fd45f.tar.gz
ports-4c85c4afba3320edbc69a735d8fa096bf59fd45f.zip
misc/xplr: fix build on powerpc
Same issue as on powerpc64 and powerpc64le, except that vanilla luajit works fine on powerpc.
-rw-r--r--misc/xplr/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/misc/xplr/Makefile b/misc/xplr/Makefile
index f2129048312a..8a8e25c6ca7f 100644
--- a/misc/xplr/Makefile
+++ b/misc/xplr/Makefile
@@ -153,6 +153,11 @@ EXTRA_PATCHES= ${FILESDIR}/extra-patch-Cargo.toml
LIB_DEPENDS= libluajit-5.1.so:lang/luajit-openresty
.endif
+.if ${ARCH} == powerpc
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-Cargo.toml
+LIB_DEPENDS= libluajit-5.1.so:lang/luajit
+.endif
+
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}