aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2023-09-06 18:36:48 +0000
committerJan Beich <jbeich@FreeBSD.org>2023-09-08 15:13:54 +0000
commit4ce3b4b71dcbf414bd7304c7336a78b2721f77f2 (patch)
tree6a84bb8531a0833c1f03662209b94568beb3fb79
parent97bb9e3d4333d1ecba90bef70a09a40cd3989a9b (diff)
downloadports-4ce3b4b71dcbf414bd7304c7336a78b2721f77f2.tar.gz
ports-4ce3b4b71dcbf414bd7304c7336a78b2721f77f2.zip
x11/xdg-desktop-portal-hyprland: update to 1.0.0
-rw-r--r--x11/hyprland-share-picker/Makefile5
-rw-r--r--x11/hyprland-share-picker/distinfo6
-rw-r--r--x11/xdg-desktop-portal-hyprland/Makefile67
-rw-r--r--x11/xdg-desktop-portal-hyprland/distinfo10
4 files changed, 54 insertions, 34 deletions
diff --git a/x11/hyprland-share-picker/Makefile b/x11/hyprland-share-picker/Makefile
index 8b64c6a732bf..d78c99384295 100644
--- a/x11/hyprland-share-picker/Makefile
+++ b/x11/hyprland-share-picker/Makefile
@@ -1,14 +1,13 @@
PORTNAME= hyprland-share-picker
DISTVERSIONPREFIX= v
-DISTVERSION= 0.5.0
-PORTREVISION= 1
+DISTVERSION= 1.0.0
CATEGORIES= x11 wayland
MAINTAINER= jbeich@FreeBSD.org
COMMENT= Share picker for xdg-desktop-portal-hyprland
WWW= https://github.com/hyprwm/xdg-desktop-portal-hyprland
-LICENSE= MIT
+LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC:H}/LICENSE
RUN_DEPENDS= slurp:x11/slurp
diff --git a/x11/hyprland-share-picker/distinfo b/x11/hyprland-share-picker/distinfo
index e1271eef1301..f182f57b3fe6 100644
--- a/x11/hyprland-share-picker/distinfo
+++ b/x11/hyprland-share-picker/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1691082525
-SHA256 (hyprwm-xdg-desktop-portal-hyprland-v0.5.0_GH0.tar.gz) = d346cbe170e7042d5e364242a715d021d9b8da2078a169771cf84cda13f24e76
-SIZE (hyprwm-xdg-desktop-portal-hyprland-v0.5.0_GH0.tar.gz) = 50608
+TIMESTAMP = 1694025408
+SHA256 (hyprwm-xdg-desktop-portal-hyprland-v1.0.0_GH0.tar.gz) = 558ff12ad20d8421f3279d5bd39dd431eccc667cc19babd5479edaaf21487f10
+SIZE (hyprwm-xdg-desktop-portal-hyprland-v1.0.0_GH0.tar.gz) = 41589
diff --git a/x11/xdg-desktop-portal-hyprland/Makefile b/x11/xdg-desktop-portal-hyprland/Makefile
index 0cdd191cdba8..ca2cc3ad5bb3 100644
--- a/x11/xdg-desktop-portal-hyprland/Makefile
+++ b/x11/xdg-desktop-portal-hyprland/Makefile
@@ -1,55 +1,49 @@
PORTNAME= xdg-desktop-portal-hyprland
DISTVERSIONPREFIX= v
-DISTVERSION= 0.5.0
+DISTVERSION= 1.0.0
CATEGORIES= x11 wayland
-PATCH_SITES+= https://github.com/emersion/xdg-desktop-portal-wlr/commit/:wlr
-PATCHFILES+= 8453779cf394.patch:-p1:wlr # https://github.com/emersion/xdg-desktop-portal-wlr/pull/279
-
MAINTAINER= jbeich@FreeBSD.org
COMMENT= xdg-desktop-portal backend for hyprland
WWW= https://github.com/hyprwm/xdg-desktop-portal-hyprland
-LICENSE= MIT
+LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= wayland-protocols>=1.24:graphics/wayland-protocols
-LIB_DEPENDS= libbasu.so:devel/basu \
- libinih.so:devel/inih \
+BROKEN_FreeBSD_12= libc++ too old
+
+BUILD_DEPENDS= wayland-protocols>=1.31:graphics/wayland-protocols
+LIB_DEPENDS= libsdbus-c++.so:devel/sdbus-cpp \
libdrm.so:graphics/libdrm \
libwayland-client.so:graphics/wayland \
- libuuid.so:misc/e2fsprogs-libuuid \
libpipewire-0.3.so:multimedia/pipewire
-RUN_DEPENDS= grim:x11/grim \
- hyprland-share-picker:x11/hyprland-share-picker@${FLAVOR} \
- slurp:x11/slurp
+RUN_DEPENDS= hyprland-share-picker:x11/hyprland-share-picker@${FLAVOR}
FLAVORS= qt5 qt6
qt5_CONFLICTS_INSTALL= ${PORTNAME}-qt6
qt6_CONFLICTS_INSTALL= ${PORTNAME}
qt6_PKGNAMESUFFIX= -qt6
-USES= compiler:c11 gl meson pkgconfig
+USES= compiler:gcc-c++11-lib gl meson pkgconfig
USE_GITHUB= yes
USE_GL= gbm
GH_ACCOUNT= hyprwm
GH_TUPLE= hyprwm:hyprland-protocols:v0.2:hyprland_protocols/subprojects/hyprland-protocols
-MESON_ARGS= -Dsd-bus-provider=basu -Dsystemd=disabled
+MESON_ARGS= -Dsystemd=disabled
PLIST_FILES= libexec/${PORTNAME} \
share/dbus-1/services/org.freedesktop.impl.portal.desktop.hyprland.service \
share/xdg-desktop-portal/portals/hyprland.portal
-# XXX Drop after FreeBSD 13.4 EOL around 2026-01-31
-# https://cgit.freebsd.org/src/commit/?id=af93fea71038
-.if !exists(/usr/include/sys/timerfd.h)
-LIB_DEPENDS+= libepoll-shim.so:devel/libepoll-shim
+.if exists(/usr/lib/libc++.so) && !exists(/usr/include/c++/v1/__format/write_escaped.h)
+CXXFLAGS+= -D_LIBCPP_ENABLE_EXPERIMENTAL # std::vformat
.endif
-.include <bsd.port.options.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400097
-CFLAGS+= -D__BSD_VISIBLE -D__XSI_VISIBLE
-.endif
+post-patch:
+# Drop unused dependencies
+ @${REINPLACE_CMD} -e '/cairo/d' \
+ -e '/jpeg/d' \
+ -e '/pango/d' \
+ ${WRKSRC}/src/meson.build
.ifdef GH_TUPLE
post-configure:
@@ -57,4 +51,31 @@ post-configure:
--skip-subprojects/' ${BUILD_WRKSRC}/build.ninja
.endif
+# XXX Drop after FreeBSD 13.2 EOL around 2024-05-01 (don't forget distinfo)
+.if ${CXX} == c++ && exists(/usr/lib/libc++.so)
+.if !exists(/usr/include/c++/v1/__ranges/as_rvalue_view.h) || make(makesum) || make(fetch)
+BUILD_DEPENDS+= ${CMAKE_BIN}:devel/cmake-core
+CONFIGURE_ENV+= CC="${CC}" CXX="${CXX}" CPP="${CPP}"
+CMAKE_BIN= ${LOCALBASE}/bin/cmake
+
+# XXX Move into separate port and standardize via USES
+GH_TUPLE+= llvm:llvm-project:llvmorg-16.0.1:libcxx
+CXXFLAGS+= -nostdinc++ -isystem${WRKDIR}/libcxx_prefix/include/c++/v1
+# Don't link against new libc++ as it's not necessary
+#LDFLAGS+= -nostdlib++ -L${WRKDIR}/libcxx_prefix/lib -l:libc++.a -lcxxrt
+
+pre-configure: bundled-libcxx
+bundled-libcxx:
+ @${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} \
+ -DLIBCXX_INCLUDE_BENCHMARKS:BOOL=OFF \
+ -DCMAKE_INSTALL_PREFIX:PATH=${WRKDIR}/libcxx_prefix \
+ -B ${WRKDIR}/libcxx_build -S ${WRKSRC_libcxx}/libcxx
+ @${DO_MAKE_BUILD:NDESTDIR*} install -C ${WRKDIR}/libcxx_build
+.endif
+.endif # exists(/usr/lib/libc++.so)
+
.include <bsd.port.mk>
+
+# XXX USES=compiler:gcc-c++11-lib
+RUN_DEPENDS:= ${RUN_DEPENDS:Ngcc*}
+LDFLAGS+= -static-libgcc
diff --git a/x11/xdg-desktop-portal-hyprland/distinfo b/x11/xdg-desktop-portal-hyprland/distinfo
index 0ed6ac560030..0fcd6f9c0763 100644
--- a/x11/xdg-desktop-portal-hyprland/distinfo
+++ b/x11/xdg-desktop-portal-hyprland/distinfo
@@ -1,7 +1,7 @@
-TIMESTAMP = 1691082525
-SHA256 (hyprwm-xdg-desktop-portal-hyprland-v0.5.0_GH0.tar.gz) = d346cbe170e7042d5e364242a715d021d9b8da2078a169771cf84cda13f24e76
-SIZE (hyprwm-xdg-desktop-portal-hyprland-v0.5.0_GH0.tar.gz) = 50608
+TIMESTAMP = 1694025408
+SHA256 (hyprwm-xdg-desktop-portal-hyprland-v1.0.0_GH0.tar.gz) = 558ff12ad20d8421f3279d5bd39dd431eccc667cc19babd5479edaaf21487f10
+SIZE (hyprwm-xdg-desktop-portal-hyprland-v1.0.0_GH0.tar.gz) = 41589
SHA256 (hyprwm-hyprland-protocols-v0.2_GH0.tar.gz) = 106cb189d0fbe4ec0ee11a12a17238172f4c4cd1b2b26db904df144e5c7a05f0
SIZE (hyprwm-hyprland-protocols-v0.2_GH0.tar.gz) = 6342
-SHA256 (8453779cf394.patch) = 45d3dc817e34ef6126f2326917d17258ea67e3e4cfd8fa3dff2c748616e2b9ed
-SIZE (8453779cf394.patch) = 881
+SHA256 (llvm-llvm-project-llvmorg-16.0.1_GH0.tar.gz) = b5a9ff1793b1e2d388a3819bf35797002b1d2e40bb35a10c65605e0ea1435271
+SIZE (llvm-llvm-project-llvmorg-16.0.1_GH0.tar.gz) = 179289803