aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2024-06-25 03:47:46 +0000
committerJason E. Hale <jhale@FreeBSD.org>2024-06-25 04:01:43 +0000
commit4d45e8f52336cfd0249dc73c638cfe39b06f2cc9 (patch)
treeda6bbf2118c3c8eaa090d84b37f4d39f729f041a
parente5549e61d82b731bff7e0f475e1c689ec8ccc403 (diff)
downloadports-4d45e8f52336cfd0249dc73c638cfe39b06f2cc9.tar.gz
ports-4d45e8f52336cfd0249dc73c638cfe39b06f2cc9.zip
net-im/libaccounts-qt: Fix build if DOCS is off
Move BINARY_ALIAS to the DOCS option so that the build doesn't break due to qhelpgenerator not being installed. Add graphics/graphviz as a build dependency for DOCS. If the user has the GRAPHVIZ option off in devel/doxygen, it does not get installed and causes pkg-plist errors. PR: 279946 Reported by: <tjlegg@gmail.com>
-rw-r--r--net-im/libaccounts-qt/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/net-im/libaccounts-qt/Makefile b/net-im/libaccounts-qt/Makefile
index b17872366643..267adcc46495 100644
--- a/net-im/libaccounts-qt/Makefile
+++ b/net-im/libaccounts-qt/Makefile
@@ -27,18 +27,18 @@ _USE_QT_qt5= buildtools:build core qmake:build testlib:build xml
_USE_QT_qt6= base
USE_QT= ${_USE_QT_${FLAVOR}}
-BINARY_ALIAS= qhelpgenerator=${QHELPGENERATOR}
-
PLIST_SUB= QT_VER=${FLAVOR:S/qt//}
OPTIONS_DEFINE= DOCS
OPTIONS_SUB= yes
-DOCS_BUILD_DEPENDS= doxygen:devel/doxygen
+DOCS_BUILD_DEPENDS= doxygen:devel/doxygen \
+ dot:graphics/graphviz
_DOCS_USE_qt5= QT=help:build
_DOCS_USE_qt6= QT=tools:build
DOCS_USE= ${_DOCS_USE_${FLAVOR}}
DOCS_QMAKE_ON= CONFIG+=docs
+DOCS_BINARY_ALIAS= qhelpgenerator=${QHELPGENERATOR}
pre-configure:
${REINPLACE_CMD} -e 's,$$$${INSTALL_LIBDIR},${LOCALBASE}/libdata,' \