aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2022-11-07 18:52:54 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2022-11-09 13:12:40 +0000
commit4d4c08ea1c9bbb758e51a59a25c617dc43a9c9d8 (patch)
tree610dd2e36a0eb21b953af3d1f310c65876bac797
parenta5f1cca72a5b84fe783e600eb468cf140b5e3a31 (diff)
downloadports-4d4c08ea1c9bbb758e51a59a25c617dc43a9c9d8.tar.gz
ports-4d4c08ea1c9bbb758e51a59a25c617dc43a9c9d8.zip
misc/wmScoreBoard: fix build with -fcommon
PR: 267614 Reported by: fuz@fuz.su (maintainer) MFH: 2022Q4 (build fix)
-rw-r--r--misc/wmScoreBoard/Makefile3
-rw-r--r--misc/wmScoreBoard/files/patch-xutils.c14
-rw-r--r--misc/wmScoreBoard/files/patch-xutils.h19
3 files changed, 33 insertions, 3 deletions
diff --git a/misc/wmScoreBoard/Makefile b/misc/wmScoreBoard/Makefile
index 75f66baf055c..96d32cd2d130 100644
--- a/misc/wmScoreBoard/Makefile
+++ b/misc/wmScoreBoard/Makefile
@@ -10,9 +10,6 @@ COMMENT= Window Maker dockapp that display game scores from excite
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/../COPYING
-BROKEN_FreeBSD_13= ld: error: duplicate symbol: DisplayDepth
-BROKEN_FreeBSD_14= ld: error: duplicate symbol: DisplayDepth
-
RUN_DEPENDS= wget:ftp/wget
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
diff --git a/misc/wmScoreBoard/files/patch-xutils.c b/misc/wmScoreBoard/files/patch-xutils.c
new file mode 100644
index 000000000000..4ca56fce3463
--- /dev/null
+++ b/misc/wmScoreBoard/files/patch-xutils.c
@@ -0,0 +1,14 @@
+--- xutils.c.orig 2022-11-07 09:20:08 UTC
++++ xutils.c
+@@ -39,6 +39,11 @@
+ * X11 Variables
+ */
+
++Display *display;
++Window Root;
++Window iconwin, win;
++int screen;
++int DisplayDepth;
+ int x_fd;
+ XSizeHints mysizehints;
+ XWMHints mywmhints;
diff --git a/misc/wmScoreBoard/files/patch-xutils.h b/misc/wmScoreBoard/files/patch-xutils.h
new file mode 100644
index 000000000000..ba01407b041c
--- /dev/null
+++ b/misc/wmScoreBoard/files/patch-xutils.h
@@ -0,0 +1,19 @@
+--- xutils.h.orig 2022-11-07 09:20:05 UTC
++++ xutils.h
+@@ -15,11 +15,11 @@ typedef struct {
+ * Global variables
+ */
+
+-Display *display;
+-Window Root;
+-Window iconwin, win;
+-int screen;
+-int DisplayDepth;
++extern Display *display;
++extern Window Root;
++extern Window iconwin, win;
++extern int screen;
++extern int DisplayDepth;
+
+ /*
+ * Function Prototypes