aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRodrigo Osorio <rodrigo@FreeBSD.org>2022-10-30 16:02:26 +0000
committerRodrigo Osorio <rodrigo@FreeBSD.org>2022-10-30 21:55:14 +0000
commit4dbdc33a8d7e75b863ed5ccc34a072536b97ff2d (patch)
tree0d52791d66fe886993643676180c58fffdaae231
parente9360bde1753435c0fb3769a941915ca078b6ded (diff)
downloadports-4dbdc33a8d7e75b863ed5ccc34a072536b97ff2d.tar.gz
ports-4dbdc33a8d7e75b863ed5ccc34a072536b97ff2d.zip
x11/tilda: Fix OOB write in start_default_shell()
The fix was committed to upstream in May 9, but no release was made for it until now. https://github.com/lanoxx/tilda/commit/51a980a55ad6d750daa21d43a66d44577dad277b Update Makefile to make portlint happy PR: 264270 Reported by: <iron.udjin@gmail.com> Tested by: <iron.udjin@gmail.com>
-rw-r--r--x11/tilda/Makefile15
-rw-r--r--x11/tilda/files/patch-src_tilda_terminal.c11
2 files changed, 20 insertions, 6 deletions
diff --git a/x11/tilda/Makefile b/x11/tilda/Makefile
index 5e112bfe1a6d..e5b52df0c12c 100644
--- a/x11/tilda/Makefile
+++ b/x11/tilda/Makefile
@@ -1,6 +1,7 @@
PORTNAME= tilda
PORTVERSION= 1.5.0
DISTVERSIONPREFIX= ${PORTNAME}-
+PORTREVISION= 1
CATEGORIES= x11
MAINTAINER= rodrigo@FreeBSD.org
@@ -10,17 +11,19 @@ WWW= https://github.com/lanoxx/tilda
LICENSE= GPLv2
BUILD_DEPENDS= vte3>=0:x11-toolkits/vte3
-RUN_DEPENDS= vte3>=0:x11-toolkits/vte3
LIB_DEPENDS= libconfuse.so:devel/libconfuse
+RUN_DEPENDS= vte3>=0:x11-toolkits/vte3
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-rpath
USES= gmake gettext gnome pkgconfig autoreconf pathfix libtool xorg
-USE_XORG+= x11
-USE_GNOME+= glib20 gtk30 gdkpixbuf2 pango
-INSTALL_TARGET= install-strip
USE_GITHUB= yes
GH_ACCOUNT= lanoxx
+USE_GNOME+= glib20 gtk30 gdkpixbuf2 pango
+USE_XORG+= x11
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-rpath
+
+INSTALL_TARGET= install-strip
DOCS= AUTHORS ChangeLog HACKING.md README.md TODO.md
diff --git a/x11/tilda/files/patch-src_tilda_terminal.c b/x11/tilda/files/patch-src_tilda_terminal.c
new file mode 100644
index 000000000000..d0df3b7b7af7
--- /dev/null
+++ b/x11/tilda/files/patch-src_tilda_terminal.c
@@ -0,0 +1,11 @@
+--- src/tilda_terminal.c.orig 2022-10-30 15:03:03 UTC
++++ src/tilda_terminal.c
+@@ -530,7 +530,7 @@
+ */
+ flags |= G_SPAWN_FILE_AND_ARGV_ZERO;
+ } else {
+- argv = malloc(1 * sizeof(void *));
++ argv = malloc(2 * sizeof(void *));
+ argv[0] = default_command;
+ argv[1] = NULL;
+ }