aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2023-03-20 13:59:45 +0000
committerJan Beich <jbeich@FreeBSD.org>2023-03-20 15:16:33 +0000
commit4eb651d911259975b75d7e70cf56c08736d6ee29 (patch)
treeb1d46c8290178a3964b4f3324effb27297866339
parent3d5afae595293f22d87244f6b950abbc274ece7e (diff)
downloadports-4eb651d911259975b75d7e70cf56c08736d6ee29.tar.gz
ports-4eb651d911259975b75d7e70cf56c08736d6ee29.zip
print/harfbuzz: simplify tests
Drop TEST option in favor of re-invoking build via "make test".
-rw-r--r--print/harfbuzz/Makefile18
1 files changed, 11 insertions, 7 deletions
diff --git a/print/harfbuzz/Makefile b/print/harfbuzz/Makefile
index 44775a653f77..ec46ed76f8e1 100644
--- a/print/harfbuzz/Makefile
+++ b/print/harfbuzz/Makefile
@@ -22,34 +22,38 @@ SHEBANG_GLOB= *.py
CPE_VENDOR= harfbuzz_project
MESON_ARGS= -Dglib=enabled -Dgobject=enabled -Dgraphite2=enabled \
- -Dchafa=disabled -Dfreetype=enabled
+ -Dchafa=disabled -Dfreetype=enabled -Dtests=disabled
PLIST_SUB+= LIBVER=0.60710.0
HARFBUZZ_SLAVE?= no
.if ${HARFBUZZ_SLAVE} == no
-OPTIONS_DEFINE= DOCS TEST
+OPTIONS_DEFINE= DOCS
OPTIONS_SUB= yes
DOCS_BUILD_DEPENDS= gtkdoc-scan:textproc/gtk-doc
DOCS_MESON_ENABLED= docs
-TEST_MESON_ENABLED= tests
.endif
.if ${HARFBUZZ_SLAVE} == no
MESON_ARGS+= -Dicu=disabled -Dcairo=disabled
.elif ${HARFBUZZ_SLAVE} == icu
-MESON_ARGS+= -Dicu=enabled -Dcairo=disabled -Ddocs=disabled \
- -Dtests=disabled
+MESON_ARGS+= -Dicu=enabled -Dcairo=disabled -Ddocs=disabled
LIB_DEPENDS+= libharfbuzz.so:print/harfbuzz \
libicudata.so:devel/icu
.elif ${HARFBUZZ_SLAVE} == cairo
-MESON_ARGS+= -Dcairo=enabled -Dicu=disabled -Ddocs=disabled \
- -Dtests=disabled
+MESON_ARGS+= -Dcairo=enabled -Dicu=disabled -Ddocs=disabled
LIB_DEPENDS+= libharfbuzz.so:print/harfbuzz
USE_GNOME+= cairo
.endif
+pre-test:
+ @if [ ! -e ${WRKDIR}/.meson_build_tests ]; then \
+ ${RM} ${CONFIGURE_COOKIE} ${BUILD_COOKIE}; \
+ ${MAKE} -C${.CURDIR} build MESON_ARGS="${MESON_ARGS} --reconfigure -Dtests=enabled"; \
+ ${TOUCH} ${WRKDIR}/.meson_build_tests; \
+ fi
+
.include <bsd.port.mk>