aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2022-10-15 17:51:37 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2022-10-15 17:52:15 +0000
commit4f385871cbf90a525fdd38f075f7b3a27155ac3b (patch)
treebf84b416f4adb272fcc1f75d32969239bb3bd82e
parentb5d0d7bd56c0cba7748cd49b0d695dd7cadc9f5b (diff)
downloadports-4f385871cbf90a525fdd38f075f7b3a27155ac3b.tar.gz
ports-4f385871cbf90a525fdd38f075f7b3a27155ac3b.zip
databases/redis{,62,-devel}: Amend previous commit
The openresty patches work for luajit-devel, though redis is still broken with luajit enabled.
-rw-r--r--databases/redis-devel/Makefile6
-rw-r--r--databases/redis/Makefile6
-rw-r--r--databases/redis62/Makefile6
3 files changed, 9 insertions, 9 deletions
diff --git a/databases/redis-devel/Makefile b/databases/redis-devel/Makefile
index aaad66cd0ab8..7b603d560899 100644
--- a/databases/redis-devel/Makefile
+++ b/databases/redis-devel/Makefile
@@ -64,12 +64,12 @@ LDFLAGS+= -Wl,-E
.endif
.if ${PORT_OPTIONS:MLUAJIT}
-. if ${LUAJIT_VER} == luajit-openresty
+. if ${LUAJIT_VER} == luajit
+EXTRA_PATCHES= ${PATCHDIR}/extra-patch-src-Makefile.luajit
+. else
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-src-Makefile.luajit-or \
${PATCHDIR}/extra-patch-src-function_lua.c \
${PATCHDIR}/extra-patch-deps_lua_src_lua__cjson.c
-. else
-EXTRA_PATCHES= ${PATCHDIR}/extra-patch-src-Makefile.luajit
. endif
. endif
diff --git a/databases/redis/Makefile b/databases/redis/Makefile
index 1ca005550206..721fb46b00b3 100644
--- a/databases/redis/Makefile
+++ b/databases/redis/Makefile
@@ -59,12 +59,12 @@ LDFLAGS+= -Wl,-E
.endif
.if ${PORT_OPTIONS:MLUAJIT}
-. if ${LUAJIT_VER} == luajit-openresty
+. if ${LUAJIT_VER} == luajit
+EXTRA_PATCHES= ${PATCHDIR}/extra-patch-src-Makefile.luajit
+. else
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-src-Makefile.luajit-or \
${PATCHDIR}/extra-patch-src-function_lua.c \
${PATCHDIR}/extra-patch-deps_lua_src_lua__cjson.c
-. else
-EXTRA_PATCHES= ${PATCHDIR}/extra-patch-src-Makefile.luajit
. endif
.endif
diff --git a/databases/redis62/Makefile b/databases/redis62/Makefile
index 00f2760f708c..0dc8f8473474 100644
--- a/databases/redis62/Makefile
+++ b/databases/redis62/Makefile
@@ -61,11 +61,11 @@ LDFLAGS+= -Wl,-E
.endif
.if ${PORT_OPTIONS:MLUAJIT}
-. if ${LUAJIT_VER} == luajit-openresty
+. if ${LUAJIT_VER} == luajit
+EXTRA_PATCHES= ${PATCHDIR}/extra-patch-src-Makefile.luajit
+. else
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-src-Makefile.luajit-or \
${PATCHDIR}/extra-patch-deps_lua_src_lua__cjson.c
-. else
-EXTRA_PATCHES= ${PATCHDIR}/extra-patch-src-Makefile.luajit
. endif
.endif