aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNuno Teixeira <eduardo@FreeBSD.org>2024-02-01 08:54:56 +0000
committerNuno Teixeira <eduardo@FreeBSD.org>2024-02-01 11:53:01 +0000
commit4f3fb1c3f9ba7948a1c8ece79d1e82530e88ab87 (patch)
treef06b0b68a4de4d50868a127a7ae2a5f2dbd9c665
parente36ab4e0de24f7c3b9d6b7dcfb3b8eb86bf39889 (diff)
downloadports-4f3fb1c3f9ba7948a1c8ece79d1e82530e88ab87.tar.gz
ports-4f3fb1c3f9ba7948a1c8ece79d1e82530e88ab87.zip
textproc/R-cran-reprex: New port: Prepare Reproducible Example Code via the Clipboard
Convenience wrapper that uses the 'rmarkdown' package to render small snippets of code to target formats that include both code and output. The goal is to encourage the sharing of small, reproducible, and runnable examples on code-oriented websites, such as stackoverflow.com and github.com, or in email. The user's clipboard is the default source of input code and the default target for rendered output. 'reprex' also extracts clean, runnable R code from various common formats, such as copy/paste from an R session. WWW: https://cran.r-project.org/web/packages/reprex/
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/R-cran-reprex/Makefile31
-rw-r--r--textproc/R-cran-reprex/distinfo3
-rw-r--r--textproc/R-cran-reprex/pkg-descr10
4 files changed, 45 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index b831355715c6..e702745f7781 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -21,6 +21,7 @@
SUBDIR += R-cran-readr
SUBDIR += R-cran-readxl
SUBDIR += R-cran-rematch
+ SUBDIR += R-cran-reprex
SUBDIR += R-cran-rex
SUBDIR += R-cran-rio
SUBDIR += R-cran-rmarkdown
diff --git a/textproc/R-cran-reprex/Makefile b/textproc/R-cran-reprex/Makefile
new file mode 100644
index 000000000000..2985e39b16bd
--- /dev/null
+++ b/textproc/R-cran-reprex/Makefile
@@ -0,0 +1,31 @@
+PORTNAME= reprex
+DISTVERSION= 2.1.0
+CATEGORIES= textproc
+DISTNAME= ${PORTNAME}_${DISTVERSION}
+
+MAINTAINER= eduardo@FreeBSD.org
+COMMENT= Prepare Reproducible Example Code via the Clipboard
+WWW= https://cran.r-project.org/web/packages/reprex/
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+CRAN_DEPENDS= R-cran-callr>=3.6.0:devel/R-cran-callr \
+ R-cran-cli>=3.2.0:devel/R-cran-cli \
+ R-cran-clipr>=0.4.0:devel/R-cran-clipr \
+ R-cran-fs>0:sysutils/R-cran-fs \
+ R-cran-glue>0:devel/R-cran-glue \
+ R-cran-knitr>=1.23:print/R-cran-knitr \
+ R-cran-lifecycle>0:devel/R-cran-lifecycle \
+ R-cran-rlang>=1.0.0:devel/R-cran-rlang \
+ R-cran-rmarkdown>0:textproc/R-cran-rmarkdown \
+ R-cran-rstudioapi>0:devel/R-cran-rstudioapi \
+ R-cran-withr>=2.3.0:devel/R-cran-withr
+BUILD_DEPENDS= ${CRAN_DEPENDS}
+RUN_DEPENDS= ${CRAN_DEPENDS} \
+ hs-pandoc>=2.0:textproc/hs-pandoc
+TEST_DEPENDS= R-cran-testthat>=3.0.2:devel/R-cran-testthat
+
+USES= cran:auto-plist
+
+.include <bsd.port.mk>
diff --git a/textproc/R-cran-reprex/distinfo b/textproc/R-cran-reprex/distinfo
new file mode 100644
index 000000000000..cb108b26d331
--- /dev/null
+++ b/textproc/R-cran-reprex/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1706692524
+SHA256 (reprex_2.1.0.tar.gz) = 0a0dfe5976e5ddb908d5a7582b11cbddee342e99d8dbd64b08ff64c1e705a951
+SIZE (reprex_2.1.0.tar.gz) = 1088629
diff --git a/textproc/R-cran-reprex/pkg-descr b/textproc/R-cran-reprex/pkg-descr
new file mode 100644
index 000000000000..2850919f97e4
--- /dev/null
+++ b/textproc/R-cran-reprex/pkg-descr
@@ -0,0 +1,10 @@
+Convenience wrapper that uses the 'rmarkdown' package to render small
+snippets of code to target formats that include both code and output.
+
+The goal is to encourage the sharing of small, reproducible, and runnable
+examples on code-oriented websites, such as stackoverflow.com and
+github.com, or in email.
+
+The user's clipboard is the default source of input code and the default
+target for rendered output. 'reprex' also extracts clean, runnable R code
+from various common formats, such as copy/paste from an R session.