aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-03-23 14:23:51 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-03-23 14:49:39 +0000
commit4fdef02afc948dc2fb0e4cd6b858171c7d415037 (patch)
treee6f93d878f50bc78d91c1236f007183aca2342d9
parent63b5f8fea99a26eb49516b596e8d8ed204038efd (diff)
downloadports-4fdef02afc948dc2fb0e4cd6b858171c7d415037.tar.gz
ports-4fdef02afc948dc2fb0e4cd6b858171c7d415037.zip
x11-fonts/py-cffsubr: Update to 0.3.0
- Remove PY_SETUPTOOLS: py-setuptools should be used rather than PY_SETUPTOOLS Changes: https://github.com/adobe-type-tools/cffsubr/releases
-rw-r--r--x11-fonts/py-cffsubr/Makefile6
-rw-r--r--x11-fonts/py-cffsubr/distinfo6
-rw-r--r--x11-fonts/py-cffsubr/files/patch-pyproject.toml11
-rw-r--r--x11-fonts/py-cffsubr/files/patch-setup.py22
4 files changed, 18 insertions, 27 deletions
diff --git a/x11-fonts/py-cffsubr/Makefile b/x11-fonts/py-cffsubr/Makefile
index 6ad6a2481aa2..8b1b87be4eca 100644
--- a/x11-fonts/py-cffsubr/Makefile
+++ b/x11-fonts/py-cffsubr/Makefile
@@ -1,6 +1,5 @@
PORTNAME= cffsubr
-PORTVERSION= 0.2.9.post1
-PORTREVISION= 2
+PORTVERSION= 0.3.0
CATEGORIES= x11-fonts python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,8 +11,7 @@ WWW= https://github.com/adobe-type-tools/cffsubr
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PY_SETUPTOOLS} \
- ${PYTHON_PKGNAMEPREFIX}setuptools_git_ls_files>=0:devel/py-setuptools_git_ls_files@${PY_FLAVOR} \
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}setuptools-scm>=0:devel/py-setuptools-scm@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= tx:x11-fonts/afdko \
diff --git a/x11-fonts/py-cffsubr/distinfo b/x11-fonts/py-cffsubr/distinfo
index 934b510c85ca..b96a4edbf99b 100644
--- a/x11-fonts/py-cffsubr/distinfo
+++ b/x11-fonts/py-cffsubr/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1646057862
-SHA256 (cffsubr-0.2.9.post1.tar.gz) = 6b31412dcf49c8fa84664bda867e2eddc55b6fe6fa696ff253c4f13a9ff2fc5c
-SIZE (cffsubr-0.2.9.post1.tar.gz) = 12671095
+TIMESTAMP = 1710712574
+SHA256 (cffsubr-0.3.0.tar.gz) = 7745150bdb81679facdd11c1f3b87096c4f4dbd4957e8fcebb88c45687952efb
+SIZE (cffsubr-0.3.0.tar.gz) = 17830033
diff --git a/x11-fonts/py-cffsubr/files/patch-pyproject.toml b/x11-fonts/py-cffsubr/files/patch-pyproject.toml
new file mode 100644
index 000000000000..ab10b421dc94
--- /dev/null
+++ b/x11-fonts/py-cffsubr/files/patch-pyproject.toml
@@ -0,0 +1,11 @@
+--- pyproject.toml.orig 2024-01-18 11:25:11 UTC
++++ pyproject.toml
+@@ -3,8 +3,5 @@ requires = [
+ "setuptools",
+ "setuptools_scm",
+ ]
+-# https://setuptools.pypa.io/en/latest/build_meta.html#dynamic-build-dependencies-and-other-build-meta-tweaks
+-build-backend = "backend"
+-backend-path = ["_custom_build"]
+ [tool.setuptools_scm]
+ write_to = "src/cffsubr/_version.py"
diff --git a/x11-fonts/py-cffsubr/files/patch-setup.py b/x11-fonts/py-cffsubr/files/patch-setup.py
index cbbdca8803a1..80e391e7bfc0 100644
--- a/x11-fonts/py-cffsubr/files/patch-setup.py
+++ b/x11-fonts/py-cffsubr/files/patch-setup.py
@@ -1,16 +1,6 @@
---- setup.py.orig 2021-11-25 15:57:49 UTC
+--- setup.py.orig 2024-01-18 11:25:11 UTC
+++ setup.py
-@@ -107,6 +107,9 @@ elif platform.system() == "Darwin":
- elif platform.system() == "Windows":
- plat = "win"
- compiler = "visualstudio"
-+elif platform.system() == "FreeBSD":
-+ plat = "freebsd"
-+ compiler = "cc"
- else:
- raise NotImplementedError(platform.system())
-
-@@ -136,7 +139,6 @@ setup(
+@@ -104,7 +104,6 @@ setup(
package_dir={"": "src"},
packages=find_packages("src"),
entry_points={"console_scripts": ["cffsubr = cffsubr.__main__:main"]},
@@ -18,11 +8,3 @@
zip_safe=False,
cmdclass=cmdclass,
install_requires=[
-@@ -146,7 +148,6 @@ setup(
- setup_requires=[
- "setuptools_scm",
- # finds all git tracked files including submodules when making sdist MANIFEST
-- "setuptools-git-ls-files",
- ],
- extras_require={"testing": ["pytest"]},
- python_requires=">=3.6",