aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-03 18:36:36 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-03 19:59:23 +0000
commit4fec4429208ad765eeb85fdab532a4b0be7b5fb4 (patch)
treee9dfde4024a6ba7c8c9fc823d33e19fb94313865
parent08ec0f71fd637b4e2a1de4a58a9668ca06045f28 (diff)
downloadports-4fec4429208ad765eeb85fdab532a4b0be7b5fb4.tar.gz
ports-4fec4429208ad765eeb85fdab532a4b0be7b5fb4.zip
lang/php80: Mark IGNORE_SSL for base
Considering that OpenSSL 3.0.9 will be merged at OSVERSION 1400089 mark IGNORE_SSL for base ssl version. In case this happens later we will fix the OSVERSION. PR: 271656 Sponsored by: Bounce Experts
-rw-r--r--lang/php80/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/lang/php80/Makefile b/lang/php80/Makefile
index e20a3bcbd230..5c51d25e8181 100644
--- a/lang/php80/Makefile
+++ b/lang/php80/Makefile
@@ -35,8 +35,6 @@ CONFIGURE_ARGS+= \
--with-password-argon2=${LOCALBASE}
USES+= autoreconf:build localbase ssl
-IGNORE_SSL= openssl30 openssl31
-IGNORE_SSL_REASON= Missing upstream support for openssl30 and later
USE_GNOME= libxml2
LDFLAGS= -L${OPENSSLLIB} -lcrypto -lssl
@@ -101,6 +99,13 @@ SHORTMODNAME= php
WARNING= "!!! If you have a threaded Apache, you must build ${PHP_PORT} with ZTS support to enable thread-safety in extensions !!!"
.endif
+.include <bsd.port.options.mk>
+
+.if ( ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400089 && ${SSL_DEFAULT} == base ) || ${SSL_DEFAULT:Mopenssl3*}
+IGNORE_SSL= base openssl30 openssl31
+IGNORE_SSL_REASON= Missing upstream support for OpenSSL 3.0.0 and later
+.endif
+
.include <bsd.port.pre.mk>
.if ${ARCH} == riscv64