aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Leres <leres@FreeBSD.org>2023-03-20 03:37:28 +0000
committerCraig Leres <leres@FreeBSD.org>2023-03-20 03:37:28 +0000
commit502fa56edbf3877c186a8203a782a441df60b6bc (patch)
treebb2a62d35047d15aa1256dcb3c9f0c290024d96f
parentcadd4725f3e8bae43a9a030996324767d2bfafbd (diff)
downloadports-502fa56edbf3877c186a8203a782a441df60b6bc.tar.gz
ports-502fa56edbf3877c186a8203a782a441df60b6bc.zip
net/savvycan: Update to V208
Changes since 1.0.245: - ++PORTEPOCH - VERY large changes to DBC interface. - Now loaded DBC files that were loaded when the program was exited will be loaded when it is restarted - GMLAN filtering support - The entire way the DBC file is presented is entirely new now. The DBC is presented as a treeview with icons - It is now possible to search for DBC signals and messages by name and ID - Help files are now just HTML files - Bugfixes to a few different file format loads (CANAlyzer for one) - Large changes and bug fixes to ISO-TP / UDS decoder. It actually works now. - Backend is now more compatible with QCanBusFrame and potentially is better geared toward CAN-FD support (though CAN-FD is not supported properly yet) - Added text boxes to Fuzzing window so the values can more easily be set and viewed - Fixes for Sniffer Window - Changed to logarithmic view for bit counts in Frame Details Window. This makes it far easier to see the distribution. - Added a special CAN driver that allows for tunneling CAN traffic over MQTT back and forth to SavvyCAN - Added ability to load Tesla AP Snapshots. How you would get those is up to you. - Several bug fixes for file loading - Huge changes to graphing interface to support many different visualization modes - Ability to filter main CAN frame view by bus - Support for extended multiplexing (in DBC files) - Bug fixes for fuzzing window, overwrite mode - Now graphs of signals with DBC value tables will be annotated with the value strings and brackets - The graphing window can be opened multiple times now with different graphs in each window - Graphing of multiplexed signals should be correct now - DBC signals are utilized if available in the Frame Data Analysis window to give more analysis - The File Comparison window will now also use DBC signals to compare signal differences between the two sides. This is currently slow and poorly done. But, it works. - PCAN version 1.3 files are now supported for loading - Updated help files - Fixed some bugs in DBC code - Added ability to read CANServer binary log files - Support drag/drop files onto app icon - Fixes to ISO-TP decoding - Datagrid now can show signal names when doing DBC edits - Added ability to set notch and expire intervals in sniffer - Support for reading wireshark files - Added preliminary support for lawicel devices (not great yet) - UDS Scan window has been redone to make it more configurable - Increased support for CAN-FD. It's not complete yet but some things support CAN-FD now - Bisector window can now break frames along bus boundaries - Graphing window can now respect bus number so the same ID but on multiple buses won't break things any longer. Reported by: portscout
-rw-r--r--net/savvycan/Makefile32
-rw-r--r--net/savvycan/distinfo6
-rw-r--r--net/savvycan/files/patch-connections_connectionwindow.cpp10
3 files changed, 10 insertions, 38 deletions
diff --git a/net/savvycan/Makefile b/net/savvycan/Makefile
index ce311016ae93..9e850f52e1f8 100644
--- a/net/savvycan/Makefile
+++ b/net/savvycan/Makefile
@@ -1,7 +1,6 @@
PORTNAME= savvycan
-PORTVERSION= 1.0.245
-PORTREVISION= 1
-PORTEPOCH= 1
+PORTVERSION= 208
+PORTEPOCH= 2
CATEGORIES= net
MAINTAINER= leres@FreeBSD.org
@@ -10,43 +9,26 @@ WWW= https://www.savvycan.com/
LICENSE= MIT
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>=0,1:textproc/py-sphinx@${PY_FLAVOR}
-
USES= compiler:c++11-lang gmake python:build,3.6+ qmake qt:5
-USE_QT= buildtools:build core gui help printsupport serialbus \
- serialport websockets-qml widgets
+USE_QT= core gui help network opengl printsupport serialbus serialport \
+ websockets-qml widgets buildtools:build
USE_GITHUB= yes
-GH_TUPLE= collin80:SavvyCAN:${DISTVERSIONPREFIX}${PORTVERSION}
+GH_TUPLE= collin80:SavvyCAN:V${PORTVERSION}
NO_MTREE= yes
-PLIST_FILES= bin/savvycan \
- man/man1/savvycan.1.gz
+PLIST_FILES= bin/savvycan
PORTSCOUT= skipv:continuous
-OPTIONS_DEFINE+= DOCS EXAMPLES
+OPTIONS_DEFINE+= EXAMPLES
-PORTDOCS= *
PORTEXAMPLES= *
.include <bsd.port.options.mk>
-post-build:
- cd ${WRKSRC}/docs && ${GMAKE} man
-.if ${PORT_OPTIONS:MDOCS}
- cd ${WRKSRC}/docs && ${GMAKE} html
-.endif
-
do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/SavvyCAN ${STAGEDIR}${PREFIX}/bin/savvycan
- ${MKDIR} ${STAGEDIR}${MANPREFIX}/man/man1
- ${INSTALL_MAN} ${WRKSRC}/docs/build/man/savvycan.1 \
- ${STAGEDIR}${MANPREFIX}/man/man1
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
- cd ${WRKSRC}/docs/build && ${COPYTREE_SHARE} html ${STAGEDIR}${DOCSDIR}
-.endif
.if ${PORT_OPTIONS:MEXAMPLES}
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}
diff --git a/net/savvycan/distinfo b/net/savvycan/distinfo
index 1dd547852b4a..88c8e39243f2 100644
--- a/net/savvycan/distinfo
+++ b/net/savvycan/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1640463819
-SHA256 (collin80-SavvyCAN-1.0.245_GH0.tar.gz) = 347c6bf143ba09e6002068f7484d13179f54bef4a077980eafd4a3c06f0e18bf
-SIZE (collin80-SavvyCAN-1.0.245_GH0.tar.gz) = 5027669
+TIMESTAMP = 1679276294
+SHA256 (collin80-SavvyCAN-208-V208_GH0.tar.gz) = 3454dc4f3d03ca083b0c2c962f3ccc41bccaf0ffdb303e4c8becc5339c491140
+SIZE (collin80-SavvyCAN-208-V208_GH0.tar.gz) = 3267604
diff --git a/net/savvycan/files/patch-connections_connectionwindow.cpp b/net/savvycan/files/patch-connections_connectionwindow.cpp
deleted file mode 100644
index dbbdc7187e0f..000000000000
--- a/net/savvycan/files/patch-connections_connectionwindow.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- connections/connectionwindow.cpp.orig 2022-10-01 20:28:59 UTC
-+++ connections/connectionwindow.cpp
-@@ -62,6 +62,7 @@ ConnectionWindow::ConnectionWindow(QWidget *parent) :
- connect(ui->btnMoveUp, &QPushButton::clicked, this, &ConnectionWindow::moveConnUp);
- connect(ui->btnMoveDown, &QPushButton::clicked, this, &ConnectionWindow::moveConnDown);
-
-+ ui->cbBusSpeed->addItem("33333");
- ui->cbBusSpeed->addItem("50000");
- ui->cbBusSpeed->addItem("100000");
- ui->cbBusSpeed->addItem("125000");