aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRainer Hurling <rhurlin@FreeBSD.org>2021-05-06 07:49:08 +0000
committerRainer Hurling <rhurlin@FreeBSD.org>2021-05-06 07:54:43 +0000
commit5041f74ee3a6f603d9083114fc5f6f796a899402 (patch)
tree580715a197ab757556d5155e554fcf7bd16e9b72
parent67fba013d7e76fd02d7cc23be537a0e424337d79 (diff)
downloadports-5041f74ee3a6f603d9083114fc5f6f796a899402.tar.gz
ports-5041f74ee3a6f603d9083114fc5f6f796a899402.zip
textproc/py-pyls-spyder: Update to 0.4.0
- Use python-lsp-server instead of python-language-server - Make utf-8 ready for python36 Reported by: Repology
-rw-r--r--textproc/py-pyls-spyder/Makefile4
-rw-r--r--textproc/py-pyls-spyder/distinfo6
-rw-r--r--textproc/py-pyls-spyder/files/patch-setup.py11
3 files changed, 16 insertions, 5 deletions
diff --git a/textproc/py-pyls-spyder/Makefile b/textproc/py-pyls-spyder/Makefile
index fdcb05780b2e..6588e07c76e2 100644
--- a/textproc/py-pyls-spyder/Makefile
+++ b/textproc/py-pyls-spyder/Makefile
@@ -1,7 +1,7 @@
# Created by: Rainer Hurling <rhurlin@gwdg.de>
PORTNAME= pyls-spyder
-PORTVERSION= 0.3.2
+PORTVERSION= 0.4.0
CATEGORIES= textproc python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,7 +12,7 @@ COMMENT= Spyder extensions for the python-language-server (pyls)
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}python-language-server>0:textproc/py-python-language-server@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}python-lsp-server>0:textproc/py-python-lsp-server@${PY_FLAVOR}
USES= python:3.6+
USE_PYTHON= autoplist concurrent distutils
diff --git a/textproc/py-pyls-spyder/distinfo b/textproc/py-pyls-spyder/distinfo
index 6862d3426054..6841298e0373 100644
--- a/textproc/py-pyls-spyder/distinfo
+++ b/textproc/py-pyls-spyder/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1614413190
-SHA256 (pyls-spyder-0.3.2.tar.gz) = f2be1b05f2c7a72565b28de7289d2c2b16052b88e46914279a2d631e074ed158
-SIZE (pyls-spyder-0.3.2.tar.gz) = 7357
+TIMESTAMP = 1619798220
+SHA256 (pyls-spyder-0.4.0.tar.gz) = 45a321c83f64267d82907492c55199fccabda45bc872dd23bf1efd08edac1b0b
+SIZE (pyls-spyder-0.4.0.tar.gz) = 7427
diff --git a/textproc/py-pyls-spyder/files/patch-setup.py b/textproc/py-pyls-spyder/files/patch-setup.py
new file mode 100644
index 000000000000..74dd38bd1565
--- /dev/null
+++ b/textproc/py-pyls-spyder/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2021-04-29 20:01:20 UTC
++++ setup.py
+@@ -33,7 +33,7 @@ def get_version(module='pyls_spyder'):
+
+ def get_description():
+ """Get long description."""
+- with open(os.path.join(HERE, 'README.md'), 'r') as f:
++ with open(os.path.join(HERE, 'README.md'), 'r', encoding='utf8') as f:
+ data = f.read()
+ return data
+