aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-10-08 11:52:38 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-10-08 11:52:38 +0000
commit5046c0c3a8a18d6ee9c87477236cec2eb8bb5545 (patch)
tree4a643f246001949da39b378758b9d43609ce785d
parentd142b1f5ed5be6acc1c72a32a552035ba89af8e4 (diff)
downloadports-5046c0c3a8a18d6ee9c87477236cec2eb8bb5545.tar.gz
ports-5046c0c3a8a18d6ee9c87477236cec2eb8bb5545.zip
textproc/py-sphinx-gallery: Add py-sphinx-gallery 0.14.0
Sphinx-Gallery is a Sphinx extension that builds an HTML gallery of examples from any set of Python scripts. Features: - Create example galleries automatically by running pure Python example scripts while capturing outputs + figures, rendering them into reST files built into your documentation by Sphinx - Embed reST in your example Python files, allowing you to interweave narrative-like content with code that generates plots in your documentation. Sphinx-Gallery also automatically generates a Jupyter Notebook for each your example page. - Add mini-galleries for API documentation. Sphinx-Gallery can generate mini-galleries listing all examples that use a particular function/method/etc. - Add intersphinx links to your examples. Sphinx-Gallery can automatically add links to API documentation for functions/methods/classes that are used in your examples (for any Python module that uses intersphinx). - Manage multiple galleries to create and embed galleries for several folders of examples.
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-sphinx-gallery/Makefile22
-rw-r--r--textproc/py-sphinx-gallery/distinfo3
-rw-r--r--textproc/py-sphinx-gallery/pkg-descr18
4 files changed, 44 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 6abe99331807..96b51a69cffc 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1558,6 +1558,7 @@
SUBDIR += py-sphinx-copybutton
SUBDIR += py-sphinx-design
SUBDIR += py-sphinx-examples
+ SUBDIR += py-sphinx-gallery
SUBDIR += py-sphinx-inline-tabs
SUBDIR += py-sphinx-intl
SUBDIR += py-sphinx-issues
diff --git a/textproc/py-sphinx-gallery/Makefile b/textproc/py-sphinx-gallery/Makefile
new file mode 100644
index 000000000000..14cb56fc63f2
--- /dev/null
+++ b/textproc/py-sphinx-gallery/Makefile
@@ -0,0 +1,22 @@
+PORTNAME= sphinx-gallery
+PORTVERSION= 0.14.0
+CATEGORIES= textproc python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Sphinx extension that builds an HTML gallery of examples from any set of Python scripts
+WWW= https://sphinx-gallery.github.io/stable/ \
+ https://github.com/sphinx-gallery/sphinx-gallery
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>=4,1:textproc/py-sphinx@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/py-sphinx-gallery/distinfo b/textproc/py-sphinx-gallery/distinfo
new file mode 100644
index 000000000000..2a4c24f0e89f
--- /dev/null
+++ b/textproc/py-sphinx-gallery/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1696753604
+SHA256 (sphinx-gallery-0.14.0.tar.gz) = 2a4a0aaf032955508e1d0f3495199a3c7819ce420e71096bff0bca551a4043c2
+SIZE (sphinx-gallery-0.14.0.tar.gz) = 408734
diff --git a/textproc/py-sphinx-gallery/pkg-descr b/textproc/py-sphinx-gallery/pkg-descr
new file mode 100644
index 000000000000..cd250d65da38
--- /dev/null
+++ b/textproc/py-sphinx-gallery/pkg-descr
@@ -0,0 +1,18 @@
+Sphinx-Gallery is a Sphinx extension that builds an HTML gallery of examples
+from any set of Python scripts.
+
+Features:
+- Create example galleries automatically by running pure Python example scripts
+ while capturing outputs + figures, rendering them into reST files built into
+ your documentation by Sphinx
+- Embed reST in your example Python files, allowing you to interweave
+ narrative-like content with code that generates plots in your documentation.
+ Sphinx-Gallery also automatically generates a Jupyter Notebook for each your
+ example page.
+- Add mini-galleries for API documentation. Sphinx-Gallery can generate
+ mini-galleries listing all examples that use a particular function/method/etc.
+- Add intersphinx links to your examples. Sphinx-Gallery can automatically add
+ links to API documentation for functions/methods/classes that are used in your
+ examples (for any Python module that uses intersphinx).
+- Manage multiple galleries to create and embed galleries for several folders of
+ examples.