aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-09-30 23:30:20 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-09-30 23:30:20 +0000
commit506fee9bb841fab48012c3683326a45ffe00d110 (patch)
tree3cab9ed786fa7baf89642523a202dac2707b1a1d
parent60cefaecb9fcc6e2bd3c31fa65f132af3bab5ea3 (diff)
downloadports-506fee9bb841fab48012c3683326a45ffe00d110.tar.gz
ports-506fee9bb841fab48012c3683326a45ffe00d110.zip
www/py-django-allauth: Add MFA and SAML options
-rw-r--r--www/py-django-allauth/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/www/py-django-allauth/Makefile b/www/py-django-allauth/Makefile
index 5b5bc18727b8..bb0509a0a7f8 100644
--- a/www/py-django-allauth/Makefile
+++ b/www/py-django-allauth/Makefile
@@ -25,4 +25,11 @@ USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
+OPTIONS_DEFINE= MFA SAML
+MFA_DESC= Multi-Factor Authentication support
+SAML_DESC= Security Assertion Markup Language support
+
+MFA_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}qrcode>=7.0.0:textproc/py-qrcode@${PY_FLAVOR}
+SAML_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}python3-saml>=1.15.0<2.0.0:security/py-python3-saml@${PY_FLAVOR}
+
.include <bsd.port.mk>