aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNeel Chauhan <nc@FreeBSD.org>2021-05-27 02:41:16 +0000
committerNeel Chauhan <nc@FreeBSD.org>2021-05-27 02:41:16 +0000
commit507359c509389602b4060b2c5e203c99911c3578 (patch)
treee4f9a7cba2606f96be22ba06ba7863b01dda568a
parent1309a4a76e93cd933e7d7049f576136e7cb62d2e (diff)
downloadports-507359c509389602b4060b2c5e203c99911c3578.tar.gz
ports-507359c509389602b4060b2c5e203c99911c3578.zip
devel/glib20: Update to 2.68.2
-rw-r--r--devel/glib20/Makefile5
-rw-r--r--devel/glib20/distinfo6
-rw-r--r--devel/glib20/files/patch-glib_meson.build10
-rw-r--r--devel/glib20/files/patch-glib_tests_gdatetime.c20
-rw-r--r--devel/glib20/pkg-plist1
5 files changed, 21 insertions, 21 deletions
diff --git a/devel/glib20/Makefile b/devel/glib20/Makefile
index 59e08b25c9ef..cdea3554f3a1 100644
--- a/devel/glib20/Makefile
+++ b/devel/glib20/Makefile
@@ -1,8 +1,7 @@
# Created by: Vanilla I. Shu <vanilla@FreeBSD.org>
PORTNAME= glib
-DISTVERSION= 2.66.7
-PORTREVISION= 1
+DISTVERSION= 2.68.2
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= GNOME
@@ -32,7 +31,7 @@ MESON_ARGS= -Db_lundef=false \
BINARY_ALIAS= python3=${PYTHON_CMD}
PORTSCOUT= limitw:1,even
-_LIBVERSION= 0.6600.7
+_LIBVERSION= 0.6800.2
PLIST_SUB= LIBVERSION=${_LIBVERSION}
OPTIONS_DEFINE= DEBUG FAM_ALTBACKEND MANPAGES NLS
diff --git a/devel/glib20/distinfo b/devel/glib20/distinfo
index 5363bd9180e3..2aa909ffa58a 100644
--- a/devel/glib20/distinfo
+++ b/devel/glib20/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1613215761
-SHA256 (gnome/glib-2.66.7.tar.xz) = 09f158769f6f26b31074e15b1ac80ec39b13b53102dfae66cfe826fb2cc65502
-SIZE (gnome/glib-2.66.7.tar.xz) = 4844892
+TIMESTAMP = 1622082621
+SHA256 (gnome/glib-2.68.2.tar.xz) = ecc7798a9cc034eabdfd7f246e6dd461cdbf1175fcc2e9867cc7da7b7309e0fb
+SIZE (gnome/glib-2.68.2.tar.xz) = 4944192
diff --git a/devel/glib20/files/patch-glib_meson.build b/devel/glib20/files/patch-glib_meson.build
index e42c509110d2..6be437f22882 100644
--- a/devel/glib20/files/patch-glib_meson.build
+++ b/devel/glib20/files/patch-glib_meson.build
@@ -1,11 +1,11 @@
---- glib/meson.build.orig 2021-02-18 15:31:48.638470000 -0800
-+++ glib/meson.build 2021-02-18 15:32:08.983695000 -0800
-@@ -376,7 +376,7 @@
+--- glib/meson.build.orig 2021-05-26 19:31:21.839171000 -0700
++++ glib/meson.build 2021-05-26 19:31:36.723873000 -0700
+@@ -377,7 +377,7 @@
# intl.lib is not compatible with SAFESEH
link_args : [noseh_link_args, glib_link_flags, win32_ldflags],
include_directories : configinc,
-- dependencies : pcre_deps + [thread_dep, librt] + libintl_deps + libiconv + platform_deps + gnulib_libm_dependency + [libsysprof_capture_dep],
-+ dependencies : pcre_deps + [thread_dep, librt] + libintl_deps + libiconv + platform_deps + gnulib_libm_dependency + [libsysprof_capture_dep] + libutil,
+- dependencies : pcre_deps + [thread_dep, librt] + libintl_deps + libiconv + platform_deps + [gnulib_libm_dependency, libm] + [libsysprof_capture_dep],
++ dependencies : pcre_deps + [thread_dep, librt] + libintl_deps + libiconv + platform_deps + [gnulib_libm_dependency, libm] + [libsysprof_capture_dep] + libutil,
c_args : glib_c_args,
objc_args : glib_c_args,
)
diff --git a/devel/glib20/files/patch-glib_tests_gdatetime.c b/devel/glib20/files/patch-glib_tests_gdatetime.c
index 3904e106a0ca..c02b8ea5c481 100644
--- a/devel/glib20/files/patch-glib_tests_gdatetime.c
+++ b/devel/glib20/files/patch-glib_tests_gdatetime.c
@@ -1,20 +1,20 @@
---- glib/tests/gdatetime.c.orig 2014-03-09 10:29:13.925231275 +0000
-+++ glib/tests/gdatetime.c 2014-03-09 10:30:18.235227107 +0000
-@@ -1322,7 +1322,7 @@
+--- glib/tests/gdatetime.c.orig 2021-05-26 19:32:37.257501000 -0700
++++ glib/tests/gdatetime.c 2021-05-26 19:32:53.078466000 -0700
+@@ -2377,7 +2377,7 @@
gint i1, i2;
#ifdef G_OS_UNIX
-- tz = g_time_zone_new ("America/Toronto");
-+ tz = g_time_zone_new ("America/Toronto Eastern");
+- tz = g_time_zone_new_identifier ("America/Toronto");
++ tz = g_time_zone_new_identifier ("America/Toronto Eastern");
#elif defined G_OS_WIN32
- tz = g_time_zone_new ("Eastern Standard Time");
+ tz = g_time_zone_new_identifier ("Eastern Standard Time");
#endif
-@@ -1355,7 +1355,7 @@
+@@ -2411,7 +2411,7 @@
gint i1, i2;
#ifdef G_OS_UNIX
-- tz = g_time_zone_new ("America/Toronto");
-+ tz = g_time_zone_new ("America/Toronto Eastern");
+- tz = g_time_zone_new_identifier ("America/Toronto");
++ tz = g_time_zone_new_identifier ("America/Toronto Eastern");
#elif defined G_OS_WIN32
- tz = g_time_zone_new ("Eastern Standard Time");
+ tz = g_time_zone_new_identifier ("Eastern Standard Time");
#endif
diff --git a/devel/glib20/pkg-plist b/devel/glib20/pkg-plist
index 275cfdac0119..a292150ea817 100644
--- a/devel/glib20/pkg-plist
+++ b/devel/glib20/pkg-plist
@@ -242,6 +242,7 @@ include/glib-2.0/glib/gstdio.h
include/glib-2.0/glib/gstrfuncs.h
include/glib-2.0/glib/gstring.h
include/glib-2.0/glib/gstringchunk.h
+include/glib-2.0/glib/gstrvbuilder.h
include/glib-2.0/glib/gtestutils.h
include/glib-2.0/glib/gthread.h
include/glib-2.0/glib/gthreadpool.h