aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Cochard <olivier@FreeBSD.org>2021-10-13 09:03:18 +0000
committerOlivier Cochard <olivier@FreeBSD.org>2021-10-13 09:03:18 +0000
commit508036a7d578dee2d4264a039941d10c76b60b6d (patch)
tree00624165410ac80e5dbd174a6c0669f3572f951f
parentc55f38a3bc5493967a35b969ec0b442d2a9ff180 (diff)
downloadports-508036a7d578dee2d4264a039941d10c76b60b6d.tar.gz
ports-508036a7d578dee2d4264a039941d10c76b60b6d.zip
www/shellinabox: fix ssh command line options
PR: 258838 Reported by: Felix Palmen <felix@palmen-it.de>
-rw-r--r--www/shellinabox/Makefile2
-rw-r--r--www/shellinabox/files/patch-shellinabox_service.c12
2 files changed, 11 insertions, 3 deletions
diff --git a/www/shellinabox/Makefile b/www/shellinabox/Makefile
index fb7f5c1a58ed..c414a708bec3 100644
--- a/www/shellinabox/Makefile
+++ b/www/shellinabox/Makefile
@@ -3,7 +3,7 @@
PORTNAME= shellinabox
PORTVERSION= 2.20
DISTVERSIONPREFIX= v
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= www
MAINTAINER= olivier@FreeBSD.org
diff --git a/www/shellinabox/files/patch-shellinabox_service.c b/www/shellinabox/files/patch-shellinabox_service.c
index 30c91ccb436c..fd708ab9df11 100644
--- a/www/shellinabox/files/patch-shellinabox_service.c
+++ b/www/shellinabox/files/patch-shellinabox_service.c
@@ -1,6 +1,14 @@
---- shellinabox/service.c.orig
+--- shellinabox/service.c.orig 2016-11-09 19:40:33 UTC
+++ shellinabox/service.c
-@@ -175,8 +175,7 @@ void initService(struct Service *service, const char *
+@@ -169,14 +169,13 @@ void initService(struct Service *service, const char *
+ }
+
+ service->cmdline = stringPrintf(NULL,
+- "ssh -a -e none -i /dev/null -x -oChallengeResponseAuthentication=no "
++ "ssh -a -e none -i /dev/null -x "
+ "-oCheckHostIP=no -oClearAllForwardings=yes -oCompression=no "
+- "-oControlMaster=no -oGSSAPIAuthentication=no "
++ "-oControlMaster=no "
"-oHostbasedAuthentication=no -oIdentitiesOnly=yes "
"-oKbdInteractiveAuthentication=yes -oPasswordAuthentication=yes "
"-oPreferredAuthentications=keyboard-interactive,password "