aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2023-09-27 13:57:26 +0000
committerDima Panov <fluffy@FreeBSD.org>2023-09-27 14:36:28 +0000
commit50ace901b044edd6b46a0e5ad59f4b76733da90c (patch)
tree09d8ba671132f8aa13e0b390c1abcbc135737d15
parent659620f1586eafcf14a22c6a58ae7cabb943d869 (diff)
downloadports-50ace901b044edd6b46a0e5ad59f4b76733da90c.tar.gz
ports-50ace901b044edd6b46a0e5ad59f4b76733da90c.zip
devel/cpp-netlib: fix build after Boost-1.83.0 update
-rw-r--r--devel/cpp-netlib/Makefile2
-rw-r--r--devel/cpp-netlib/files/patch-boost_network_protocol_http_server_impl_parsers.ipp19
2 files changed, 20 insertions, 1 deletions
diff --git a/devel/cpp-netlib/Makefile b/devel/cpp-netlib/Makefile
index 926a2253bdf6..9a07aa0ec2c1 100644
--- a/devel/cpp-netlib/Makefile
+++ b/devel/cpp-netlib/Makefile
@@ -1,7 +1,7 @@
PORTNAME= cpp-netlib
DISTVERSIONPREFIX= ${PORTNAME}-
DISTVERSION= 0.13.0
-PORTREVISION= 5
+PORTREVISION= 6
DISTVERSIONSUFFIX= -final
CATEGORIES= devel
diff --git a/devel/cpp-netlib/files/patch-boost_network_protocol_http_server_impl_parsers.ipp b/devel/cpp-netlib/files/patch-boost_network_protocol_http_server_impl_parsers.ipp
new file mode 100644
index 000000000000..f79c467225af
--- /dev/null
+++ b/devel/cpp-netlib/files/patch-boost_network_protocol_http_server_impl_parsers.ipp
@@ -0,0 +1,19 @@
+--- boost/network/protocol/http/server/impl/parsers.ipp.orig 2018-07-19 06:37:41 UTC
++++ boost/network/protocol/http/server/impl/parsers.ipp
+@@ -13,6 +13,7 @@
+ #include <tuple>
+ #include <boost/fusion/include/std_tuple.hpp>
+ #include <boost/network/protocol/http/message/header.hpp>
++#include <boost/regex/pending/unicode_iterator.hpp>
+
+ #ifdef BOOST_NETWORK_NO_LIB
+ #ifndef BOOST_NETWORK_INLINE
+@@ -32,7 +33,7 @@ struct assign_to_container_from_value<std::string, u32
+ template <> // <typename Attrib, typename T, typename Enable>
+ struct assign_to_container_from_value<std::string, u32_string, void> {
+ static void call(u32_string const& val, std::string& attr) {
+- u32_to_u8_iterator<u32_string::const_iterator> begin = val.begin(),
++ boost::u32_to_u8_iterator<u32_string::const_iterator> begin = val.begin(),
+ end = val.end();
+ for (; begin != end; ++begin) attr += *begin;
+ }