aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2024-02-05 23:18:52 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2024-02-05 23:18:56 +0000
commit513740cc8e824a4d53853a38a5470a9d3bcd6996 (patch)
tree0aababa557679340468391a51bd77ed97f68727c
parent3ec1635f66ea4e76b57932c9580121b6f415f9b6 (diff)
downloadports-513740cc8e824a4d53853a38a5470a9d3bcd6996.tar.gz
ports-513740cc8e824a4d53853a38a5470a9d3bcd6996.zip
net/libngtcp2: Update to 1.2.0
* Switch to CMake for faster builds, it also additionally cleans up the port Makefile and removes the need for additional patching * Disable OpenSSL requirement as it fails due to lack of QUIC support which is in 3.2 * Rearrange Makefile to follow Porters Handbook more closely and for readability PR: 274782 Approved by: portmgr (maintainer timeout 2+ weeks)
-rw-r--r--net/libngtcp2/Makefile17
-rw-r--r--net/libngtcp2/distinfo6
-rw-r--r--net/libngtcp2/files/patch-Makefile.in13
-rw-r--r--net/libngtcp2/pkg-plist2
4 files changed, 13 insertions, 25 deletions
diff --git a/net/libngtcp2/Makefile b/net/libngtcp2/Makefile
index e766d8a84edd..1deb680168a1 100644
--- a/net/libngtcp2/Makefile
+++ b/net/libngtcp2/Makefile
@@ -1,7 +1,7 @@
PORTNAME= ngtcp2
-PORTVERSION= 1.1.0
+DISTVERSION= 1.2.0
CATEGORIES= net
-MASTER_SITES= https://github.com/ngtcp2/ngtcp2/releases/download/v${PORTVERSION}/
+MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/releases/download/v${DISTVERSION}/
PKGNAMEPREFIX= lib
MAINTAINER= sunpoet@FreeBSD.org
@@ -12,12 +12,13 @@ WWW= https://nghttp2.org/ngtcp2/ \
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= compiler:c++17-lang libtool pathfix pkgconfig ssl tar:xz
-
-CONFIGURE_ARGS= --enable-lib-only --with-jemalloc
-GNU_CONFIGURE= yes
-INSTALL_TARGET= install-strip
-USE_CXXSTD= c++17
+USES= cmake compiler:c++14-lang pathfix tar:xz
USE_LDCONFIG= yes
+# Always disabled due to lack of QUIC support which is in 3.2
+CMAKE_OFF= ENABLE_OPENSSL
+CMAKE_ON= CMAKE_DISABLE_FIND_PACKAGE_CUnit \
+ CMAKE_DISABLE_FIND_PACKAGE_Libev \
+ CMAKE_DISABLE_FIND_PACKAGE_Libnghttp3
+
.include <bsd.port.mk>
diff --git a/net/libngtcp2/distinfo b/net/libngtcp2/distinfo
index e3c12d14c911..5e02e151e88b 100644
--- a/net/libngtcp2/distinfo
+++ b/net/libngtcp2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1702028058
-SHA256 (ngtcp2-1.1.0.tar.xz) = 803eeb4a626d37a7512eacd6f419dbc4bb8ddbc1e105310c0fe9c322b4a1f7de
-SIZE (ngtcp2-1.1.0.tar.xz) = 595536
+TIMESTAMP = 1705948404
+SHA256 (ngtcp2-1.2.0.tar.xz) = b0e78508bcf861296eb2382a845413ecb10b2f2209928e25eedab81680650a95
+SIZE (ngtcp2-1.2.0.tar.xz) = 598000
diff --git a/net/libngtcp2/files/patch-Makefile.in b/net/libngtcp2/files/patch-Makefile.in
deleted file mode 100644
index afad6594b328..000000000000
--- a/net/libngtcp2/files/patch-Makefile.in
+++ /dev/null
@@ -1,13 +0,0 @@
---- Makefile.in.orig 2022-01-16 12:35:06 UTC
-+++ Makefile.in
-@@ -425,8 +425,8 @@ top_srcdir = @top_srcdir@
- # LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
- # OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
- # WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
--SUBDIRS = lib tests doc $(am__append_1) $(am__append_2)
--dist_doc_DATA = README.rst
-+SUBDIRS = lib $(am__append_1)
-+dist_doc_DATA =
- ACLOCAL_AMFLAGS = -I m4
- EXTRA_DIST = \
- cmakeconfig.h.in \
diff --git a/net/libngtcp2/pkg-plist b/net/libngtcp2/pkg-plist
index 85a15f4c2d52..000b4a1f39b2 100644
--- a/net/libngtcp2/pkg-plist
+++ b/net/libngtcp2/pkg-plist
@@ -3,5 +3,5 @@ include/ngtcp2/version.h
lib/libngtcp2.a
lib/libngtcp2.so
lib/libngtcp2.so.16
-lib/libngtcp2.so.16.1.0
+lib/libngtcp2.so.16.1.1
libdata/pkgconfig/libngtcp2.pc