aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Fechner <mfechner@FreeBSD.org>2021-05-29 11:42:06 +0000
committerMatthias Fechner <mfechner@FreeBSD.org>2021-05-29 16:23:55 +0000
commit5154c2bd5207fdc3ea59c58484421196c949aca4 (patch)
tree8c8e5b4f546bbb06991f1373e1548c63f1fb3f4a
parent76585a941a4fd7d59b1a0d16d2442445057fcabb (diff)
downloadports-5154c2bd5207fdc3ea59c58484421196c949aca4.tar.gz
ports-5154c2bd5207fdc3ea59c58484421196c949aca4.zip
na/na: New ports required for gitlab-ce 13.12.
-rw-r--r--net/Makefile2
-rw-r--r--net/rubygem-gitlab-omniauth-openid-connect/Makefile23
-rw-r--r--net/rubygem-gitlab-omniauth-openid-connect/distinfo3
-rw-r--r--net/rubygem-gitlab-omniauth-openid-connect/pkg-descr3
-rw-r--r--net/rubygem-spamcheck/Makefile18
-rw-r--r--net/rubygem-spamcheck/distinfo3
-rw-r--r--net/rubygem-spamcheck/pkg-descr3
-rw-r--r--security/Makefile1
-rw-r--r--security/rubygem-declarative_policy/Makefile19
-rw-r--r--security/rubygem-declarative_policy/distinfo3
-rw-r--r--security/rubygem-declarative_policy/pkg-descr5
11 files changed, 83 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 2c6818e29a7c..d2962af2565d 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1254,6 +1254,7 @@
SUBDIR += rubygem-gitaly-proto
SUBDIR += rubygem-gitlab-fog-azure-rm
SUBDIR += rubygem-gitlab-fog-google
+ SUBDIR += rubygem-gitlab-omniauth-openid-connect
SUBDIR += rubygem-gitlab_omniauth-ldap
SUBDIR += rubygem-google-cloud-bigquery
SUBDIR += rubygem-google-cloud-bigtable
@@ -1344,6 +1345,7 @@
SUBDIR += rubygem-rye
SUBDIR += rubygem-serverengine
SUBDIR += rubygem-simple_oauth
+ SUBDIR += rubygem-spamcheck
SUBDIR += rubygem-stackdriver-core
SUBDIR += rubygem-stompserver
SUBDIR += rubygem-t
diff --git a/net/rubygem-gitlab-omniauth-openid-connect/Makefile b/net/rubygem-gitlab-omniauth-openid-connect/Makefile
new file mode 100644
index 000000000000..90bc712c993e
--- /dev/null
+++ b/net/rubygem-gitlab-omniauth-openid-connect/Makefile
@@ -0,0 +1,23 @@
+# Created by: Matthias Fechner <mfechner@FreeBSD.org>
+
+PORTNAME= gitlab-omniauth-openid-connect
+PORTVERSION= 0.4.0
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+
+MAINTAINER= mfechner@FreeBSD.org
+COMMENT= OpenID Connect Strategy for OmniAuth
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= rubygem-addressable>=2.7<3.0:www/rubygem-addressable \
+ rubygem-omniauth>=1.9<2.0:security/rubygem-omniauth \
+ rubygem-openid_connect>=1.2<2.0:net/rubygem-openid_connect
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-gitlab-omniauth-openid-connect/distinfo b/net/rubygem-gitlab-omniauth-openid-connect/distinfo
new file mode 100644
index 000000000000..31c95a17a9d6
--- /dev/null
+++ b/net/rubygem-gitlab-omniauth-openid-connect/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1621457273
+SHA256 (rubygem/gitlab-omniauth-openid-connect-0.4.0.gem) = b125385cb632af64f6f769987c1beb331002f32b1ccc6b7b2a51d02aae6f6b9b
+SIZE (rubygem/gitlab-omniauth-openid-connect-0.4.0.gem) = 22016
diff --git a/net/rubygem-gitlab-omniauth-openid-connect/pkg-descr b/net/rubygem-gitlab-omniauth-openid-connect/pkg-descr
new file mode 100644
index 000000000000..c71b5a46fd73
--- /dev/null
+++ b/net/rubygem-gitlab-omniauth-openid-connect/pkg-descr
@@ -0,0 +1,3 @@
+OpenID Connect Strategy for OmniAuth.
+
+WWW: https://gitlab.com/gitlab-org/gitlab-omniauth-openid-connect
diff --git a/net/rubygem-spamcheck/Makefile b/net/rubygem-spamcheck/Makefile
new file mode 100644
index 000000000000..d26b8c89d487
--- /dev/null
+++ b/net/rubygem-spamcheck/Makefile
@@ -0,0 +1,18 @@
+PORTNAME= spamcheck
+PORTVERSION= 0.1.0
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+
+MAINTAINER= mfechner@FreeBSD.org
+COMMENT= Auto-generated gRPC client for SpamCheck
+
+LICENSE= MIT
+
+RUN_DEPENDS= rubygem-grpc>=1.0<2.0:net/rubygem-grpc
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-spamcheck/distinfo b/net/rubygem-spamcheck/distinfo
new file mode 100644
index 000000000000..bc86134961a8
--- /dev/null
+++ b/net/rubygem-spamcheck/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1621461680
+SHA256 (rubygem/spamcheck-0.1.0.gem) = 79a4a3714a7a850e6146611466c7638f9542f2889642ec83c02f05e44f3e6058
+SIZE (rubygem/spamcheck-0.1.0.gem) = 5632
diff --git a/net/rubygem-spamcheck/pkg-descr b/net/rubygem-spamcheck/pkg-descr
new file mode 100644
index 000000000000..ed29fca696e1
--- /dev/null
+++ b/net/rubygem-spamcheck/pkg-descr
@@ -0,0 +1,3 @@
+Auto-generated gRPC client for SpamCheck.
+
+WWW: https://rubygems.org/gems/spamcheck
diff --git a/security/Makefile b/security/Makefile
index 1c9313c89a51..3fc813d3e9f6 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -1051,6 +1051,7 @@
SUBDIR += rubygem-bcrypt_pbkdf
SUBDIR += rubygem-bcrypt_pbkdf10
SUBDIR += rubygem-cose
+ SUBDIR += rubygem-declarative_policy
SUBDIR += rubygem-devise-two-factor
SUBDIR += rubygem-devise-two-factor-rails5
SUBDIR += rubygem-devise-two-factor-rails60
diff --git a/security/rubygem-declarative_policy/Makefile b/security/rubygem-declarative_policy/Makefile
new file mode 100644
index 000000000000..8d26deafca5c
--- /dev/null
+++ b/security/rubygem-declarative_policy/Makefile
@@ -0,0 +1,19 @@
+# Created by: Matthias Fechner <mfechner@FreeBSD.org>
+
+PORTNAME= declarative_policy
+PORTVERSION= 1.0.0
+CATEGORIES= security rubygems
+MASTER_SITES= RG
+
+MAINTAINER= mfechner@FreeBSD.org
+COMMENT= Authorization framework with a declarative DSL
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/security/rubygem-declarative_policy/distinfo b/security/rubygem-declarative_policy/distinfo
new file mode 100644
index 000000000000..4da0547a71dd
--- /dev/null
+++ b/security/rubygem-declarative_policy/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1621456936
+SHA256 (rubygem/declarative_policy-1.0.0.gem) = 06f60321c3fabc803a77ce6f63fca111ff26ea8d61ad78fc23064b9025a05c4c
+SIZE (rubygem/declarative_policy-1.0.0.gem) = 27136
diff --git a/security/rubygem-declarative_policy/pkg-descr b/security/rubygem-declarative_policy/pkg-descr
new file mode 100644
index 000000000000..76b0f322df5d
--- /dev/null
+++ b/security/rubygem-declarative_policy/pkg-descr
@@ -0,0 +1,5 @@
+This library provides an authorization framework with a declarative
+DSL With this library, you can write permission policies that are
+separate from business logic. This library is in production use at GitLab.com
+
+WWW: https://gitlab.com/gitlab-org/declarative-policy