aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2022-10-28 13:11:22 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2022-10-28 13:11:22 +0000
commit517ca7b450f68991d1183d740e0565939fc65b20 (patch)
tree30e746ecfb63eb94a58d647b70c0395f899eb097
parentc783ffdd639055a303d1d89d3d28f47be854f8e5 (diff)
downloadports-517ca7b450f68991d1183d740e0565939fc65b20.tar.gz
ports-517ca7b450f68991d1183d740e0565939fc65b20.zip
games/yquake2: the port had been updated to version 8.10
While here, do not needlessly initialize local variable as the FS_GetNextRawPath() would DTRT itself and drop one extra space. PR: 265286
-rw-r--r--games/yquake2/Makefile2
-rw-r--r--games/yquake2/distinfo6
-rw-r--r--games/yquake2/files/patch-src_client_vid_vid.c4
-rw-r--r--games/yquake2/pkg-plist1
4 files changed, 7 insertions, 6 deletions
diff --git a/games/yquake2/Makefile b/games/yquake2/Makefile
index f24106250f61..c9ae6bd5a296 100644
--- a/games/yquake2/Makefile
+++ b/games/yquake2/Makefile
@@ -1,5 +1,5 @@
PORTNAME= yquake2
-PORTVERSION= 8.01
+PORTVERSION= 8.10
CATEGORIES= games
MASTER_SITES= https://deponie.yamagi.org/quake2/
DISTNAME= quake2-${PORTVERSION}
diff --git a/games/yquake2/distinfo b/games/yquake2/distinfo
index ee74449e7613..a8e03b54aa0f 100644
--- a/games/yquake2/distinfo
+++ b/games/yquake2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1642841575
-SHA256 (quake2-8.01.tar.xz) = 132889a6976dd7c75bf94a4ca49c76ff09cf843d66541872320d7a02a25a622c
-SIZE (quake2-8.01.tar.xz) = 2109408
+TIMESTAMP = 1653801164
+SHA256 (quake2-8.10.tar.xz) = 93d625f67bd365d943113f6aa7c65f6fd2bd4c46c4ab77eedc4642735c143ea1
+SIZE (quake2-8.10.tar.xz) = 2138064
diff --git a/games/yquake2/files/patch-src_client_vid_vid.c b/games/yquake2/files/patch-src_client_vid_vid.c
index 3238c79518d5..18a7f8ff95f3 100644
--- a/games/yquake2/files/patch-src_client_vid_vid.c
+++ b/games/yquake2/files/patch-src_client_vid_vid.c
@@ -5,9 +5,9 @@
VID_GetRendererLibPath(const char *renderer, char *path, size_t len)
{
- snprintf(path, len, "%sref_%s.%s", Sys_GetBinaryDir(), renderer, lib_ext);
-+ char *next_path = NULL;
++ char *next_path;
+
-+ while ((next_path = FS_GetNextRawPath (next_path)) != NULL) {
++ while ((next_path = FS_GetNextRawPath(next_path)) != NULL) {
+ snprintf(path, len, "%s/ref_%s.%s", next_path, renderer, lib_ext);
+ if (Sys_IsFile(path))
+ break;
diff --git a/games/yquake2/pkg-plist b/games/yquake2/pkg-plist
index fce8f627ae2e..1886f5b83753 100644
--- a/games/yquake2/pkg-plist
+++ b/games/yquake2/pkg-plist
@@ -3,6 +3,7 @@ bin/yquake2
lib/yquake2/baseq2/game.so
lib/yquake2/ref_gl1.so
lib/yquake2/ref_gl3.so
+lib/yquake2/ref_gles3.so
lib/yquake2/ref_soft.so
%%PORTDOCS%%%%DOCSDIR%%/010_index.md
%%PORTDOCS%%%%DOCSDIR%%/020_installation.md