aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-07-14 15:48:41 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-07-14 16:09:38 +0000
commit517fda3c534d7000795ec423c54c7acea362cf6f (patch)
treef8e487c66fdb429a5c969c405e43ae6b6b6440a9
parent07b8c981976a886c405735ff760e749df903fa23 (diff)
downloadports-517fda3c534d7000795ec423c54c7acea362cf6f.tar.gz
ports-517fda3c534d7000795ec423c54c7acea362cf6f.zip
www/py-django-hashid-field: Add py-django-hashid-field 3.2.1
A custom Model Field that uses the Hashids library to obfuscate an IntegerField or AutoField. It can be used in new models or dropped in place of an existing IntegerField, explicit AutoField, or an automatically generated AutoField. WWW: https://github.com/nshafer/django-hashid-field
-rw-r--r--www/Makefile1
-rw-r--r--www/py-django-hashid-field/Makefile22
-rw-r--r--www/py-django-hashid-field/distinfo3
-rw-r--r--www/py-django-hashid-field/pkg-descr5
4 files changed, 31 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index fb6312130f98..e48afc459aa7 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1494,6 +1494,7 @@
SUBDIR += py-django-gravatar2
SUBDIR += py-django-guardian
SUBDIR += py-django-happenings-update
+ SUBDIR += py-django-hashid-field
SUBDIR += py-django-haystack
SUBDIR += py-django-hierarkey
SUBDIR += py-django-hijack
diff --git a/www/py-django-hashid-field/Makefile b/www/py-django-hashid-field/Makefile
new file mode 100644
index 000000000000..6cdbaa3ea80e
--- /dev/null
+++ b/www/py-django-hashid-field/Makefile
@@ -0,0 +1,22 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= django-hashid-field
+PORTVERSION= 3.2.1
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Hashids obfuscated Django Model Field
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django22>=1.11:www/py-django22@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}hashids>=1.2.0:textproc/py-hashids@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/www/py-django-hashid-field/distinfo b/www/py-django-hashid-field/distinfo
new file mode 100644
index 000000000000..afcd1d5ecff6
--- /dev/null
+++ b/www/py-django-hashid-field/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1625585440
+SHA256 (django-hashid-field-3.2.1.tar.gz) = b602d6db33576bafd7bfed7609372bba13cb492bffc0a6560f402a334bd6146e
+SIZE (django-hashid-field-3.2.1.tar.gz) = 23976
diff --git a/www/py-django-hashid-field/pkg-descr b/www/py-django-hashid-field/pkg-descr
new file mode 100644
index 000000000000..a877b4e90291
--- /dev/null
+++ b/www/py-django-hashid-field/pkg-descr
@@ -0,0 +1,5 @@
+A custom Model Field that uses the Hashids library to obfuscate an IntegerField
+or AutoField. It can be used in new models or dropped in place of an existing
+IntegerField, explicit AutoField, or an automatically generated AutoField.
+
+WWW: https://github.com/nshafer/django-hashid-field