aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-07-04 15:00:27 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-07-04 15:00:27 +0000
commit51ea03179aff52b1bdac30fc908e46f81392e619 (patch)
treeaa05698cebe2f22de3741f7945b2dae3f64ea3fe
parent2dac60ac174f6aa9d85fc9c75453d570c0e1cf6e (diff)
downloadports-51ea03179aff52b1bdac30fc908e46f81392e619.tar.gz
ports-51ea03179aff52b1bdac30fc908e46f81392e619.zip
archivers/lazperf: fix build on big-endian architectures
/wrkdirs/usr/ports/archivers/lazperf/work/laz-perf-2.0.0/cpp/lazperf/vlr.cpp:188:28: error: constant expression evaluates to 16777216 which cannot be narrowed to type 'uint8_t' (aka 'unsigned char') [-Wc++11-narrowing] reserved{}, data_type{ htole32(1) }, options{}, name{}, unused{}, ^~~~~~~~~~ /usr/include/sys/endian.h:88:20: note: expanded from macro 'htole32' ^~~~~~~~~~~~ /usr/include/sys/endian.h:62:20: note: expanded from macro 'bswap32' ^~~~~~~~~~~~ /usr/include/machine/endian.h:136:22: note: expanded from macro '__bswap32' ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ /wrkdirs/usr/ports/archivers/lazperf/work/laz-perf-2.0.0/cpp/lazperf/vlr.cpp:188:28: note: insert an explicit cast to silence this issue reserved{}, data_type{ htole32(1) }, options{}, name{}, unused{}, ^~~~~~~~~~ static_cast<uint8_t>( ) /usr/include/sys/endian.h:88:20: note: expanded from macro 'htole32' ^~~~~~~~~~~~ /usr/include/sys/endian.h:62:20: note: expanded from macro 'bswap32' ^~~~~~~~~~~~ /usr/include/machine/endian.h:136:22: note: expanded from macro '__bswap32' ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ /wrkdirs/usr/ports/archivers/lazperf/work/laz-perf-2.0.0/cpp/lazperf/vlr.cpp:188:28: warning: implicit conversion from 'unsigned int' to 'uint8_t' (aka 'unsigned char') changes value from 16777216 to 0 [-Wconstant-conversion] reserved{}, data_type{ htole32(1) }, options{}, name{}, unused{}, ~ ^~~~~~~~~~ /usr/include/sys/endian.h:88:20: note: expanded from macro 'htole32' ^~~~~~~~~~~~ /usr/include/sys/endian.h:62:20: note: expanded from macro 'bswap32' ^~~~~~~~~~~~ /usr/include/machine/endian.h:136:42: note: expanded from macro '__bswap32' ^~~~~~~~~~~~~~~~~~ /usr/include/machine/endian.h:98:37: note: expanded from macro '__bswap32_const' (((__uint32_t)(x)<< 8) & 0xff0000) | \ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ 1 warning and 1 error generated.
-rw-r--r--archivers/lazperf/Makefile3
-rw-r--r--archivers/lazperf/distinfo4
2 files changed, 6 insertions, 1 deletions
diff --git a/archivers/lazperf/Makefile b/archivers/lazperf/Makefile
index db3758d05571..5480422ead87 100644
--- a/archivers/lazperf/Makefile
+++ b/archivers/lazperf/Makefile
@@ -4,6 +4,9 @@ PORTNAME= lazperf
DISTVERSION= 2.0.0
CATEGORIES= archivers databases geography
+PATCH_SITES= https://github.com/hobu/laz-perf/commit/
+PATCHFILES= a003d1ead4afb9a0c61cde8b00340c489f2ce370.patch:-p1
+
MAINTAINER= lbartoletti@FreeBSD.org
COMMENT= Alternative LAZ implementation for C++ and JavaScript
diff --git a/archivers/lazperf/distinfo b/archivers/lazperf/distinfo
index 21adcaa8d999..9de69a3d6545 100644
--- a/archivers/lazperf/distinfo
+++ b/archivers/lazperf/distinfo
@@ -1,3 +1,5 @@
-TIMESTAMP = 1622957308
+TIMESTAMP = 1625410349
SHA256 (hobu-laz-perf-2.0.0_GH0.tar.gz) = 0b088e17b7ed96333fc4d791fb78d021e37a63c97fe85dff59b19a0098df6462
SIZE (hobu-laz-perf-2.0.0_GH0.tar.gz) = 4968421
+SHA256 (a003d1ead4afb9a0c61cde8b00340c489f2ce370.patch) = 9dc35fcf10ef722a9901152faeb4c727532010f690484329df98249af9234a4e
+SIZE (a003d1ead4afb9a0c61cde8b00340c489f2ce370.patch) = 857