aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-19 18:48:28 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-19 19:27:15 +0000
commit524c1cd189cb88c2aa74d3b4efafdf97be6f3109 (patch)
treef132544a1d273a4091c773ae5c34cd9152ea1386
parent314e20f37279b2f1db13042225a8ea33b4561864 (diff)
downloadports-524c1cd189cb88c2aa74d3b4efafdf97be6f3109.tar.gz
ports-524c1cd189cb88c2aa74d3b4efafdf97be6f3109.zip
security/pks: Fix build with llvm16
Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
-rw-r--r--security/pks/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/security/pks/Makefile b/security/pks/Makefile
index 6ecedd1cfd41..ac5482fd76e0 100644
--- a/security/pks/Makefile
+++ b/security/pks/Makefile
@@ -23,7 +23,7 @@ CONFIGURE_ARGS= --datadir=${DATADIR} \
--with-db --with-ipv6 --with-libwrap \
--with-openssl=${OPENSSLBASE}
CONFIGURE_ENV= DBLIB="-L${BDB_LIB_DIR} -l${BDB_LIB_NAME}" \
- DBINC=-I${BDB_INCLUDE_DIR} DBHDR=db.h
+ DBINC=-I${BDB_INCLUDE_DIR} DBHDR=db.h cflags="${CFLAGS}"
SUB_FILES= pkg-message
SUB_LIST= PORTNAME="${PORTNAME}"
@@ -31,6 +31,12 @@ SUB_LIST= PORTNAME="${PORTNAME}"
OPTIONS_DEFINE= DOCS
PORTDOCS= pks_help.* README EMAIL
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+CFLAGS+= -Wno-error=incompatible-function-pointer-types
+.endif
+
post-extract:
@${CP} -a ${FILESDIR}/EMAIL ${WRKSRC}