aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEvgeniy Khramtsov <evgeniy@khramtsov.org>2021-08-04 12:43:13 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-08-16 20:44:17 +0000
commit52549f096d76c3539c5644afc7ea01ce5b50e3d3 (patch)
tree6af9a383fd744074d35f4ef9097aee26b8b63dd4
parent40354e8a7d1dfc5ab6d8ef34a06d546bc2223bce (diff)
downloadports-52549f096d76c3539c5644afc7ea01ce5b50e3d3.tar.gz
ports-52549f096d76c3539c5644afc7ea01ce5b50e3d3.zip
net-im/fractal: respect RUSTFLAGS
Set RUSTFLAGS like Mk/Uses/cargo.mk does to respect CC and LDFLAGS. PR: 257621 Approved by: Greg V <greg@unrelenting.technology> (maintainer) (cherry picked from commit e6d430445e5a7180f1b45e61eb7793c8c43f3aa0)
-rw-r--r--net-im/fractal/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/net-im/fractal/Makefile b/net-im/fractal/Makefile
index 4dd946805ef2..d974a6f0d704 100644
--- a/net-im/fractal/Makefile
+++ b/net-im/fractal/Makefile
@@ -31,7 +31,8 @@ INSTALLS_ICONS= yes
# for the gettext-sys crate
MAKE_ENV+= GETTEXT_BIN_DIR=${LOCALBASE}/bin \
GETTEXT_LIB_DIR=${LOCALBASE}/lib \
- GETTEXT_INCLUDE_DIR=${LOCALBASE}/include
+ GETTEXT_INCLUDE_DIR=${LOCALBASE}/include \
+ RUSTFLAGS="${RUSTFLAGS} -C linker=${CC:Q} ${LDFLAGS:C/.+/-C link-arg=&/}"
post-patch:
# Disable vendor checksums