aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-04-09 13:31:45 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-04-09 13:36:55 +0000
commit529f1fdfe52c2709fbed84694f162d4a7feec821 (patch)
treee137874b768a2af097e3d76b1052cbb638182f41
parent2bc11de5ba8e5d69c7dc610a90d0e1b368ae6fde (diff)
downloadports-529f1fdfe52c2709fbed84694f162d4a7feec821.tar.gz
ports-529f1fdfe52c2709fbed84694f162d4a7feec821.zip
math/py-pygsl: Update to 2.3.3
- Convert to USE_PYTHON=pep517 Changes: https://github.com/pygsl/pygsl/releases
-rw-r--r--math/py-pygsl/Makefile8
-rw-r--r--math/py-pygsl/distinfo6
-rw-r--r--math/py-pygsl/files/patch-setup.py50
3 files changed, 8 insertions, 56 deletions
diff --git a/math/py-pygsl/Makefile b/math/py-pygsl/Makefile
index 4afa0ab1a7e3..a012404752d3 100644
--- a/math/py-pygsl/Makefile
+++ b/math/py-pygsl/Makefile
@@ -1,5 +1,5 @@
PORTNAME= pygsl
-PORTVERSION= 2.3.2
+PORTVERSION= 2.3.3
CATEGORIES= math python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,12 +11,14 @@ WWW= https://github.com/pygsl/pygsl
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=0,1:math/py-numpy@${PY_FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=0,1:math/py-numpy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
LIB_DEPENDS= libgsl.so:math/gsl
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=0,1:math/py-numpy@${PY_FLAVOR}
USES= python:3.7+
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
post-install:
${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR} -name '*.so' -exec ${STRIP_CMD} {} +
diff --git a/math/py-pygsl/distinfo b/math/py-pygsl/distinfo
index 622e5ac95539..e0555a1aab82 100644
--- a/math/py-pygsl/distinfo
+++ b/math/py-pygsl/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1643971114
-SHA256 (pygsl-2.3.2.tar.gz) = fa5d018d4421373f5390ac199bc5d484ef317d8358505b35a795bb89f96c8a9c
-SIZE (pygsl-2.3.2.tar.gz) = 1093630
+TIMESTAMP = 1680726188
+SHA256 (pygsl-2.3.3.tar.gz) = 1779bce41b3cb0e370d11bf41003852ba4750c51df5b8771bb34265e8e0f1df3
+SIZE (pygsl-2.3.3.tar.gz) = 1087169
diff --git a/math/py-pygsl/files/patch-setup.py b/math/py-pygsl/files/patch-setup.py
deleted file mode 100644
index 3b3b1f1e273b..000000000000
--- a/math/py-pygsl/files/patch-setup.py
+++ /dev/null
@@ -1,50 +0,0 @@
---- setup.py.orig 2021-12-07 16:05:38 UTC
-+++ setup.py
-@@ -89,8 +89,6 @@ del versiontext
- gsldist_path = os.path.join(pygsldir, "gsl_dist")
- sys.path.insert(0, gsldist_path)
-
--from wheel.bdist_wheel import bdist_wheel as _bdist_wheel
--
- import setuptools
- import setuptools.command
- import setuptools.command.install
-@@ -173,26 +171,6 @@ else:
- del t_file
-
-
--class CustomInstallCommand(setuptools.command.install.install):
-- def run(self):
-- # first re-generate GSL wrappers using SWIG
-- self.run_command('gsl_wrappers')
-- # then configure
-- self.run_command('config')
-- # then install
-- setuptools.command.install.install.run(self)
-- #super().run()
--
--class CustomBdistWheelCommand(_bdist_wheel):
-- def run(self):
-- # first re-generate GSL wrappers using SWIG
-- self.run_command('gsl_wrappers')
-- # then configure
-- self.run_command('config')
-- # then install
-- _bdist_wheel.run(self)
-- #super().run()
--
- py_module_names = ['errors',
- 'statistics.__init__',
- '_numobj',
-@@ -270,10 +248,9 @@ setup (name = proj_name,
- ext_package = 'pygsl',
- ext_modules = exts,
- headers = headers,
-- cmdclass = {'bdist_wheel': CustomBdistWheelCommand,
-+ cmdclass = {
- 'config' : gsl_Config_Path,
- 'gsl_wrappers': gsl_CodeGenerator.gsl_CodeGenerator,
-- 'install': CustomInstallCommand,
- #'build_sphinx': BuildDoc
- },
- install_requires = ['numpy'],