aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Fechner <mfechner@FreeBSD.org>2024-03-09 08:12:31 +0000
committerMatthias Fechner <mfechner@FreeBSD.org>2024-03-26 07:56:35 +0000
commit53331c0d82099be48e3ecf18e46555881d2fe1b1 (patch)
tree0b916afba2227f9d01b534b0767edd7f7d8f9f55
parent1d8a7133d438ce6028011488b2fa70cb53e3975a (diff)
downloadports-53331c0d82099be48e3ecf18e46555881d2fe1b1.tar.gz
ports-53331c0d82099be48e3ecf18e46555881d2fe1b1.zip
security/trivy: include templates
These templates can be used to integrate trivy into gitlab pipelines. But it seems that gitlab does support the full parsing not in the community edition of gitlab. (cherry picked from commit 9e6fcaf3eaa2e2f5a8036bcdfde6bd18810d72dd)
-rw-r--r--security/trivy/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/security/trivy/Makefile b/security/trivy/Makefile
index 44282f9226e1..862dba088fd4 100644
--- a/security/trivy/Makefile
+++ b/security/trivy/Makefile
@@ -1,5 +1,6 @@
PORTNAME= trivy
DISTVERSION= 0.49.1
+PORTREVISION= 1
DISTVERSIONPREFIX= v
CATEGORIES= security
@@ -21,6 +22,14 @@ GO_BUILDFLAGS= -ldflags=" \
PLIST_FILES= bin/${PORTNAME}
+post-install:
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/contrib/*.tpl ${STAGEDIR}${DATADIR}/
+ ${FIND} -s ${STAGEDIR}${DATADIR} -not -type d | ${SORT} | \
+ ${SED} -e 's#^${STAGEDIR}${PREFIX}/##' | \
+ ${SED} -E -e '/sample$$/ s#^#@sample #; \
+ s#${DATADIR_REL}/bin#@(,,555) ${DATADIR_REL}/bin#; ' >> ${TMPPLIST}
+ cat ${TMPPLIST}
.include <bsd.port.mk>