aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLorenzo Salvadore <salvadore@FreeBSD.org>2022-05-02 19:38:29 +0000
committerLorenzo Salvadore <salvadore@FreeBSD.org>2022-05-12 14:17:36 +0000
commit53c59951224eece2f7cee46b36aee912120aa4d3 (patch)
tree2cda8202a211dd492fe68740beb16983df52dc03
parent6c00f6e30fbd66a5ccc7173c9f4aca3122cd4c63 (diff)
downloadports-53c59951224eece2f7cee46b36aee912120aa4d3.tar.gz
ports-53c59951224eece2f7cee46b36aee912120aa4d3.zip
devel/rubygem-docopt: Add new port
Rubygem implementation of docopt. Docopt helps you: - define an interface for your command-line app, and - automatically generate a parser for it. Docopt is based on conventions that have been used in help messages for decades and man pages for describing a program's interface. An interface description in docopt is such a help message, but formalized. WWW: https://github.com/docopt/docopt.rb Reviewed by: ruby (sunpoet) Approved by: gerald (mentor) Differential Revision: https://reviews.freebsd.org/D35031
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-docopt/Makefile19
-rw-r--r--devel/rubygem-docopt/distinfo3
-rw-r--r--devel/rubygem-docopt/pkg-descr11
4 files changed, 34 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index d90e44dacd80..fc9df1cf4d18 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -6327,6 +6327,7 @@
SUBDIR += rubygem-ditz
SUBDIR += rubygem-diva
SUBDIR += rubygem-docile
+ SUBDIR += rubygem-docopt
SUBDIR += rubygem-drb
SUBDIR += rubygem-dry-configurable
SUBDIR += rubygem-dry-container
diff --git a/devel/rubygem-docopt/Makefile b/devel/rubygem-docopt/Makefile
new file mode 100644
index 000000000000..80cac84b0bcd
--- /dev/null
+++ b/devel/rubygem-docopt/Makefile
@@ -0,0 +1,19 @@
+PORTNAME= docopt
+DISTVERSION= 0.6.1
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= salvadore@FreeBSD.org
+COMMENT= Parse command line arguments based on nothing more than a usage message
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= gem python:env shebangfix
+USE_RUBY= yes
+
+SHEBANG_FILES= test/language_agnostic_tester.py
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-docopt/distinfo b/devel/rubygem-docopt/distinfo
new file mode 100644
index 000000000000..ebd5347192be
--- /dev/null
+++ b/devel/rubygem-docopt/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1650642167
+SHA256 (rubygem/docopt-0.6.1.gem) = 73f837ed376d015971712c17f7aafa021998b964b77d52997dcaff79d6727467
+SIZE (rubygem/docopt-0.6.1.gem) = 19456
diff --git a/devel/rubygem-docopt/pkg-descr b/devel/rubygem-docopt/pkg-descr
new file mode 100644
index 000000000000..483ada5911b5
--- /dev/null
+++ b/devel/rubygem-docopt/pkg-descr
@@ -0,0 +1,11 @@
+Rubygem implementation of docopt.
+
+Docopt helps you:
+- define an interface for your command-line app, and
+- automatically generate a parser for it.
+
+Docopt is based on conventions that have been used in help messages for decades
+and man pages for describing a program's interface. An interface description in
+docopt is such a help message, but formalized.
+
+WWW: https://github.com/docopt/docopt.rb