aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-07-18 17:47:14 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-07-18 17:47:14 +0000
commit54021a8b696e9fb94e95154a51997bbea079f85d (patch)
tree775420252e0232f7a857d43a293eaac358cfc5a2
parent6ac7818d86f1df2ce74c52a467d316f1591af417 (diff)
downloadports-54021a8b696e9fb94e95154a51997bbea079f85d.tar.gz
ports-54021a8b696e9fb94e95154a51997bbea079f85d.zip
deskutils/py-py3status: Add GEVENT and UDEV options
-rw-r--r--deskutils/py-py3status/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/deskutils/py-py3status/Makefile b/deskutils/py-py3status/Makefile
index dd03b59d58d5..3f11528182e3 100644
--- a/deskutils/py-py3status/Makefile
+++ b/deskutils/py-py3status/Makefile
@@ -17,4 +17,11 @@ USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
+OPTIONS_DEFINE= GEVENT UDEV
+GEVENT_DESC= Gevent support
+UDEV_DESC= UDEV support
+
+GEVENT_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gevent>=1.1:devel/py-gevent@${PY_FLAVOR}
+UDEV_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyudev>=0.21.0:devel/py-pyudev@${PY_FLAVOR}
+
.include <bsd.port.mk>