aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2023-03-15 12:45:39 +0000
committerJan Beich <jbeich@FreeBSD.org>2023-03-15 12:46:49 +0000
commit546e957ac8428c8adc2e46faf371d41a247b170c (patch)
tree1a5983c1a01822afa219a0e83acd5fe64048d4b1
parent538e577adb485fdeb80cbedb51f54106e7e18da5 (diff)
downloadports-546e957ac8428c8adc2e46faf371d41a247b170c.tar.gz
ports-546e957ac8428c8adc2e46faf371d41a247b170c.zip
multimedia/ffms2: unbreak with ffmpeg 5.0
src/core/videosource.cpp:174:18: error: cannot initialize a variable of type 'AVCodec *' with an rvalue of type 'const AVCodec *' AVCodec *Codec = avcodec_find_decoder(FormatContext->streams[VideoTrack]->codecpar->codec_id); ^ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ src/core/audiosource.cpp:466:14: error: cannot initialize a variable of type 'AVCodec *' with an rvalue of type 'const AVCodec *' AVCodec *Codec = avcodec_find_decoder(FormatContext->streams[TrackNumber]->codecpar->codec_id); ^ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ src/core/indexing.cpp:387:14: error: cannot initialize a variable of type 'AVCodec *' with an rvalue of type 'const AVCodec *' AVCodec *codec = avcodec_find_decoder(FormatContext->streams[Track]->codecpar->codec_id); ^ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ src/core/indexing.cpp:405:22: error: cannot initialize a variable of type 'AVCodec *' with an rvalue of type 'const AVCodec *' AVCodec *VideoCodec = avcodec_find_decoder(FormatContext->streams[i]->codecpar->codec_id); ^ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ src/core/indexing.cpp:436:22: error: cannot initialize a variable of type 'AVCodec *' with an rvalue of type 'const AVCodec *' AVCodec *AudioCodec = avcodec_find_decoder(FormatContext->streams[i]->codecpar->codec_id); ^ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ PR: 270226 Obtained from: upstream
-rw-r--r--multimedia/ffms2/Makefile6
-rw-r--r--multimedia/ffms2/distinfo6
2 files changed, 12 insertions, 0 deletions
diff --git a/multimedia/ffms2/Makefile b/multimedia/ffms2/Makefile
index 8ba20899d3fe..443d60c48941 100644
--- a/multimedia/ffms2/Makefile
+++ b/multimedia/ffms2/Makefile
@@ -1,7 +1,13 @@
PORTNAME= ffms2
DISTVERSION= 2.40
+PORTREVISION= 1
CATEGORIES= multimedia
+PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
+PATCHFILES+= 96cbf38ea938.patch:-p1 # https://github.com/FFMS/ffms2/pull/380
+PATCHFILES+= 586d87de3f89.patch:-p1 # https://github.com/FFMS/ffms2/pull/380
+PATCHFILES+= 45673149e9a2.patch:-p1 # https://github.com/FFMS/ffms2/pull/380
+
MAINTAINER= jbeich@FreeBSD.org
COMMENT= FFmpeg-based source library and VapourSynth plugin
WWW= https://github.com/FFMS/ffms2
diff --git a/multimedia/ffms2/distinfo b/multimedia/ffms2/distinfo
index 190cbb020cbf..a8d034f5d271 100644
--- a/multimedia/ffms2/distinfo
+++ b/multimedia/ffms2/distinfo
@@ -1,3 +1,9 @@
TIMESTAMP = 1598095686
SHA256 (FFMS-ffms2-2.40_GH0.tar.gz) = 82e95662946f3d6e1b529eadbd72bed196adfbc41368b2d50493efce6e716320
SIZE (FFMS-ffms2-2.40_GH0.tar.gz) = 140356
+SHA256 (96cbf38ea938.patch) = dd063e21c6e7887614ab5fb1009cf9b353066829771d4426dfe779d74dfac758
+SIZE (96cbf38ea938.patch) = 13422
+SHA256 (586d87de3f89.patch) = d5ec6ee44bf8f0a2bd943c1c61bace33b7b80559137b71fe5c4af5e7dd9ac7f8
+SIZE (586d87de3f89.patch) = 931
+SHA256 (45673149e9a2.patch) = ecef89ce1bb4158181c96eecdbc2c37e49a880a88e72a271b54ce98832dcf049
+SIZE (45673149e9a2.patch) = 3693