aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2023-08-31 05:40:06 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2023-08-31 05:40:06 +0000
commit54aad5f05fcb858926477ee9f4ba5328c695fbe8 (patch)
tree5024797fbae9419b39abfe2c34564bef1d9997f4
parent03b5e2ea76628e41868f3b7d25d4734577d854e7 (diff)
downloadports-54aad5f05fcb858926477ee9f4ba5328c695fbe8.tar.gz
ports-54aad5f05fcb858926477ee9f4ba5328c695fbe8.zip
deskutils/vnote: new port had been added (+)
Qt-based note-taking platform currently focusing on Markdown.
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/vnote/Makefile37
-rw-r--r--deskutils/vnote/distinfo11
-rw-r--r--deskutils/vnote/pkg-descr4
-rw-r--r--deskutils/vnote/pkg-plist18
5 files changed, 71 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index dd9179db64b2..900b6523c80e 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -273,6 +273,7 @@
SUBDIR += ultralist
SUBDIR += virt-manager
SUBDIR += vit
+ SUBDIR += vnote
SUBDIR += vym
SUBDIR += walld
SUBDIR += when
diff --git a/deskutils/vnote/Makefile b/deskutils/vnote/Makefile
new file mode 100644
index 000000000000..3c20efdcebec
--- /dev/null
+++ b/deskutils/vnote/Makefile
@@ -0,0 +1,37 @@
+PORTNAME= vnote
+PORTVERSION= 3.17.0
+DISTVERSIONPREFIX= v
+CATEGORIES= deskutils
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Pleasant Qt-based note-taking platform
+WWW= https://app.vnote.fun/en_us/
+
+LICENSE= LGPL3
+
+LIB_DEPENDS= libhunspell-1.7.so:textproc/hunspell
+
+USES= compiler:c++14-lang qmake qt:5
+USE_LDCONFIG= yes
+USE_QT= buildtools:build core gui network printsupport sql svg \
+ webchannel webengine widgets x11extras
+
+USE_GITHUB= yes
+GH_ACCOUNT= ${PORTNAME}x
+GH_PROJECT= QHotkey:qhk vtextedit:vte syntax-highlighting:shl sonnet:s
+GH_TAGNAME= 18ac011:qhk 398ec0f:vte 807895f:shl 403863f:s
+GH_SUBDIR= libs/QHotkey:qhk libs/vtextedit:vte \
+ libs/vtextedit/src/libs/sonnet:s \
+ libs/vtextedit/src/libs/syntax-highlighting:shl
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,"hunspell\.hxx",<hunspell/hunspell.hxx>,' \
+ ${WRKSRC}/libs/vtextedit/src/libs/sonnet/src/plugins/hunspell/hunspelldict.h
+ @${REINPLACE_CMD} -E '/demo|tests/d' \
+ ${WRKSRC}/libs/vtextedit/vtextedit.pro \
+ ${WRKSRC}/vnote.pro
+ @${ECHO_CMD} 'LIBS += -lhunspell-1.7' >> ${WRKSRC}/src/src.pro
+ @${GREP} -Rl --null Q_OS_LINUX ${WRKSRC}/src | ${XARGS} -0 \
+ ${REINPLACE_CMD} -e 's,Q_OS_LINUX,Q_OS_UNIX,'
+
+.include <bsd.port.mk>
diff --git a/deskutils/vnote/distinfo b/deskutils/vnote/distinfo
new file mode 100644
index 000000000000..b0605ed26907
--- /dev/null
+++ b/deskutils/vnote/distinfo
@@ -0,0 +1,11 @@
+TIMESTAMP = 1693148599
+SHA256 (vnotex-vnote-v3.17.0_GH0.tar.gz) = 55c0d059c01ff23fc4e81d3eb754d53a0f201c01db9d305044b72feb130a686a
+SIZE (vnotex-vnote-v3.17.0_GH0.tar.gz) = 7363985
+SHA256 (vnotex-QHotkey-18ac011_GH0.tar.gz) = 558ced948c8642ef4478c7da46658036aa6c3cda31527009096a5e8f4a4ffcf2
+SIZE (vnotex-QHotkey-18ac011_GH0.tar.gz) = 53423
+SHA256 (vnotex-vtextedit-398ec0f_GH0.tar.gz) = fa781bf61e5b72b1b34c0d9536b64a465b574ca0ee56fa0628f71ccdef2e7300
+SIZE (vnotex-vtextedit-398ec0f_GH0.tar.gz) = 1478207
+SHA256 (vnotex-syntax-highlighting-807895f_GH0.tar.gz) = fbf4eabc7bcaaf8c0faef2d6bd357182863887fa8bf8d81e1d6c1705817241b1
+SIZE (vnotex-syntax-highlighting-807895f_GH0.tar.gz) = 2312843
+SHA256 (vnotex-sonnet-403863f_GH0.tar.gz) = 9bd5eab05ee7daf08774dcc428dc9ac245f6179d080c4f93a14ac38e745e1570
+SIZE (vnotex-sonnet-403863f_GH0.tar.gz) = 282981
diff --git a/deskutils/vnote/pkg-descr b/deskutils/vnote/pkg-descr
new file mode 100644
index 000000000000..3a6e9e79e7a2
--- /dev/null
+++ b/deskutils/vnote/pkg-descr
@@ -0,0 +1,4 @@
+VNote is a Qt-based, free and open-source note-taking application,
+currently focusing on Markdown (support for more formats is planned).
+VNote is designed to provide a pleasant note-taking platform with
+excellent editing experience.
diff --git a/deskutils/vnote/pkg-plist b/deskutils/vnote/pkg-plist
new file mode 100644
index 000000000000..e494558a64ea
--- /dev/null
+++ b/deskutils/vnote/pkg-plist
@@ -0,0 +1,18 @@
+bin/vnote
+bin/vnote_extra.rcc
+lib/libVSyntaxHighlighting.so
+lib/libVSyntaxHighlighting.so.1
+lib/libVSyntaxHighlighting.so.1.0
+lib/libVSyntaxHighlighting.so.1.0.0
+lib/libVTextEdit.so
+lib/libVTextEdit.so.1
+lib/libVTextEdit.so.1.0
+lib/libVTextEdit.so.1.0.0
+share/applications/vnote.desktop
+share/icons/hicolor/128x128/apps/vnote.png
+share/icons/hicolor/16x16/apps/vnote.png
+share/icons/hicolor/256x256/apps/vnote.png
+share/icons/hicolor/32x32/apps/vnote.png
+share/icons/hicolor/48x48/apps/vnote.png
+share/icons/hicolor/64x64/apps/vnote.png
+share/icons/hicolor/scalable/apps/vnote.svg