aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWarner Losh <imp@FreeBSD.org>2023-02-23 22:51:10 +0000
committerWarner Losh <imp@FreeBSD.org>2023-02-23 22:56:39 +0000
commit54e6f989275ae7b21551429c72f111d414fd3c39 (patch)
tree0d7bc3ae718c33936314f6adaa24aebfba7a355e
parentaf3d1a7b4e7c3f9be348ef5d3bd99ab9add8254f (diff)
downloadports-54e6f989275ae7b21551429c72f111d414fd3c39.tar.gz
ports-54e6f989275ae7b21551429c72f111d414fd3c39.zip
sysutils/intel-pcm: Fix plist and paths
Some code migrated from pcm-iio.cpp to utils.cpp with hard-coded paths, but the REINPLACE commands were wrong. Additional binaries and files are present in newer versions that were neglected in the last commit. PR: 268730 Fixes: fc33bc299d1e Sponsored by: Netflix
-rw-r--r--sysutils/intel-pcm/Makefile5
-rw-r--r--sysutils/intel-pcm/pkg-plist6
2 files changed, 9 insertions, 2 deletions
diff --git a/sysutils/intel-pcm/Makefile b/sysutils/intel-pcm/Makefile
index efe63cdc1de6..8d39fa5e80e9 100644
--- a/sysutils/intel-pcm/Makefile
+++ b/sysutils/intel-pcm/Makefile
@@ -1,5 +1,6 @@
PORTNAME= intel-pcm
DISTVERSION= 202302
+PORTREVISION= 1
CATEGORIES= sysutils
MAINTAINER= imp@FreeBSD.org
@@ -31,9 +32,9 @@ post-patch:
@${REINPLACE_CMD} -e 's|$${CMAKE_INSTALL_DOCDIR}|$${CMAKE_INSTALL_DATADIR}/doc/${PORTNAME}|g' \
${PATCH_WRKSRC}/src/CMakeLists.txt
@${REINPLACE_CMD} -e 's|/usr/share/pcm/|${DATADIR}/|g' \
- ${PATCH_WRKSRC}/src/pcm-iio.cpp
- @${REINPLACE_CMD} -e 's|/usr/share/pcm/|${DATADIR}/|g' \
${PATCH_WRKSRC}/src/pcm-raw.cpp
+ @${REINPLACE_CMD} -e 's|/usr/share/pcm/|${DATADIR}/|g' \
+ ${PATCH_WRKSRC}/src/utils.cpp
post-install:
${RM} -r ${STAGEDIR}${PREFIX}/share/licenses
diff --git a/sysutils/intel-pcm/pkg-plist b/sysutils/intel-pcm/pkg-plist
index 18c9d5b16031..565cb141d141 100644
--- a/sysutils/intel-pcm/pkg-plist
+++ b/sysutils/intel-pcm/pkg-plist
@@ -1,4 +1,5 @@
sbin/pcm
+sbin/pcm-accel
sbin/pcm-bw-histogram
sbin/pcm-core
sbin/pcm-iio
@@ -13,12 +14,17 @@ sbin/pcm-pcie
sbin/pcm-power
sbin/pcm-raw
sbin/pcm-sensor
+sbin/pcm-sensor-server
sbin/pcm-tsx
+%%DATADIR%%/PMURegisterDeclarations/GenuineIntel-6-4F-1.json
%%DATADIR%%/PMURegisterDeclarations/GenuineIntel-6-55-4.json
%%DATADIR%%/PMURegisterDeclarations/GenuineIntel-6-55-7.json
%%DATADIR%%/PMURegisterDeclarations/GenuineIntel-6-6A-6.json
%%DATADIR%%/PMURegisterDeclarations/GenuineIntel-6-86-5.json
%%DATADIR%%/PMURegisterDeclarations/GenuineIntel-6-8E-C.json
+%%DATADIR%%/PMURegisterDeclarations/GenuineIntel-6-8F-6.json
%%DATADIR%%/opCode-106.txt
%%DATADIR%%/opCode-134.txt
+%%DATADIR%%/opCode-143-accel.txt
+%%DATADIR%%/opCode-143.txt
%%DATADIR%%/opCode-85.txt