aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-10-13 05:33:57 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-10-13 05:33:57 +0000
commit54e8cf9f32cd0efa97305bd7fcfc6db59149dd5d (patch)
treeb43d6262eb2c015c75d4a917e386fce8b1a3bd77
parent362e45336de02778f764564dc9ae89e9e5f08e31 (diff)
downloadports-54e8cf9f32cd0efa97305bd7fcfc6db59149dd5d.tar.gz
ports-54e8cf9f32cd0efa97305bd7fcfc6db59149dd5d.zip
devel/py-backports.cached-property: Add py-backports.cached-property 1.0.1
Python 3.8 adds great descriptor to functools: cached_property. Technically all required APIs was available since python 3.6, but it is what it is. This package is a backport of this functionality for python 3.6 and 3.7. WWW: https://github.com/penguinolog/backports.cached_property
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-backports.cached-property/Makefile22
-rw-r--r--devel/py-backports.cached-property/distinfo3
-rw-r--r--devel/py-backports.cached-property/files/patch-setup.py10
-rw-r--r--devel/py-backports.cached-property/pkg-descr6
5 files changed, 42 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a31d132aec7f..62711ad1cbc7 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4248,6 +4248,7 @@
SUBDIR += py-babi_grammars
SUBDIR += py-backcall
SUBDIR += py-backports
+ SUBDIR += py-backports.cached-property
SUBDIR += py-backports.csv
SUBDIR += py-backports.entry-points-selectable
SUBDIR += py-backports.zoneinfo
diff --git a/devel/py-backports.cached-property/Makefile b/devel/py-backports.cached-property/Makefile
new file mode 100644
index 000000000000..b451dad21996
--- /dev/null
+++ b/devel/py-backports.cached-property/Makefile
@@ -0,0 +1,22 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= backports.cached-property
+PORTVERSION= 1.0.1
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= cached_property() - computed once per instance, cached as attribute
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=3.4:devel/py-setuptools_scm@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-backports.cached-property/distinfo b/devel/py-backports.cached-property/distinfo
new file mode 100644
index 000000000000..38a81aa838b5
--- /dev/null
+++ b/devel/py-backports.cached-property/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1632773602
+SHA256 (backports.cached-property-1.0.1.tar.gz) = 1a5ef1e750f8bc7d0204c807aae8e0f450c655be0cf4b30407a35fd4bb27186c
+SIZE (backports.cached-property-1.0.1.tar.gz) = 7430
diff --git a/devel/py-backports.cached-property/files/patch-setup.py b/devel/py-backports.cached-property/files/patch-setup.py
new file mode 100644
index 000000000000..e5697f8eeff7
--- /dev/null
+++ b/devel/py-backports.cached-property/files/patch-setup.py
@@ -0,0 +1,10 @@
+--- setup.py.orig 2021-02-04 08:47:57 UTC
++++ setup.py
+@@ -65,7 +65,6 @@ setuptools.setup(
+ "setuptools >= 21.0.0,!=24.0.0,"
+ "!=34.0.0,!=34.0.1,!=34.0.2,!=34.0.3,!=34.1.0,!=34.1.1,!=34.2.0,!=34.3.0,!=34.3.1,!=34.3.2,"
+ "!=36.2.0",
+- "wheel",
+ "setuptools_scm[toml]>=3.4",
+ ],
+ install_requires=REQUIRED,
diff --git a/devel/py-backports.cached-property/pkg-descr b/devel/py-backports.cached-property/pkg-descr
new file mode 100644
index 000000000000..8f77b541edc7
--- /dev/null
+++ b/devel/py-backports.cached-property/pkg-descr
@@ -0,0 +1,6 @@
+Python 3.8 adds great descriptor to functools: cached_property. Technically all
+required APIs was available since python 3.6, but it is what it is.
+
+This package is a backport of this functionality for python 3.6 and 3.7.
+
+WWW: https://github.com/penguinolog/backports.cached_property