aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuangyuan Yang <ygy@FreeBSD.org>2021-06-27 01:51:07 +0000
committerGuangyuan Yang <ygy@FreeBSD.org>2021-06-27 01:51:07 +0000
commit55044a2200a4c42b6b653349f0a65dfca3f96f36 (patch)
treeaf86412a5cf8d206899bfc22c2e9501d1ad1b6ee
parent36f56c79f9d13b9401a90e48979a0a2bde74a3a1 (diff)
downloadports-55044a2200a4c42b6b653349f0a65dfca3f96f36.tar.gz
ports-55044a2200a4c42b6b653349f0a65dfca3f96f36.zip
devel/gradle6: New port
devel/gradle needs to be updated to 7.x, while some ports build failed under the newer version, including: - biology/jalview - biology/igv Updated them to use this devel/gradle6 until they officially support 7.x. No functional changes for these ports. Approved by: lwhsu (mentor)
-rw-r--r--biology/igv/Makefile4
-rw-r--r--biology/jalview/Makefile4
-rw-r--r--devel/Makefile1
-rw-r--r--devel/gradle6/Makefile29
-rw-r--r--devel/gradle6/distinfo3
-rw-r--r--devel/gradle6/files/gradle.in2
-rw-r--r--devel/gradle6/pkg-descr16
7 files changed, 55 insertions, 4 deletions
diff --git a/biology/igv/Makefile b/biology/igv/Makefile
index d514583cb41a..39bd21a96377 100644
--- a/biology/igv/Makefile
+++ b/biology/igv/Makefile
@@ -14,7 +14,7 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/license.txt
BUILD_DEPENDS= openjfx14>0:java/openjfx14 \
- gradle:devel/gradle
+ gradle6:devel/gradle6
RUN_DEPENDS= openjfx14>0:java/openjfx14
USES= gettext-runtime
@@ -62,7 +62,7 @@ post-extract: # need a separate extract step because the cache is in /tmp, and n
.endif
do-build:
- cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} gradle \
+ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} gradle6 \
--gradle-user-home ${DEPS_CACHE_DIR}/gradle-${PORTNAME} --project-cache-dir ${DEPS_CACHE_DIR}/gradle-${PORTNAME} \
${GRADLE_ARGS} --build-cache --stacktrace createDist
diff --git a/biology/jalview/Makefile b/biology/jalview/Makefile
index 67bee6fe6514..f3810e2415e8 100644
--- a/biology/jalview/Makefile
+++ b/biology/jalview/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BROKEN_FreeBSD_11= gradle daemon systematically fails on 11: The message received from the daemon indicates that the daemon has disappeared.
-BUILD_DEPENDS= gradle:devel/gradle
+BUILD_DEPENDS= gradle6:devel/gradle6
USE_JAVA= yes
JAVA_VERSION= 11
@@ -61,7 +61,7 @@ PLIST_FILES= bin/jalview \
${DATADIR}/jalview.jar
do-build:
- @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} gradle \
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} gradle6 \
--gradle-user-home ${DEPS_CACHE_DIR}/gradle-${PORTNAME} --project-cache-dir ${DEPS_CACHE_DIR}/gradle-${PORTNAME} \
${GRADLE_ARGS} --build-cache shadowJar
diff --git a/devel/Makefile b/devel/Makefile
index e4f7782fd531..e50ec46d2d02 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -885,6 +885,7 @@
SUBDIR += gradle
SUBDIR += gradle-completion
SUBDIR += gradle5
+ SUBDIR += gradle6
SUBDIR += gradle62
SUBDIR += grantlee5
SUBDIR += grcov
diff --git a/devel/gradle6/Makefile b/devel/gradle6/Makefile
new file mode 100644
index 000000000000..e54a53479b18
--- /dev/null
+++ b/devel/gradle6/Makefile
@@ -0,0 +1,29 @@
+PORTNAME= gradle
+PORTVERSION= 6.9
+CATEGORIES= devel java
+MASTER_SITES= https://downloads.gradle.org/distributions/
+PKGNAMESUFFIX= 6
+EXTRACT_SUFX= -bin.zip
+
+MAINTAINER= ygy@FreeBSD.org
+COMMENT= Project automation tool
+
+LICENSE= APACHE20 BSD3CLAUSE CDDL EPL LGPL21+ MIT MPL20
+LICENSE_COMB= multi
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= zip
+USE_JAVA= yes
+NO_ARCH= yes
+NO_BUILD= yes
+SUB_FILES= gradle
+SUB_LIST= JAVA=${JAVA} \
+ PORTVERSION=${PORTVERSION}
+PLIST_FILES= bin/gradle
+PORTDATA= *
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/gradle ${STAGEDIR}${PREFIX}/bin/gradle
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} lib ${STAGEDIR}${DATADIR})
+
+.include <bsd.port.mk>
diff --git a/devel/gradle6/distinfo b/devel/gradle6/distinfo
new file mode 100644
index 000000000000..377857ed10c6
--- /dev/null
+++ b/devel/gradle6/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1624750882
+SHA256 (gradle-6.9-bin.zip) = 765442b8069c6bee2ea70713861c027587591c6b1df2c857a23361512560894e
+SIZE (gradle-6.9-bin.zip) = 108129558
diff --git a/devel/gradle6/files/gradle.in b/devel/gradle6/files/gradle.in
new file mode 100644
index 000000000000..25d4d31d87f5
--- /dev/null
+++ b/devel/gradle6/files/gradle.in
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec "java" -Dorg.gradle.native=false $JAVA_OPTS -classpath "%%DATADIR%%/lib/gradle-launcher-%%PORTVERSION%%.jar" org.gradle.launcher.GradleMain "$@"
diff --git a/devel/gradle6/pkg-descr b/devel/gradle6/pkg-descr
new file mode 100644
index 000000000000..9ca5da488bc7
--- /dev/null
+++ b/devel/gradle6/pkg-descr
@@ -0,0 +1,16 @@
+Gradle is build automation evolved.
+
+Gradle can automate the building, testing, publishing, deployment
+and more of software packages or other types of projects such as
+generated static websites, generated documentation or indeed anything
+else.
+
+Gradle combines the power and flexibility of Ant with the dependency
+management and conventions of Maven into a more effective way to
+build. Powered by a Groovy DSL and packed with innovation, Gradle
+provides a declarative way to describe all kinds of builds through
+sensible defaults. Gradle is quickly becoming the build system of
+choice for many open source projects, leading edge enterprises and
+legacy automation challenges.
+
+WWW: https://www.gradle.org/