aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2024-05-21 19:11:58 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2024-05-21 19:56:02 +0000
commit5569738064d7d6eabe931bf2975fe2ef2b284210 (patch)
treec6f5ff7842da0da7fce5a97331f856598c8dfa09
parentaa9d236237bf9c9afa3f09ab67717fd60f88988c (diff)
downloadports-5569738064d7d6eabe931bf2975fe2ef2b284210.tar.gz
ports-5569738064d7d6eabe931bf2975fe2ef2b284210.zip
security/nmap: Use EXTRACT_AFTER_ARGS
To decrease I/O load skip extracting files instead of removing after extraction PR: 278742 Approved by: portmgr (maintainer timeout, 2+ weeks)
-rw-r--r--security/nmap/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/security/nmap/Makefile b/security/nmap/Makefile
index 820e26ffb6ca..c3b20bc1ae9d 100644
--- a/security/nmap/Makefile
+++ b/security/nmap/Makefile
@@ -21,6 +21,11 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
.if !defined(MASTERDIR)
USES= tar:bzip2 gmake cpe
+
+# XXX limit results if we do a grep in the sources!
+EXTRACT_AFTER_ARGS= --exclude ${DISTNAME}/mswin32 \
+ --no-same-owner --no-same-permissions
+
GNU_CONFIGURE= yes
GNU_CONFIGURE_MANPREFIX=${PREFIX}/share
@@ -54,10 +59,6 @@ CONFIGURE_ARGS+=--without-localdirs \
.include <bsd.port.options.mk>
-# XXX limit results if we do a grep in the sources!
-post-extract:
- @${RM} -r ${WRKSRC}/mswin32
-
.if exists(/usr/lib/libibverbs.a)
# Link with libibverbs is needed by static libpcap
post-patch-PCAP-on: