aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2022-12-30 08:26:41 +0000
committerJan Beich <jbeich@FreeBSD.org>2022-12-31 00:26:50 +0000
commit559edaedc8141cdd5b02c86589b76808fca1d42f (patch)
tree59f329525ce7a39d4a36150cfb383572434eae4a
parent079a609d10c39a0e4f75eb7f6e241bd10a081010 (diff)
downloadports-559edaedc8141cdd5b02c86589b76808fca1d42f.tar.gz
ports-559edaedc8141cdd5b02c86589b76808fca1d42f.zip
emulators/yuzu: update to s20221230
-rw-r--r--emulators/yuzu/Makefile6
-rw-r--r--emulators/yuzu/distinfo10
-rw-r--r--emulators/yuzu/files/patch-libusb17
3 files changed, 18 insertions, 15 deletions
diff --git a/emulators/yuzu/Makefile b/emulators/yuzu/Makefile
index 7cec3357f302..463f05f0e2e2 100644
--- a/emulators/yuzu/Makefile
+++ b/emulators/yuzu/Makefile
@@ -1,5 +1,5 @@
PORTNAME= yuzu
-PORTVERSION= s20221228
+PORTVERSION= s20221230
CATEGORIES= emulators wayland
.if make(makesum)
MASTER_SITES= https://api.yuzu-emu.org/gamedb/?dummy=/:gamedb
@@ -53,7 +53,7 @@ qt6_OPTIONS_EXCLUDE= QT5
USE_GITHUB= yes
GH_ACCOUNT= yuzu-emu
-GH_TAGNAME= 60419dd35
+GH_TAGNAME= 88f5d38b9
GH_TUPLE= yuzu-emu:mbedtls:v2.16.9-115-g8c88150ca:mbedtls/externals/mbedtls \
yuzu-emu:sirit:d7ad93a:sirit/externals/sirit \
KhronosGroup:SPIRV-Headers:1.5.4.raytracing.fixed-201-gc214f6f:SPIRV_Headers/externals/sirit/externals/SPIRV-Headers \
@@ -68,7 +68,7 @@ USES= cmake:testing elfctl localbase:ldflags pkgconfig sdl ssl
USE_SDL= sdl2
CMAKE_ON= Boost_USE_STATIC_LIBS
CMAKE_ON+= BUNDLE_SPEEX # only used by cubeb tests
-CMAKE_OFF= YUZU_CHECK_SUBMODULES YUZU_USE_EXTERNAL_SDL2
+CMAKE_OFF= YUZU_CHECK_SUBMODULES YUZU_USE_EXTERNAL_SDL2 YUZU_USE_EXTERNAL_VULKAN_HEADERS
CMAKE_OFF+= ${CMAKE_TESTING_ON}
CMAKE_TESTING_ON= YUZU_TESTS
CXXFLAGS+= -D_LIBCPP_HAS_NO_INCOMPLETE_RANGES # common/polyfill_ranges.h
diff --git a/emulators/yuzu/distinfo b/emulators/yuzu/distinfo
index cb72a75dee56..3442d9cff1d4 100644
--- a/emulators/yuzu/distinfo
+++ b/emulators/yuzu/distinfo
@@ -1,8 +1,8 @@
-TIMESTAMP = 1672266511
-SHA256 (yuzu-s20221228/compatibility_list.json) = 0152fbc04a849e37d35717c5f0d7760a6edc0fd5af1468e4f64025c787fabac1
-SIZE (yuzu-s20221228/compatibility_list.json) = 1662235
-SHA256 (yuzu-emu-yuzu-s20221228-60419dd35_GH0.tar.gz) = c54e651d13c0db5864168db583f66790148deec12d7a1cdf061c205e81ff2b01
-SIZE (yuzu-emu-yuzu-s20221228-60419dd35_GH0.tar.gz) = 5399219
+TIMESTAMP = 1672431620
+SHA256 (yuzu-s20221230/compatibility_list.json) = d8023ad0cec2c53fc07f57537bc5a9991370b4e6f22a609cb618c4f8234618c9
+SIZE (yuzu-s20221230/compatibility_list.json) = 1662434
+SHA256 (yuzu-emu-yuzu-s20221230-88f5d38b9_GH0.tar.gz) = b1c703421c2c9ee30dbf482731a03fccef2c4cf6c1a995d5eea5faa27b2bcbdd
+SIZE (yuzu-emu-yuzu-s20221230-88f5d38b9_GH0.tar.gz) = 5400344
SHA256 (yuzu-emu-mbedtls-v2.16.9-115-g8c88150ca_GH0.tar.gz) = 8cd6d075b4da0ad5fb995eb37390e2e6088be8d41ab1cdfc7e7e4256bd991450
SIZE (yuzu-emu-mbedtls-v2.16.9-115-g8c88150ca_GH0.tar.gz) = 2679189
SHA256 (yuzu-emu-sirit-d7ad93a_GH0.tar.gz) = f338a73c12bcc4e6c18a1a8104ca7bf30af40eb37b4054992e3be4c3d3589faa
diff --git a/emulators/yuzu/files/patch-libusb b/emulators/yuzu/files/patch-libusb
index 5f4e087c9064..a5ae2a061f9c 100644
--- a/emulators/yuzu/files/patch-libusb
+++ b/emulators/yuzu/files/patch-libusb
@@ -3,11 +3,14 @@ compatibility with newer versions of the reference implementation.
-- Could NOT find libusb: Found unsuitable version "1.0.13", but required is at least "1.0.24" (found /usr/lib/libusb.so)
---- CMakeLists.txt.orig 2022-12-07 02:08:14 UTC
+--- CMakeLists.txt.orig 2022-12-30 08:26:41 UTC
+++ CMakeLists.txt
-@@ -203,4 +203,4 @@
--find_package(libusb 1.0.24)
-+find_package(libusb)
- find_package(lz4 REQUIRED)
- find_package(nlohmann_json 3.8 REQUIRED)
- find_package(Opus 1.3)
+@@ -221,7 +221,7 @@ if (ENABLE_LIBUSB)
+ endif()
+
+ if (ENABLE_LIBUSB)
+- find_package(libusb 1.0.24)
++ find_package(libusb)
+ endif()
+
+ if (ARCHITECTURE_x86 OR ARCHITECTURE_x86_64)