aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2022-11-18 14:31:01 +0000
committerNicola Vitale <nivit@FreeBSD.org>2022-11-18 14:31:01 +0000
commit55fb5874fcce06a26dfed53a795e1cff25ebcce0 (patch)
treee6729429aee06712e3eabacbd47b7d3c8051bb6f
parent9b3b2cf3202f6a663e9a2cd2b271a39be47f1572 (diff)
downloadports-55fb5874fcce06a26dfed53a795e1cff25ebcce0.tar.gz
ports-55fb5874fcce06a26dfed53a795e1cff25ebcce0.zip
math/muparser: update to 2.3.4
- Use PLIST_SUB to remove hard-coded version of the program - Reorder variables in Makefile - Fix value of LICENSE_FILE
-rw-r--r--math/muparser/Makefile21
-rw-r--r--math/muparser/distinfo6
-rw-r--r--math/muparser/files/patch-docs_Doxyfile6
-rw-r--r--math/muparser/pkg-plist2
4 files changed, 19 insertions, 16 deletions
diff --git a/math/muparser/Makefile b/math/muparser/Makefile
index 97335db011c7..e924510c3f3f 100644
--- a/math/muparser/Makefile
+++ b/math/muparser/Makefile
@@ -1,5 +1,5 @@
PORTNAME= muparser
-PORTVERSION= 2.3.2
+PORTVERSION= 2.3.4
DISTVERSIONPREFIX= v
CATEGORIES= math devel
@@ -8,23 +8,26 @@ COMMENT= Mathematical expressions parser library written in C++
WWW= https://beltoforion.de/en/muparser/
LICENSE= BSD2CLAUSE
-LICENSE_FILE= ${WRKSRC}/License.txt
+LICENSE_FILE= ${WRKSRC}/LICENSE
USES= cmake compiler:c++11-lang
-USE_LDCONFIG= yes
-
USE_GITHUB= yes
GH_ACCOUNT= beltoforion
+USE_LDCONFIG= yes
-OPTIONS_DEFINE= EXAMPLES
-
+.if !exists(/usr/include/omp.h)
+CMAKE_ARGS+= -DENABLE_OPENMP:BOOL=OFF
+.endif
CMAKE_OFF= ENABLE_SAMPLES
+PLIST_SUB= MUPARSER_VERSION=${MUPARSER_VERSION}
+OPTIONS_DEFINE= EXAMPLES
EXAMPLES_PORTEXAMPLES= *
-.if !exists(/usr/include/omp.h)
-CMAKE_ARGS+= -DENABLE_OPENMP:BOOL=OFF
-.endif
+MUPARSER_VERSION= ${PORTVERSION}
+
+post-patch:
+ ${SED} -i.bak -e 's/%%MUPARSER_VERSION%%/${MUPARSER_VERSION}/' ${WRKSRC}/docs/Doxyfile
post-install-EXAMPLES-on:
cd ${WRKSRC} && ${COPYTREE_SHARE} samples ${STAGEDIR}${EXAMPLESDIR}
diff --git a/math/muparser/distinfo b/math/muparser/distinfo
index a9e9e273bd30..a4ac1afea98d 100644
--- a/math/muparser/distinfo
+++ b/math/muparser/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1610209798
-SHA256 (beltoforion-muparser-v2.3.2_GH0.tar.gz) = b35fc84e3667d432e3414c8667d5764dfa450ed24a99eeef7ee3f6647d44f301
-SIZE (beltoforion-muparser-v2.3.2_GH0.tar.gz) = 103979
+TIMESTAMP = 1668768752
+SHA256 (beltoforion-muparser-v2.3.4_GH0.tar.gz) = 0c3fa54a3ebf36dda0ed3e7cd5451c964afbb15102bdbcba08aafb359a290121
+SIZE (beltoforion-muparser-v2.3.4_GH0.tar.gz) = 112693
diff --git a/math/muparser/files/patch-docs_Doxyfile b/math/muparser/files/patch-docs_Doxyfile
index 1fc059a3ae87..eda372937f44 100644
--- a/math/muparser/files/patch-docs_Doxyfile
+++ b/math/muparser/files/patch-docs_Doxyfile
@@ -1,11 +1,11 @@
---- docs/Doxyfile.orig 2015-08-16 14:23:14 UTC
+--- docs/Doxyfile.orig 2022-11-09 11:54:31 UTC
+++ docs/Doxyfile
-@@ -31,7 +31,7 @@ PROJECT_NAME = "muParser API -
+@@ -31,7 +31,7 @@ PROJECT_NAME = "muParser API -"
# This could be handy for archiving the generated documentation or
# if some version control system is used.
-PROJECT_NUMBER = 1.35
-+PROJECT_NUMBER = 2.2.5
++PROJECT_NUMBER = %%MUPARSER_VERSION%%
# The OUTPUT_DIRECTORY tag is used to specify the (relative or absolute)
# base path where the generated documentation will be put.
diff --git a/math/muparser/pkg-plist b/math/muparser/pkg-plist
index 885c9de7ca07..e63e7b1374a4 100644
--- a/math/muparser/pkg-plist
+++ b/math/muparser/pkg-plist
@@ -13,5 +13,5 @@ include/muParserToken.h
include/muParserTokenReader.h
lib/libmuparser.so
lib/libmuparser.so.2
-lib/libmuparser.so.2.3.2
+lib/libmuparser.so.%%MUPARSER_VERSION%%
libdata/pkgconfig/muparser.pc