aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2023-03-06 11:24:35 +0000
committerGleb Popov <arrowd@FreeBSD.org>2023-03-06 11:30:44 +0000
commit5699106002b551d66a29a37f501d553e7245c18d (patch)
tree2cc47c5b4b257c795b4b86ae1f2fff73441c5ca3
parente36085bccca7192ebc91e87ce2fb3560dd645eae (diff)
downloadports-5699106002b551d66a29a37f501d553e7245c18d.tar.gz
ports-5699106002b551d66a29a37f501d553e7245c18d.zip
sysutils/plasma5-systemsettings and x11-wm/plasma5-kwin: Fix desktop effects previews.
An obscure gstreamer bug [1] prevents .ogv videos from being played via curl plugin. Workaround this by re-encoding Theora videos into WebM (suggested at KDE Devel Matrix channel) and store it on my site for the time being. [1] https://gitlab.freedesktop.org/gstreamer/gstreamer/-/issues/2026 Sponsored by: Serenity Cybersecurity, LLC
-rw-r--r--sysutils/plasma5-systemsettings/Makefile4
-rw-r--r--x11-wm/plasma5-kwin/Makefile9
2 files changed, 10 insertions, 3 deletions
diff --git a/sysutils/plasma5-systemsettings/Makefile b/sysutils/plasma5-systemsettings/Makefile
index f96318dfaaab..c5e4a791731e 100644
--- a/sysutils/plasma5-systemsettings/Makefile
+++ b/sysutils/plasma5-systemsettings/Makefile
@@ -1,6 +1,6 @@
PORTNAME= systemsettings
DISTVERSION= ${KDE_PLASMA_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -9,7 +9,7 @@ WWW= https://www.kde.org/plasma-desktop
USES= cmake compiler:c++11-lib gettext gstreamer kde:5 qt:5 tar:xz \
xorg
-USE_GSTREAMER= curl openh264 theora
+USE_GSTREAMER= curl openh264 vpx
USE_KDE= activities activities-stats auth codecs completion config \
configwidgets coreaddons crash dbusaddons guiaddons i18n \
iconthemes itemmodels itemviews jobwidgets js kcmutils \
diff --git a/x11-wm/plasma5-kwin/Makefile b/x11-wm/plasma5-kwin/Makefile
index 4489cd099df9..232c6125940f 100644
--- a/x11-wm/plasma5-kwin/Makefile
+++ b/x11-wm/plasma5-kwin/Makefile
@@ -1,6 +1,6 @@
PORTNAME= kwin
DISTVERSION= ${KDE_PLASMA_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-wm kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -56,4 +56,11 @@ SHEBANG_FILES= kconf_update/*.py \
kconf_update/*.pl \
src/effects/strip-effect-metadata.py
+# A (hopefully) temporary workaround for
+# https://gitlab.freedesktop.org/gstreamer/gstreamer/-/issues/2026
+post-patch:
+ ${REINPLACE_CMD} -E \
+ 's|https://files.kde.org/plasma/kwin/effect-videos/([a-z_]+)\.ogv|https://arrowd.name/kwin-effect-videos/\1\.webm|' \
+ ${WRKSRC}/src/effects/*/metadata.json
+
.include <bsd.port.mk>