aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2023-04-08 11:37:55 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2023-04-08 11:40:39 +0000
commit56be636b7f70848199f09c3036c7051690c42965 (patch)
treec8ee6e589fd3021aa73816707566489ab8fa6252
parentff0eeb428d1d8f98411adf5d333559708cb14859 (diff)
downloadports-56be636b7f70848199f09c3036c7051690c42965.tar.gz
ports-56be636b7f70848199f09c3036c7051690c42965.zip
multimedia/dvdstyler: Update to 3.3b3
- Fixes build with FFmpeg 6 - Additional runtime patch by Alan Hicks (maintainer) Changelog: https://sourceforge.net/projects/dvdstyler/files/dvdstyler-devel/3.3b3/ PR: 270223 Reviewed by: Alan Hicks <ahicks@p-o.co.uk> (maintainer) Tested by: Alan Hicks <ahicks@p-o.co.uk>
-rw-r--r--multimedia/dvdstyler/Makefile20
-rw-r--r--multimedia/dvdstyler/distinfo6
-rw-r--r--multimedia/dvdstyler/files/patch-configure.ac20
-rw-r--r--multimedia/dvdstyler/files/patch-src_mediaenc__ffmpeg.cpp12
-rw-r--r--multimedia/dvdstyler/files/patch-wxVillaLib-PropDlg.cpp10
-rw-r--r--multimedia/dvdstyler/pkg-plist11
6 files changed, 34 insertions, 45 deletions
diff --git a/multimedia/dvdstyler/Makefile b/multimedia/dvdstyler/Makefile
index 54448df35bc7..a8f4fbd90766 100644
--- a/multimedia/dvdstyler/Makefile
+++ b/multimedia/dvdstyler/Makefile
@@ -1,10 +1,10 @@
PORTNAME= dvdstyler
-PORTVERSION= 3.2.1
-PORTREVISION= 1
+DISTVERSION= 3.3b3
PORTEPOCH= 2
CATEGORIES= multimedia
-MASTER_SITES= SF
-DISTNAME= DVDStyler-${PORTVERSION}
+#MASTER_SITES= SF
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-devel/${DISTVERSION}
+DISTNAME= DVDStyler-${DISTVERSION}
MAINTAINER= ahicks@p-o.co.uk
COMMENT= WxWidgets frontend to dvd recoding and authoring programs
@@ -33,16 +33,14 @@ RUN_DEPENDS= zip:archivers/zip \
mkisofs:sysutils/cdrtools \
growisofs:sysutils/dvd+rw-tools
-USES= autoreconf compiler:c++11-lib gettext gmake jpeg pkgconfig tar:bzip2
-
-USE_WX= 3.2
+USES= autoreconf compiler:c++11-lib gettext gmake jpeg \
+ localbase:ldflags pkgconfig tar:bzip2
+USE_WX= 3.2+
WX_CONF_ARGS= absolute
+
GNU_CONFIGURE= yes
-CONFIGURE_ENV= ac_cv_path_AVCONV_PATH="" OBJCXX="${CXX}"
-CONFIGURE_ARGS= --without-gnome
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= ac_cv_path_AVCONV_PATH="" OBJCXX="${CXX}"
OPTIONS_DEFINE= DOCS
diff --git a/multimedia/dvdstyler/distinfo b/multimedia/dvdstyler/distinfo
index ff967f3cf876..c3c191dac576 100644
--- a/multimedia/dvdstyler/distinfo
+++ b/multimedia/dvdstyler/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1636284298
-SHA256 (DVDStyler-3.2.1.tar.bz2) = 0bb3348739f4c93097454b814ecb3a58f6bace8f030f41619a9feeafb4747558
-SIZE (DVDStyler-3.2.1.tar.bz2) = 9040634
+TIMESTAMP = 1678827360
+SHA256 (DVDStyler-3.3b3.tar.bz2) = 7e37417f464640dfeecffb5fd4ed212999845b1c43955b203f3d691e782fe52b
+SIZE (DVDStyler-3.3b3.tar.bz2) = 9899576
diff --git a/multimedia/dvdstyler/files/patch-configure.ac b/multimedia/dvdstyler/files/patch-configure.ac
deleted file mode 100644
index 336b89e07e77..000000000000
--- a/multimedia/dvdstyler/files/patch-configure.ac
+++ /dev/null
@@ -1,20 +0,0 @@
---- configure.ac.orig 2019-10-03 16:00:00 UTC
-+++ configure.ac
-@@ -9,6 +9,7 @@ AM_MAINTAINER_MODE
- dnl options
- AM_OPTIONS_WXCONFIG
- AC_ARG_ENABLE(debug, [ --enable-debug Enable debugging information], USE_DEBUG="$enableval", USE_DEBUG="no")
-+AC_ARG_WITH(gnome, [ --with-gnome Use libgnomeui for rendering of thumbnails], with_gnome="$withval", with_gnome="no")
-
- AC_MSG_CHECKING(for install location)
- case "$prefix" in
-@@ -113,7 +114,9 @@ if test "x$WXSVGLIBAV" = x"no"; then
- fi
-
- dnl check gnomeui-2.0
-+if test x"$with_gnome" != x"no"; then
- CHECK_WX_BUILT_WITH_GTK2()
-+fi
- if test x"$GTK_USEDVERSION" = x"2" ; then
- PKG_CHECK_MODULES(GNOMEUI2, libgnomeui-2.0, GNOME2="-DGNOME2",
- AC_MSG_WARN([libgnomeui will not be used for rendering of thumbnails]))
diff --git a/multimedia/dvdstyler/files/patch-src_mediaenc__ffmpeg.cpp b/multimedia/dvdstyler/files/patch-src_mediaenc__ffmpeg.cpp
new file mode 100644
index 000000000000..c43c9d1ea648
--- /dev/null
+++ b/multimedia/dvdstyler/files/patch-src_mediaenc__ffmpeg.cpp
@@ -0,0 +1,12 @@
+--- src/mediaenc_ffmpeg.cpp.orig 2022-10-03 20:02:59 UTC
++++ src/mediaenc_ffmpeg.cpp
+@@ -330,7 +330,9 @@ bool wxFfmpegMediaEncoder::addAudioStream(int codecId)
+ return false;
+ for (int i = 0; i < c->channels; i++) {
+ uint16_t *samples = (uint16_t*)m_audioFrame->data[i];
++ if (samples) {
+ memset(samples, 0, c->frame_size * av_get_bytes_per_sample(c->sample_fmt));
++ }
+ }
+
+ return true;
diff --git a/multimedia/dvdstyler/files/patch-wxVillaLib-PropDlg.cpp b/multimedia/dvdstyler/files/patch-wxVillaLib-PropDlg.cpp
deleted file mode 100644
index fdfad8aca8ba..000000000000
--- a/multimedia/dvdstyler/files/patch-wxVillaLib-PropDlg.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- wxVillaLib/PropDlg2.cpp 2021-07-28 16:49:08.802073000 +0100
-+++ wxVillaLib/PropDlg.cpp 2021-07-28 16:49:33.888103000 +0100
-@@ -12,7 +12,6 @@
- #include "utils.h"
- #include <wx/fontdlg.h>
- #include <wx/colordlg.h>
--#include <wx/generic/colrdlgg.h>
- #include <wx/filedlg.h>
- #include <wx/dirdlg.h>
- #include <wx/grid.h>
diff --git a/multimedia/dvdstyler/pkg-plist b/multimedia/dvdstyler/pkg-plist
index ccc8c8d82343..ba76d0a28194 100644
--- a/multimedia/dvdstyler/pkg-plist
+++ b/multimedia/dvdstyler/pkg-plist
@@ -45,6 +45,7 @@ share/applications/dvdstyler.desktop
%%DATADIR%%/backgrounds/green_trees.jpg
%%DATADIR%%/backgrounds/penguin.png
%%DATADIR%%/backgrounds/red_sky.jpg
+%%DATADIR%%/backgrounds/wall.jpg
%%DATADIR%%/buttons/arrow-blue.xml
%%DATADIR%%/buttons/arrow-cool.xml
%%DATADIR%%/buttons/arrow-double.xml
@@ -83,6 +84,7 @@ share/applications/dvdstyler.desktop
%%DATADIR%%/buttons/deprecated/frame-shadow.xml
%%DATADIR%%/buttons/deprecated/frame.xml
%%DATADIR%%/buttons/deprecated/frame45.xml
+%%DATADIR%%/buttons/deprecated/gold-frame.xml
%%DATADIR%%/buttons/deprecated/home.xml
%%DATADIR%%/buttons/deprecated/text-circle.xml
%%DATADIR%%/buttons/deprecated/text-shadow.xml
@@ -96,8 +98,8 @@ share/applications/dvdstyler.desktop
%%DATADIR%%/buttons/frame-text.xml
%%DATADIR%%/buttons/frame-v2.xml
%%DATADIR%%/buttons/gear.xml
+%%DATADIR%%/buttons/gold-frame-v2.xml
%%DATADIR%%/buttons/glow_arrow.xml
-%%DATADIR%%/buttons/gold-frame.xml
%%DATADIR%%/buttons/hand-left.xml
%%DATADIR%%/buttons/hand-right.xml
%%DATADIR%%/buttons/home-moon.xml
@@ -147,6 +149,7 @@ share/applications/dvdstyler.desktop
%%DATADIR%%/docs/help_uk.zip
%%DATADIR%%/docs/help_zh_CN.zip
%%DATADIR%%/docs/help_zh_TW.zip
+%%DATADIR%%/objects/caption-rectangle.xml
%%DATADIR%%/objects/caption-line.xml
%%DATADIR%%/objects/deprecated/ellipse-v2.xml
%%DATADIR%%/objects/deprecated/ellipse.xml
@@ -195,6 +198,8 @@ share/applications/dvdstyler.desktop
%%DATADIR%%/rc/run.png
%%DATADIR%%/rc/save.png
%%DATADIR%%/rc/settings.png
+%%DATADIR%%/templates/Basic/Wall.dvdt
+%%DATADIR%%/templates/Basic/Wall.png
%%DATADIR%%/templates/Basic/blue.dvdt
%%DATADIR%%/templates/Basic/blue.png
%%DATADIR%%/templates/Basic/blueWS.dvdt
@@ -215,6 +220,10 @@ share/applications/dvdstyler.desktop
%%DATADIR%%/templates/Basic/ocean.png
%%DATADIR%%/templates/Basic/oceanWS.dvdt
%%DATADIR%%/templates/Basic/oceanWS.png
+%%DATADIR%%/templates/Basic/textAuto1.dvdt
+%%DATADIR%%/templates/Basic/textAuto1.png
+%%DATADIR%%/templates/Basic/textAuto1WS.dvdt
+%%DATADIR%%/templates/Basic/textAuto1WS.png
%%DATADIR%%/templates/Basic/turbulence.dvdt
%%DATADIR%%/templates/Basic/turbulence.png
%%DATADIR%%/templates/Basic/turbulenceWS.dvdt