aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Baldwin <jhb@FreeBSD.org>2023-11-21 21:45:52 +0000
committerJohn Baldwin <jhb@FreeBSD.org>2023-11-21 21:45:52 +0000
commit5723f9adab52b897b119d0b53a2939c75f6fdc3f (patch)
treef92312e94b448a3bee570a06b4035fdc64042311
parentfe56c9d073ce01d192ece54f9af65cde8fd2aaad (diff)
downloadports-5723f9adab52b897b119d0b53a2939c75f6fdc3f.tar.gz
ports-5723f9adab52b897b119d0b53a2939c75f6fdc3f.zip
devel/freebsd-gcc{9,12}: Various cleanups, no functional change
- Use DISTVERSION instead of PORTVERISON - Don't silence post-install commands to remove various files from the staging area - Simplify logic to handle arch-specific packing lists - Clarify package comment and description - Clarify FreeBSD 12 ignore rule for gcc12 Reviewed by: fuz Differential Revision: https://reviews.freebsd.org/D42590
-rw-r--r--devel/freebsd-gcc12/Makefile33
-rw-r--r--devel/freebsd-gcc12/pkg-descr4
-rw-r--r--devel/freebsd-gcc12/pkg-plist.riscv64 (renamed from devel/freebsd-gcc12/pkg-plist.riscv)0
-rw-r--r--devel/freebsd-gcc9/Makefile37
-rw-r--r--devel/freebsd-gcc9/pkg-descr4
-rw-r--r--devel/freebsd-gcc9/pkg-plist.riscv64 (renamed from devel/freebsd-gcc9/pkg-plist.riscv)0
6 files changed, 21 insertions, 57 deletions
diff --git a/devel/freebsd-gcc12/Makefile b/devel/freebsd-gcc12/Makefile
index b1d33c394213..3908ae055431 100644
--- a/devel/freebsd-gcc12/Makefile
+++ b/devel/freebsd-gcc12/Makefile
@@ -1,18 +1,18 @@
PORTNAME= gcc
-PORTVERSION= 12.3.0
+DISTVERSION= 12.3.0
CATEGORIES= devel
MASTER_SITES= GCC
PKGNAMEPREFIX= ${TARGETARCH}-
PKGNAMESUFFIX= ${SUFFIX}
MAINTAINER= jhb@FreeBSD.org
-COMMENT= Cross GNU Compiler Collection for ${TARGETARCH}
+COMMENT= Cross GNU Compiler ${SUFFIX} for FreeBSD/${TARGETARCH}
WWW= https://gcc.gnu.org/
LICENSE= GPLv3 GPLv3RLE
LICENSE_COMB= multi
-IGNORE_FreeBSD_12= Not supported on FreeBSD 12
+IGNORE_FreeBSD_12= Does not build
BUILD_DEPENDS= ${BU_PREFIX}-as:devel/binutils@${BU_FLAVOR} \
objdump:devel/binutils
@@ -106,36 +106,21 @@ PLIST_SUB+= FLOAT_H=""
.endif
PLIST= ${.CURDIR}/pkg-plist
+PLISTARCH= ${TARGETARCH:C/armv[67]/arm_gnueabi/}
+PLIST+= ${.CURDIR}/pkg-plist.${PLISTARCH}
-.if ${TARGETARCH} == "aarch64"
-PLIST+= ${.CURDIR}/pkg-plist.aarch64
-.endif
.if ${TARGETARCH} == "aarch64" || ${TARGETARCH:Marm*}
PLIST+= ${.CURDIR}/pkg-plist.arm
.endif
-.if ${TARGETARCH:Marm*}
-PLIST+= ${.CURDIR}/pkg-plist.arm_gnueabi
-.endif
.if ${TARGETARCH} == "amd64"
-PLIST+= ${.CURDIR}/pkg-plist.amd64
-.endif
-.if ${TARGETARCH} == "amd64" || ${TARGETARCH} == "i386"
PLIST+= ${.CURDIR}/pkg-plist.i386
.endif
-.if ${TARGETARCH:Mpowerpc64*}
-PLIST+= ${.CURDIR}/pkg-plist.powerpc64
-.elif ${TARGETARCH:Mpowerpc*}
-PLIST+= ${.CURDIR}/pkg-plist.powerpc
-.endif
-.if ${TARGETARCH:Mriscv*}
-PLIST+= ${.CURDIR}/pkg-plist.riscv
-.endif
post-install:
- @${RM} ${STAGEDIR}${PREFIX}/bin/${GCC_TARGET}-${GCC_TARGET}-*
- @${RM} ${STAGEDIR}${PREFIX}/share/info/*
- @${RM} ${STAGEDIR}${PREFIX}/man/man7/*
- @${RM} -r ${STAGEDIR}${PREFIX}/lib/gcc/${GCC_TARGET}/${PORTVERSION}/include-fixed
+ ${RM} ${STAGEDIR}${PREFIX}/bin/${GCC_TARGET}-${GCC_TARGET}-*
+ ${RM} ${STAGEDIR}${PREFIX}/share/info/*
+ ${RM} ${STAGEDIR}${PREFIX}/man/man7/*
+ ${RM} -r ${STAGEDIR}${PREFIX}/lib/gcc/${GCC_TARGET}/${PORTVERSION}/include-fixed
.if ${TARGETARCH} == "amd64" || ${TARGETARCH} == "i386"
# Conflicts with sys/x86/include/float.h
${RM} ${STAGEDIR}${PREFIX}/lib/gcc/${GCC_TARGET}/${PORTVERSION}/include/float.h
diff --git a/devel/freebsd-gcc12/pkg-descr b/devel/freebsd-gcc12/pkg-descr
index aa16abf61500..505ca21589ce 100644
--- a/devel/freebsd-gcc12/pkg-descr
+++ b/devel/freebsd-gcc12/pkg-descr
@@ -1,2 +1,2 @@
-GCC, the GNU Compiler Collection, supporting C and C++ for building the
-FreeBSD base system.
+GCC, the GNU C/C++ Compiler, customized to build the FreeBSD base system.
+To use GCC for other purposes, please use one of the lang/gcc* packages.
diff --git a/devel/freebsd-gcc12/pkg-plist.riscv b/devel/freebsd-gcc12/pkg-plist.riscv64
index 5f0ba58f0e14..5f0ba58f0e14 100644
--- a/devel/freebsd-gcc12/pkg-plist.riscv
+++ b/devel/freebsd-gcc12/pkg-plist.riscv64
diff --git a/devel/freebsd-gcc9/Makefile b/devel/freebsd-gcc9/Makefile
index 7b9bcdd8db65..8a7eec722c63 100644
--- a/devel/freebsd-gcc9/Makefile
+++ b/devel/freebsd-gcc9/Makefile
@@ -1,5 +1,5 @@
PORTNAME= gcc
-PORTVERSION= 9.5.0
+DISTVERSION= 9.5.0
PORTREVISION= 11
CATEGORIES= devel
MASTER_SITES= GCC
@@ -7,7 +7,7 @@ PKGNAMEPREFIX= ${TARGETARCH}-
PKGNAMESUFFIX= ${SUFFIX}
MAINTAINER= jhb@FreeBSD.org
-COMMENT= Cross GNU Compiler Collection for ${TARGETARCH}
+COMMENT= Cross GNU Compiler ${SUFFIX} for FreeBSD/${TARGETARCH}
WWW= https://gcc.gnu.org/
LICENSE= GPLv3 GPLv3RLE
@@ -107,42 +107,21 @@ PLIST_SUB+= FLOAT_H=""
.endif
PLIST= ${.CURDIR}/pkg-plist
+PLISTARCH= ${TARGETARCH:C/armv[67]/arm_gnueabi/:C/mips.*/mips/}
+PLIST+= ${.CURDIR}/pkg-plist.${PLISTARCH}
-.if ${TARGETARCH} == "aarch64"
-PLIST+= ${.CURDIR}/pkg-plist.aarch64
-.endif
.if ${TARGETARCH} == "aarch64" || ${TARGETARCH:Marm*}
PLIST+= ${.CURDIR}/pkg-plist.arm
.endif
-.if ${TARGETARCH:Marm*}
-PLIST+= ${.CURDIR}/pkg-plist.arm_gnueabi
-.endif
.if ${TARGETARCH} == "amd64"
-PLIST+= ${.CURDIR}/pkg-plist.amd64
-.endif
-.if ${TARGETARCH} == "amd64" || ${TARGETARCH} == "i386"
PLIST+= ${.CURDIR}/pkg-plist.i386
.endif
-.if ${TARGETARCH:Mmips*}
-PLIST+= ${.CURDIR}/pkg-plist.mips
-.endif
-.if ${TARGETARCH:Mpowerpc64*}
-PLIST+= ${.CURDIR}/pkg-plist.powerpc64
-.elif ${TARGETARCH:Mpowerpc*}
-PLIST+= ${.CURDIR}/pkg-plist.powerpc
-.endif
-.if ${TARGETARCH:Mriscv*}
-PLIST+= ${.CURDIR}/pkg-plist.riscv
-.endif
-.if ${TARGETARCH} == "sparc64"
-PLIST+= ${.CURDIR}/pkg-plist.sparc64
-.endif
post-install:
- @${RM} ${STAGEDIR}${PREFIX}/bin/${GCC_TARGET}-${GCC_TARGET}-*
- @${RM} ${STAGEDIR}${PREFIX}/share/info/*
- @${RM} ${STAGEDIR}${PREFIX}/man/man7/*
- @${RM} -r ${STAGEDIR}${PREFIX}/lib/gcc/${GCC_TARGET}/${PORTVERSION}/include-fixed
+ ${RM} ${STAGEDIR}${PREFIX}/bin/${GCC_TARGET}-${GCC_TARGET}-*
+ ${RM} ${STAGEDIR}${PREFIX}/share/info/*
+ ${RM} ${STAGEDIR}${PREFIX}/man/man7/*
+ ${RM} -r ${STAGEDIR}${PREFIX}/lib/gcc/${GCC_TARGET}/${PORTVERSION}/include-fixed
.if ${TARGETARCH} == "amd64" || ${TARGETARCH} == "i386"
# Conflicts with sys/x86/include/float.h
${RM} ${STAGEDIR}${PREFIX}/lib/gcc/${GCC_TARGET}/${PORTVERSION}/include/float.h
diff --git a/devel/freebsd-gcc9/pkg-descr b/devel/freebsd-gcc9/pkg-descr
index aa16abf61500..505ca21589ce 100644
--- a/devel/freebsd-gcc9/pkg-descr
+++ b/devel/freebsd-gcc9/pkg-descr
@@ -1,2 +1,2 @@
-GCC, the GNU Compiler Collection, supporting C and C++ for building the
-FreeBSD base system.
+GCC, the GNU C/C++ Compiler, customized to build the FreeBSD base system.
+To use GCC for other purposes, please use one of the lang/gcc* packages.
diff --git a/devel/freebsd-gcc9/pkg-plist.riscv b/devel/freebsd-gcc9/pkg-plist.riscv64
index 5f0ba58f0e14..5f0ba58f0e14 100644
--- a/devel/freebsd-gcc9/pkg-plist.riscv
+++ b/devel/freebsd-gcc9/pkg-plist.riscv64