aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2021-05-03 20:47:44 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2021-05-04 23:10:26 +0000
commit5739a98d1d68c09ff0dbb2c4ab29f02a82d16610 (patch)
tree7e53ee9a84122095448f7cb95b673bb785728e5e
parent8152cce6ee37aecd537737139186b370324e22cf (diff)
downloadports-5739a98d1d68c09ff0dbb2c4ab29f02a82d16610.tar.gz
ports-5739a98d1d68c09ff0dbb2c4ab29f02a82d16610.zip
Uses/qmake.mk: fix build WITH_DEBUG
When setting WITH_DEBUG, separate debuginfo was **not** created, although the plists for most Qt5 ports list separate debuginfo. Take a suggestion from rakuco@ and run with it. I rebuilt all the ports with USES=qmake and none had issues with separate debuginfo. No general PORTREVISION bump because the packages in most cases do not change with default options, and WITH_DEBUG would have failed to package anyway. PR: 240494 Reported by: jbeich
-rw-r--r--Mk/Uses/qmake.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/Uses/qmake.mk b/Mk/Uses/qmake.mk
index 471d4fdbc094..1524aed3d95d 100644
--- a/Mk/Uses/qmake.mk
+++ b/Mk/Uses/qmake.mk
@@ -77,7 +77,7 @@ QMAKE_ARGS+= -spec ${QMAKESPEC} \
. if defined(WITH_DEBUG)
PLIST_SUB+= DEBUG=""
-QMAKE_ARGS+= CONFIG+="debug" \
+QMAKE_ARGS+= CONFIG+="debug separate_debug_info" \
CONFIG-="release"
. else
PLIST_SUB+= DEBUG="@comment "